FORUMS: list search recent posts

Adobe Illustrator assertion has failed

COW Forums : Adobe Illustrator

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
amos piazza
Adobe Illustrator assertion has failed
on Jun 23, 2015 at 4:36:41 pm

When I try to save a file in Adobe Illustrator 10 by the "save for web" option and try to save it to a .jpeg file I get the following error

Adobe Illustrator
Could not complete this operation because an assertion has failed

What is causing this? How can I get rid of it?


Return to posts index


haani omar
Re: Adobe Illustrator assertion has failed
on Jun 25, 2015 at 6:40:26 pm

• Save the file to your local (C) drive, which will decrease the potential for issues. Open the file in other versions of Illustrator if possible. Placing the file (using the “File > Place” command) into a blank document may also work, although it may require some minor edits to restore the file to its previous specifications (ungrouping, resizing, re-linking source files or changing color mode).
• Open the file (if possible) and print as a Postscript file by choosing "File > Print," then choose "Adobe Postscript File" as your printer and click "Save." Open the exported PS file in Illustrator.
• Select “Object > Path > Cleanup”, then go to the “Layers Panel” menu and select “Paste Remembers Layers.” Select the artwork and copy, then paste into a new file.
• Launch Adobe Acrobat (any version except Reader) and attempt to open the Illustrator file from within Acrobat. If it opens, make a minor edit using the “Select” tool (if possible). Save as a PDF and an EPS,and export as an EPS by clicking "File > Export > Postscript > Encapsulated Postscript." Open these files in Illustrator, or place them into a blank file if opening fails.
• Eliminate potentially corrupted elements (swatches, brushes, symbols, links, fonts) one at a time and save the file (under another name) to isolate the issue; reinstall the fonts, create outlines, select all elements and convert to process black. Delete all imported elements and custom elements, such as symbols, and remove custom brush strokes.
• Open Illustrator (the same program version that was used to create the corrupt file); save a blank file in the same format (AI or EPS). Close the file and change the extension of both to TXT (not necessary on Mac) and open in a text editor, such as Notepad. Note the point in the corrupt file where the valid data begins: it will be numbers and letters rather than symbols. In the good file, find “%%BeginData” and copy all data before it, then replace the bad data in the bad file. Save, close, and change the file extension back to AI or EPS, and try opening.
• Open the file in Photoshop or place into a new blank page in InDesign. This may enable you to salvage text or critical file elements, which you can export back into Illustrator.
• A final resort is to purchase a third-party program or service that salvages damaged files, for example http://www.ai.openfiletool.com/ AI Open File Tool


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]