FORUMS: list search recent posts

Trouble with SVG export to CAD

COW Forums : Adobe Illustrator

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Rob Brandreth-Gibbs
Trouble with SVG export to CAD
on Jan 25, 2014 at 3:03:50 am

I'm attempting to export an svg file to an entry-level online CAD program called Tinkercad without success. The original artwork was a simple b&w logo built in PS and pasted into Ai. Used the Image Trace program to produce a vector wireframe and then imported into Tinkercad. The result was a 30% partial, haphazard rendition of the wire frame. Looks just fine in Ai, lousy in Tinkercad. Yet I watch others importing their svgs and they go in beautifully including walls and surfaces on their images which mine does not have.

Somewhere I must be doing something not quite right.

And of course the helpful Tinkercad Tech suggests that maybe Ai is leaving gaps in the wireframe (none that I see). And Illustrator techs took over my computer to confirm everything is running as it should.

Any ideas?

RBG

Rob Brandreth-Gibbs
Bravo Zulu Productions
Vancouver, Canada


Return to posts index

Herbert van der wegen
Re: Trouble with SVG export to CAD
on Jan 25, 2014 at 10:11:50 am

Make absolutely certain all your shapes are closed shapes.

Also export to true SVG, avoid Adobe CEF in the SVG export dialog.

I have had no issues importing Illustrator made svg shapes into Tinkercad.

/*----------------------------------------------------*/
System: Win7 64bit - i7 920@3.6Ghz, p6t Deluxe v1, 48gb (6x8gb RipjawsX), ATI 7970 3gb, EVGA 590 3GB, Revodrive X2 240gb, e-mu 1820. Screens: 2 x Samsung s27a850ds 2560x1440, HP 1920x1200 in portrait mode


Return to posts index

Rob Brandreth-Gibbs
Re: Trouble with SVG export to CAD
on Jan 26, 2014 at 6:20:25 am

Your Tinkercad experience is reassuring. My gut tells me I must be doing some simple procedure wrong. But what?

I don't know Illustrator but still I thought I was doing things correctly. I checked a few of the closed shapes on full magnification and they seem perfectly closed, yet maybe half of the trace (without any filled in walls)shows up in Tinkercad. When I export to .svg via "save as", the default svg is checked, not Adobe CEF.

I note that when I simply trace over lines using pen function, those pen marks transfer just fine to Tinkercad and they extrude.

Here is precisely the steps I have been taking and the results I get:

1. In Ai: Open new file: 11x8.5 in. 300 pixels/in. (wonder if tinkercad has maximum, will test smaller)
2. From Photoshop, paste b&w logo graphic, it fills space
3. In Image Trace Panel, Preset = Black & White Logo
"Image Large" warning, may take time: continue with "ok"
4. executes and shows: Threshold = 128, paths 15, anchors = 1842
5. View: Outlines, shows very thin and perfect outline of my logo artwork
6. Check one closed structure on full mag, no gaps
7. Put view back to "tracing Result"
8. File, save copy as, save as type svg(*svg), save
using type=svg, not Adobe CEF
9. Over to Tinkercad
10. Log in
11. Create new design
12. import, file (test.svg)
13. Import
see usual result: a third to half the outlines partially present, no walled structures.

Thanks,
RBG

Rob Brandreth-Gibbs
Bravo Zulu Productions
Vancouver, Canada


Return to posts index


Rob Brandreth-Gibbs
Re: Trouble with SVG export to CAD
on Jan 30, 2014 at 8:24:58 pm

Further to above, I have a diligent Autodesk product manager attempting to help me, so far with partial success. Partial in so far as he tells me:
"There were a lot of overlapping vectors in the SVG. I can still do some more clean up, but it is looking quite good from my side.." (And it does in his Tinkercad screen-save to me.)

He goes on, "The way svg works is the following: when imported into Tinkercad, it tries to find boundaries and extrude them. If it finds islands within the boundaries, it will not extrude them. If there are several boundaries nested, it will extrude every other one. With the amount of overlapping vectors in your file, it was impossible to detect boundaries correctly. Once I removed the overlaps, the file started to work."

Let me restate that the original artwork is very simple: a symbol within two concentric circles.

But what is causing my problems and what is he doing to "clean up" the vectors?

Says my helper: "I was also surprised that there was no clarity in Illustrator around overlaps."

On a hunch, first I pulled out every trick to be found online to get rid of anti-aliasing in my image in case this was the root of my wayward multiple vectors, ending up with a solid artwork with a single mostly black pixel border around the image. Didn't do anything to help. (Also, my background is transparent.)

So left with trying to understand how he is "cleaning up" my image. Of course to me, all I see is a single lovely vector line in Illustrator. How is he seeing multiple vectors?

"I normally first ungroup the vectors, and then start deleting and see if there's something below. There must be a better way, but mine works."

My last communication concerns me trying to understand his clean up procedure.
How do you "ungroup" the vectors? Once ungrouped, how does one delete and see what's below? He is deleting redundant closed vectors (I presume). Of course the final vector diagram must have some closed vectors to extrude properly in Tinkercad.

So if anyone has some insight after the above, please do tell. Especially with regards to how to clean up multiple vectors.

Cheers,
RBG

Rob Brandreth-Gibbs
Bravo Zulu Productions
Vancouver, Canada


Return to posts index


Vincent Rosati
Re: Trouble with SVG export to CAD
on Jan 30, 2014 at 8:45:49 pm

I haven't fully absorbed your thread, so apologies if this is old news. At about step 7, once you're back on the artboard do Object/Expand so you can access the the individual objects.

"Perfecting" a trace can sometimes take more time than just doing a redraw.

When AI creates a B&W trace it has black filled objects, and white filled objects as the negative-space areas.
Efter the expand, you might want to use the Group Select tool, click on one of the whites and Select > Same fill color, than delete.
There's probably also a bounding box that may need to be deleted.

Just some initial thoughts.

Vince

*Please remember to Rate our replies or check Solution if solved. If you get a good idea from the post, consider clicking the Kudos option.


Return to posts index

Rob Brandreth-Gibbs
Re: Trouble with SVG export to CAD
on Jan 31, 2014 at 12:39:43 am

Omg, Vince. The dang thing worked...

I have to fess up and tell you that for the uninitiated such as myself, your instructions seemed a bit like Greek. So I started going through them literally with step-by-step deciphering and experimentation, commenting as I went, fighting to keep my sarcasm under control, because when you click on some of these buttons, there is no obvious immediate action - it's not clear you are having any effect. But the breakthrough was exactly as you indicated: understanding that the totality consists of sub parts - objects, including the white parts, that can be separated out and isolated utilizing buttons in "object" then "select." And key: you then can and should actually delete the white parts. (Why I should be made to do that is fodder for my rant below.) So I am beholden, for I've probably spent a week or two here and there trying to figure this thing out. And like most things, it's easy when you know how.

And now even as thankful as I am, I'm going to leave my little rant below actually written before my attempt above and directed at software developers.

Cheers,
Rob


rant. You know, I'm sure for folks who are familiar with Ai, this is all old hat and Adobe must be very proud of their Ai accomplishment... like Rube Goldberg was very proud of his. Someday, software developers will realize that most of us have lives and are not enamoured with the beauty of their complexity. We just want it to work. And intuitively. ("Expert systems" comes to mind.) Apple is beginning to figure this one out to their great success. I just want to click on my silly little object and have a vector file ready for Tinkercad, because, you know, I'm told Tickercad is sooo easy. (A bit of irony there.) Maybe someday I'll be able to find out. Adobe has saddled me with umpteen new programs I didn't ask for. They better now make them work for me. The world is filled with thousand, millions, of programs. No one has time for a thousand page instruction manual any more. Only intuition. So until that point, we remain in the software Dark Ages. /rant

Rob Brandreth-Gibbs
Bravo Zulu Productions
Vancouver, Canada


Return to posts index


Vincent Rosati
Re: Trouble with SVG export to CAD
on Jan 31, 2014 at 5:48:59 pm

I hear your pain, brother.

Illustrator is a very specialized tool that caters the needs of numerous industries.
I had a similar experience while working with MIDI and FL Studio. FL Studio was the 'specialized tool', and it had capabilities that escape the standards of midi. But it wasn't until the project was complete, and the midi file was being pushed into its purpose that it was discovered that I created a file that violated the standards.
It wasn't a terribly huge deal, but it was extra work.

Anyway, AI is super powerful and can efficiently create complex vectors. Your only other option might be Corel Draw. I haven't used Corel in some time, but if you test it I suspect that its still similar to AI in complexity.

Vince

*Please remember to Rate our replies or check Solution if solved. If you get a good idea from the post, consider clicking the Kudos option.


Return to posts index

Rob Brandreth-Gibbs
Re: Trouble with SVG export to CAD
on Jan 31, 2014 at 7:39:08 pm

I live at the base of a ski mountain where I have a season's pass. As a result, I usually never ski anywhere it's going to cost me. It's that mentality - and shear marketing genius - that now powers Adobe Creative Cloud.

Now let me go all fan-boy for a minute. CC is a new, glorious experience for me whereby my software is constantly up-to-date and tech help is always a phone call away. All for less than the cost of soft drinks for a video shoot. Then again, who needs soft drinks when I have drunk the Kool-aide.

RBG

Rob Brandreth-Gibbs
Bravo Zulu Productions
Vancouver, Canada


Return to posts index


Rob Brandreth-Gibbs
Re: Trouble with SVG export to CAD
on Feb 3, 2014 at 7:21:58 pm

Have to laugh a bit. Though I was successful as above, it wasn't clear afterwards exactly what I had done to make it work. There was a bit of random scrambling with buttons.

My steps were:
1. Build in PS, save a jpeg.
2. Import into Ai.
3. Click on image followed by Window> Image Trace (B&W logo option)
4. Object> Expand
5. Object> Ungroup
6. Select> Object> Point Type Object
7. Seems I needed to first left click twice followed by once on object spaces to be deleted, then delete.
8. Adding the incantation: "Klaatu Barada Nikto" seemed to help.
9. Save as .svg file
10. Import into Tinkercad.


Return to posts index


Herbert van der wegen
Re: Trouble with SVG export to CAD
on Feb 15, 2014 at 7:11:19 am

You are aware you can export svg out of Photoshop now?

http://creativedroplets.com/generate-svg-with-photoshop-cc-beta/

/*----------------------------------------------------*/
System: Win7 64bit - i7 920@3.6Ghz, p6t Deluxe v1, 48gb (6x8gb RipjawsX), ATI 7970 3gb, EVGA 590 3GB, Revodrive X2 240gb, e-mu 1820. Screens: 2 x Samsung s27a850ds 2560x1440, HP 1920x1200 in portrait mode


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]