FORUMS: list search recent posts

Invert A Vector Mask??

COW Forums : Adobe Illustrator

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Jon
Invert A Vector Mask??
by
on Aug 9, 2006 at 11:23:36 pm

Qustion, can I invert a vector mask? I create a closed path. Select the shape I want to mask. Then Layer > Add Vector Mask > Current Path. Viola!! it works, BUT only on the wrong area. i want to mask the outside of the path and not the inside. So yeah can I invert or reverse the vector mask to change the masking area.

thanks in advance!!

(I did a work around with selecting the path, creating a selection, inversing that, then creating a path out of that but it creates wayy wayy to many anchor points and looks like jagged poop, any ideas)


Return to posts index

Kim Mackenzie
Re: Invert A Vector Mask??
on Aug 10, 2006 at 2:13:27 am


You need to create a "doughnut"-esque shape that corresponds to the area you want masked--Pathfinder will do it.

Create a shape that reaches to the outer bounds of the area you want to show (the bounds of your document?).

Then create a second shape which corresponds to the section in the middle that you want hidden (I guess that would be the shape you originally made, that you wanted to "inverse").

Select these two shapes, bring up the Pathfinder palette and hit the button for "Exclude Overlapping Shape Areas" (top right button).

Select your newly pathfinded shape, and the thing(s) you want masked and go to Object>Clipping Mask > Make.

Let me know if you need clarification or it doesn't work.


Return to posts index

Kim Mackenzie
Re: Invert A Vector Mask??
on Aug 10, 2006 at 2:13:27 am


You need to create a "doughnut"-esque shape that corresponds to the area you want masked--Pathfinder will do it.

Create a shape that reaches to the outer bounds of the area you want to show (the bounds of your document?).

Then create a second shape which corresponds to the section in the middle that you want hidden (I guess that would be the shape you originally made, that you wanted to "inverse").

Select these two shapes, bring up the Pathfinder palette and hit the button for "Exclude Overlapping Shape Areas" (top right button).

Select your newly pathfinded shape, and the thing(s) you want masked and go to Object>Clipping Mask > Make.

Let me know if you need clarification or it doesn't work.


Return to posts index


Jon
Re: Invert A Vector Mask in PSHOP??
by
on Aug 11, 2006 at 3:32:17 am

Im sorry guys this is in PSHOP, Thanks for the help Kim. But I believe you're talking about Illustrator??..right :)


Return to posts index

Richard Harrington
Re: Invert A Vector Mask in PSHOP??
on Aug 11, 2006 at 3:42:37 am

Yeah she was....

you can load mask as a selction.... CMD Click thumbnail.... then delete it
Then choose Inverse Selection.... and Add the mask back

They're might be a better way... I prefer using layer masks

Richard M. Harrington, PMP

Author: Photoshop CS for Nonlinear Editors, Understanding Adobe Photoshop, and ATS:iWork


Return to posts index

Kim Mackenzie
Re: Invert A Vector Mask in PSHOP??
on Aug 11, 2006 at 3:17:34 pm


Oops, duh :)

The way I described will more or less work in Photoshop, too.

Make the layer mask active.

Select the Rectangle Shape tool

In the options bar, be sure the Paths button is pushed in, instead of the Shape Layers button (2nd from the left - looks like a rectangular path and a pen). Otherwise, the next step will create a new layer, instead of adding a path to the existing vector mask.

Also in the options bar, make sure Exclude Overlapping Path Areas button is active (the button all the way on the right)

Draw a path that extends to the edges of your document.

That should invert what is hidden/revealed.

k


Return to posts index


Jon
Re: Invert A Vector Mask in PSHOP??
by
on Aug 11, 2006 at 7:18:20 pm

Cools, thanks guys I'll try'em out!


Return to posts index

jimmybee500
Re: Invert A Vector Mask in PSHOP??
on Aug 14, 2006 at 2:16:33 pm

Select the vector mask with the direct select tool, then go to the mask/path/shape options on the top toolbar and select add to shape area/subtract from shape area, etc until it's behaving the way you want.

I usually keep a copy of the layer at the bottom of my palette with it's vector mask intact, incase I need to tweak/edit it later on after I've rasterized it/applied it. Horses for courses though!


Return to posts index

Clifford Sonnentag
Re: Invert A Vector Mask in PSHOP??
on Feb 21, 2009 at 10:09:34 am

You can select the path and chose "add to shape area" or "subtract from shape area" buttons on the tool options menu (cs3) if you are dealing only with a path.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]