FORUMS: list search recent posts

Creating Alpha channels

COW Forums : Adobe Photoshop

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Hubert45
Creating Alpha channels
on Dec 13, 2007 at 12:03:10 am

For the longest time, I would use the wand or lasso to take out the background colors of pictures and logos that clients would give me. I just recently came across the right way to do it (Meyers Creating Motion Graphics with AE Vol. 2) I'm told I need to "copy" the RGB image, create a 4th channel, than "paste" the image into the channel. I'm more of an After Effects guy, so this is probably a stupid question, but how can I copy the RGB image when that option doesn't appear? I can create a 4th channel, but I don't think that's giving me an alpha channel. Thanks for the help.


Return to posts index

Richard Harrington
Re: Creating Alpha channels
on Dec 13, 2007 at 3:38:50 am

Fourth channel in an RGB image is an alpha channel


Suggest you look at the book Photoshop for Video as well as the podcast... we go MUCH deeper into PS than CMG does.








Richard M. Harrington, PMP

Author: Photoshop for Video, Understanding Adobe Photoshop, and ATS:iWork


Return to posts index

Hubert45
Re: Creating Alpha channels
on Dec 13, 2007 at 9:15:47 pm

Thank you so much. Your right CMG doesn't go into detail with Photoshop. After Effects is it's own beast, and I'm just trying to tackle one program at a time. In the future, when I need to sharpen my Photoshop skills, I will definitely order Photoshop for Video. Simple and to the point. Thanks!


Return to posts index


Darby Edelen
Re: Creating Alpha channels
on Dec 26, 2007 at 9:35:15 pm

Just to (potentially) complicate things a bit more, a selection can easily be made into an alpha channel (or vice versa), and in many circumstances it can be helpful to think of a selection, a layer mask or an alpha channel as the same thing (the layer mask and alpha channel 'select' what you see).

Selections are actually treated much the same way as alpha channels internally. This is evidenced when you use Select > Save Selection and get an alpha channel out of the operation. Most of the tools under the Select > Modify menu are identical to filters that can be applied to alpha channels (or layer masks).

Modify > Smooth is the same as the Noise > Median filter applied to an alpha or layer mask.

Modify > Expand is the same as the Other > Maximum filter applied to an alpha or layer mask.

Modify > Contract is the same as the Other > Minimum filter applied to an alpha or layer mask.

Modify > Feather is the same as the Blur > Gaussian Blur filter applied to an alpha or layer mask.

Working from the composite RGB image, or one of the individual color channels, can give you a great head start at getting the right selection you need for your alpha channel, but there's nothing that says you can't start with an arbitrary selection to build your alpha channel. The most important thing to remember is: never use a selection to delete from your RGB channels! Instead use the selection to define a layer mask or alpha channel.

I hope this didn't unnecessarily confuse you too much, but I've found that it's a valuable way to think about selections/alphas.

Darby Edelen
Designer
Left Coast Digital
Santa Cruz, CA


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]