FORUMS: list search recent posts

why's it so impossible to cut out a brush?

COW Forums : Adobe Photoshop

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
zowie repoza
why's it so impossible to cut out a brush?
on Apr 24, 2007 at 8:19:02 pm

Am relatively new to CS2--and I surely love it--but I'm still baffled by how agonizing it is to cut out a brush--particularly from a single-color background.

I have an incredibly complex shape against a black background, and I have to cut it out for use as a brush.

In ImageFX (any ole Miggy users on this list remember ImageFX?), this couldn't be easier. A double-click on the brush cut-out tool enabled it to recognize the background as transparent, and you simply cut a quick square that outlined the entire shape--and ALL the fine details of the brush were separated from the background automatically.

Having to do a Filter/Extract on this brush would be a nightmare--we're talking a complex insect with thousands of hairs.

Have heard there's an alpha trick that can be used to isolate and remove the solid-color background from a picture, but I'm jigged if I can figure out all the steps.

So, hat in hand and with bowed head, I come here to ask advice.

Any clues, o ye mighty ones?

Thanx heaps,
M


Return to posts index

ALbino
Re: why's it so impossible to cut out a brush?
on Apr 24, 2007 at 11:23:50 pm

Just a thought: Magic Wand? Magic Eraser Tool? If the differences in color are significant enough those should work fine I'd think.


Return to posts index

wuzelwazel
Re: why's it so impossible to cut out a brush?
on Apr 25, 2007 at 12:51:49 am

Black is fully transparent in a layer mask, you're working with a black background... does this give you any ideas? =)

The only problem is that there are 255 levels of non-transparent in a mask (dark gray to gray to white) so you'll need to use a levels adjustment to blow out these parts and make them white.

Curious, where did you get this image?


Return to posts index


zowie repoza
Re: why's it so impossible to cut out a brush?
on Apr 25, 2007 at 4:14:36 am

" . . . does this give you any ideas? =)"

Not really. My knowledge of layers comes from how they're treated in ImageFX. Layers in PS have never been clear to me.

Did scour the list before posting this, and I read with interest your response to another query last week about cut-outs, in which you suggested going into the layers pallette and clicking on Channels.

Where you lost me was the part where you said "drag one of the channels down to duplicate it and create an alpha channel."

Perhaps it's that the controls are slightly different on my PC version, but there doesn't seem to be an alpha option--just "Load channel as selection," "Save selection as channel," "Create new channel."

The black box with the white inner circle looks like the proper symbol for an alpha channel with transparent black background and opaque white area--but when I drag to this symbol, I get the "NO" symbol.

So, the subsequent steps of your suggestion were kinda of lost to me.

(Have examined manuals, how-to's published by adobe, and the help file within CS, but nowhere does it tell you PRECISELY how to create an alpha channel from an existing channel--only what great things you can do with one).

"Curious, where did you get this image?"

Created it from a scan of a dried insect, a dragonfly nymph.

Thanx, wuz, for chipping in here.

I'm sure there's a straightforward procedure that I'm just not getting yet.


Return to posts index

wuzelwazel
Re: why's it so impossible to cut out a brush?
on Apr 25, 2007 at 4:25:35 am

[zowie repoza] "Where you lost me was the part where you said "drag one of the channels down to duplicate it and create an alpha channel.""

That's because it's one of those less exciting rarely touted features (;

You already found the button you need to use, but PS doesn't explicitly tell you that you can use it to duplicate a channel as an alpha channel.

Try dragging one of the channels, preferably whichever one has more contrast between the foreground and background, onto the 'Create new channel' button. This will duplicate the channel. Once you're working with that channel you can use any adjustments or filters available in PS (in grayscale) on that Alpha Channel.

Once you've got that Alpha looking good you can use the 'Load Channel as Selection' button or ctrl/cmd click the channel thumbnail. Then using this selection go back to your original layer and use Layer > Layer Mask > Reveal Selection.

Good luck! =)



Return to posts index

zowie repoza
Re: why's it so impossible to cut out a brush?
on Apr 25, 2007 at 4:59:48 am

[wuzelwazel] "Try dragging one of the channels, preferably whichever one has more contrast between the foreground and background, onto the 'Create new channel' button. This will duplicate the channel. Once you're working with that channel you can use any adjustments or filters available in PS (in grayscale) on that Alpha Channel.

Once you've got that Alpha looking good you can use the 'Load Channel as Selection' button or ctrl/cmd click the channel thumbnail. Then using this selection go back to your original layer and use Layer > Layer Mask > Reveal Selection."


Aha, now we're cookin'. Turns out, I was doing it correctly--but it's at your second paragraph that I'm cut off.

I get the "alpha" looking good (VERY white and VERY black)--but when I Load Channel as Selection and go up into the menu bar and pull down the Layer options, "Layer Mask" is ghosted.

(This was happening when I tried this before; it's what made me think that this new channel I'd duplicated/created was NOT an alpha channel).

I'm really grateful for your help with this, wuz.


Return to posts index


wuzelwazel
Re: why's it so impossible to cut out a brush?
on Apr 25, 2007 at 4:53:59 pm

[zowie repoza] "
I get the "alpha" looking good (VERY white and VERY black)--but when I Load Channel as Selection and go up into the menu bar and pull down the Layer options, "Layer Mask" is ghosted."


It sounds like you haven't switched back to your original layer. Photoshop is going to apply a Layer Mask to whatever layer you have selected, and it can't apply a Layer Mask to an alpha channel. Make sure that after you have your selection you go back to the Layers palette and select your original layer.

Also, note that you can make changes to the Layer Mask after you've applied it. If you alt-click on the Layer Mask thumbnail (to the right of the Layer's thumbnail) you can view the Layer Mask, make adjustments, blur, whatever else. Note that you don't have to alt-click the Layer Mask to do this, you can just select it in the Layer Palette, but it helps me to know what I'm working with (the Layer Mask instead of the Layer).

You'll probably find that there's some fringing around your masked layer. A good tool to work with is the Filter > Other > Minimum, this is effectively like a matte choker that will collapse your mask down some (Maximum is the reverse). I don't recommend using a setting higher than 1 or 2 though. Also you can use a Gaussian Blur to feather the edges some and then a Levels adjustment to subtly redefine the edges.

Also, when you're making the final changes to the mask, it helps to look at the layer instead of the mask.


Return to posts index

zowie repoza
Re: why's it so impossible to cut out a brush?
on Apr 25, 2007 at 5:55:03 pm

[wuzelwazel] "It sounds like you haven't switched back to your original layer. Photoshop is going to apply a Layer Mask to whatever layer you have selected, and it can't apply a Layer Mask to an alpha channel. Make sure that after you have your selection you go back to the Layers palette and select your original layer."

Can't seem to do this. Clicking, double-clicking--nothing seems to "select" the original layer. Only clue I have is that there's a "locked" icon to the right of the original layer's name.

This is a mystery to me, as I certainly never intentionally "locked" the original layer--nor do I seem to be able to unlock it.

Just as an experiment, I deleted the current project and tried loading in other images, in all formats. They ALL come in "locked."

As said, wuz, I'm grateful for your thoughtful help. I'm cutting and pasting all your responses into a text document which I'll be saving in my Pshop helps/tutes folder.


Return to posts index

wuzelwazel
Re: why's it so impossible to cut out a brush?
on Apr 25, 2007 at 7:00:40 pm

[zowie repoza] "This is a mystery to me, as I certainly never intentionally "locked" the original layer--nor do I seem to be able to unlock it."

Ah yes, the lock... I'm not sure if there's a more elegant way around it, but I usually just duplicate the locked layer, it'll show up as an editable layer.


Return to posts index


zowie repoza
Re: why's it so impossible to cut out a brush?
on Apr 25, 2007 at 8:12:12 pm

This is hot. I'm so excited. (I'll never fear a "locked" layer again).

With only a slight variation on your theme (Hide Selection, rather than Reveal Selection, in the Layer Mask options), I have an excellent brush object of my ghastly insect.

When I have something fit to show, I'll send a link.

Thanx a meg, wuz. This has been an education.

Best,
M


Return to posts index

zowie repoza
Re: why's it so impossible to cut out a brush?
on Apr 25, 2007 at 9:26:52 pm

You see my brush still needs some serious work--but it's a start:

http://www.efn.org/~mikemcoo/dragonflyNymph.html

Again wuz, thanx heaps,
M


Return to posts index

wuzelwazel
Re: why's it so impossible to cut out a brush?
on Apr 25, 2007 at 10:25:33 pm

Sure, happy to help =)


Return to posts index


Boyd Hawkins
Re: why's it so impossible to cut out a brush?
on May 7, 2007 at 11:32:39 pm

"Once you've got that Alpha looking good you can use the 'Load Channel as Selection' button or ctrl/cmd click the channel thumbnail. Then using this selection go back to your original layer and use Layer > Layer Mask > Reveal Selection."


I am trying to extract a person from a solid background and the hair is either not getting extracted, or some of the background is left between the strands of hair. I think the procedure you described here will will work for me, but I am new to PS and not sure what to do. I have created the duplicate channel, but I am not sure what to do now. What do you mean by getting the Alpha looking good? What do I need to do to it?

If there is another solution for what I am trying to do, please let me know. Thank, Boyd.


Return to posts index

zowie repoza
Re: why's it so impossible to cut out a brush?
on May 8, 2007 at 1:21:07 am

OK, the alpha channel is what you're going to use to cut your person out from the background, so, by looking good, wuzel meant the alpha channel needs to be as starkly black and starkly white as you can make it.

When you select the red channel that you just duplicated as an alpha, you'll see that it's now a black and white version of your original pic.

Go into Image/Adjustments/Levels, and you'll get a window with a graph in the center that looks roughly like the cross section of a mountain range. Under it are three adjustment sliders, black on the left, grey in the center and white on the right.

Slide the white adjustment button to the left till the lighter areas in the picture become stark white, then slide the grey adjustment button to the right till the dark areas of the pic become stark black.

Now, once the alpha image is almost completely black and completely white (with no grey areas), click and drag this image to the bottom of the channels palette to the left most option icon, "load channel as selection."

On the PC this can also be done by control/clicking the channel.

Go back into the layers palette, and, if your background image (the original image) is not "locked," go into the pulldown Layers menu and choose Layer Mask/Hide Selection.

(If the background image is "locked," you'll see a little padlock icon on the right in its description, so just duplicate the layer to get an unlocked version, then be sure to delete the original layer, then procede as above).

All the background of the image should be removed, leaving just your figure in the foreground.

Hair is always tricky, so you'll have to try several versions of your black'n white alpha layer as a mask to cut away only what you need from the background of the image.


Return to posts index

Boyd Hawkins
Re: why's it so impossible to cut out a brush?
on May 8, 2007 at 2:48:11 am

Thanks! I got very close to what I wanted. There is a little of the background residue in the hair. Any suggestion on how to get rid of that? Thanks for clearing it up for me.

For anyone interested, here is a a site that also helped out a bit.

http://www.planetphotoshop.com/select-hair-by-using-channels.html


Return to posts index


Darby Edelen (wuzelwazel)
Re: why's it so impossible to cut out a brush?
on May 9, 2007 at 5:32:47 pm

The ideal layer mask will have pure white in areas you want to maintain, pure black in areas you don't and a small gradient running from white to black (mostly gray) at the edges (those small areas that are the boundaries between the black and the white).

During this whole process its important to remember you can use any filter/adjustment on a layer mask (as long as you have the layer mask and not the layer selected!) and that in a layer mask black = transparent, white = opaque, gray = semi-transparent.

First things first, it is often desirable to mask hair and other wispy elements separately from the body. So duplicate your layer and name the new duplicate something like 'Hair' and your old one 'Body.' Now hide your 'Body' layer so you're just working with 'Hair.'

You can look at Hair's layer mask by opt/alt clicking the mask thumbnail in your layers palette. If the edges are too hard and well defined, make sure that you have the layer mask (not the layer) selected and you can use a subtle gaussian blur to feather the edges some.

Alt/opt click on the layer mask again to see what your layer is looking like.

Make sure you still have the layer mask (and not the layer) selected and you can use a levels adjustment on it to either expand or contract the white area of the mask (if you decrease your white input, the arrow on the right, it will expand, if you increase your black input, the arrow on the left, it will contract). If you have background color in your hair then you will likely want to contract the white areas of the mask.

You can do this a few times (blurring then adjusting with levels) until you have something that you like.

Once you have 'Hair' looking good you need to hide the portion of the body that is still showing (we want 'Hair' to have the hair and 'Body' to have the body), you can do this by painting with black in the layer mask (this will hide anything you paint on). Make sure you have the layer mask selected and use your brush tool with black as the foreground color to paint over the majority of the body. Leave all of the hair and the parts where the hair meet the head visible in the 'Hair' layer.

Now go back to your 'Body' layer and paint the hair areas of the layer mask black (hiding the messy hair with the background color in it). You only need to paint the layer mask in areas where you can see the background color showing through the hair here, if you accidentally paint too far in and part of the head disappears you can use your brush with a white foreground color to paint it back (or ctrl-z to undo).

I hope this wasn't too much information to handle, if I didn't give you enough detail in certain parts please let me know!

Darby Edelen
DVD Menu Artist
Left Coast Digital
Aptos, CA


Return to posts index

Boyd Hawkins
Re: why's it so impossible to cut out a brush?
on May 10, 2007 at 4:55:13 pm

Thanks Darby and Zowie for all the advice! I can tell this will work, but it will just take a lot of trial and error. I think that my first mistake was taking the picture on a light blue background instead of a white one.

Does using a green screen work in Photoshop like it does in video production? If so, I could not find the filter for it....please advise.

Thanks again!

Boyd


Return to posts index

zowie repoza
Re: why's it so impossible to cut out a brush?
on May 14, 2007 at 4:26:31 pm

[Boyd Hawkins] "Does using a green screen work in Photoshop like it does in video production? If so, I could not find the filter for it....please advise."

There may be color and luminance keying options in CS2--but I ain't found them yet.

When I have solid color background in a shot and need to isolate foreground elements, I've found that the keying functions of AfterEffects work pretty well.



Return to posts index


zowie repoza
Re: why's it so impossible to cut out a brush?
on May 14, 2007 at 4:22:54 pm

This is a great tute, Darby. Thanx, for posting in such detail.

Definitely a keeper.

Best,
M


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]