FORUMS: list search recent posts

Photoshop not recognizing alpha channel from After Effects still frame export.

COW Forums : Adobe Photoshop

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Zak Stoltz
Photoshop not recognizing alpha channel from After Effects still frame export.
on Jun 8, 2012 at 8:19:34 pm

Just like it sounds. I have an image with a transparent BG in AE that I want to be able to open in Photoshop. I go to Composition>Save Frame As then choose a PSD with transparency. It exports fine. The alpha channel shows up when I do quicklook on the Mac. It shows up in Preview. I have transparency when I import it into Final Cut. I have transparency when I bring it back into After Effects. But when I try to open it up in Photoshop, it has a black background. I have also tried a TIFF with transparency, but that doesn't work either.

Anyone know what's happening here? Am I missing something important?


Return to posts index

Jeff Hinkle
Re: Photoshop not recognizing alpha channel from After Effects still frame export.
on Jun 8, 2012 at 9:22:00 pm

Check your Channels palette and see if the alpha channel is in there. If it is, just Command-click its thumbnail to make a selection of it and then you can make a layer matte out of that. That should get you your transparency back.


Return to posts index

Zak Stoltz
Re: Photoshop not recognizing alpha channel from After Effects still frame export.
on Jun 8, 2012 at 9:55:19 pm

Thanks for the suggestion. Unfortunately that only works halfway. I get the outline transparency back, but some of the semi-transparent colorized areas get knocked out. I might not be creating the mask correctly, but the real problem is that I can't just open up this image that's supposed to have transparency built into it.


Return to posts index


Jeff Hinkle
Re: Photoshop not recognizing alpha channel from After Effects still frame export.
on Jun 8, 2012 at 10:06:11 pm

Have you tried Composition>Save Frame As>Photoshop Layers instead of Save Frame As>File...? I just gave that a try on a few projects and they popped open with transparency built in.


Return to posts index

Zak Stoltz
Re: Photoshop not recognizing alpha channel from After Effects still frame export.
on Jun 9, 2012 at 1:28:18 am

I did try that, but it's the same problem. Here's some screen grabs of what it looks like in AE versus what it looks like in Photoshop when I try to export as layers:

http://imgur.com/a/S6CIN

Photoshop on top.
AE on the bottom.

It's not the biggest difference, but it's enough to be annoying and unusable for certain applications.


Return to posts index

Rob Hebert
Re: Photoshop not recognizing alpha channel from After Effects still frame export.
on Jul 7, 2014 at 4:46:47 pm

Even though this thread is 2 years old and you probably have already moved on from this project, I found out how to do this. I was having the same problem with having text in AE and not being able to export it out so the PS could see the alpha channel. Here's what I did to fix it:

1) Have image or text how you want it
2) Add a new solid below everything
3) Composition > Save Frame As > Photoshop Layers
4) Render

I then opened the PSD file in PS and deleted the solid layer. Hope this helps in the future.


Return to posts index


Zak Stoltz
Re: Photoshop not recognizing alpha channel from After Effects still frame export.
on Jul 7, 2014 at 5:48:59 pm

Thanks Rob! I had totally forgotten about this. Thanks for coming up with the solution, though now that I'm running Adobe CC, I can't seem to replicate the problem! :-P


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]