FORUMS: list search recent posts

Laging in preview-mode even with 4K Computer!

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Sep Nolia
Laging in preview-mode even with 4K Computer!
on Nov 1, 2015 at 8:41:27 pm

Hello guys!

My old computer coudln't handle full HD/4K videos so I had to buy a new computer for editing 4K videos without any problems in the preview-window.
It took me a long time to decide which hardware I have to buy to edit 4k Videos in the without any problems.

My new system:
-I7 5820 3.3Ghz 6 Core (not overclocked)
-Firepro W8100 GPU
-32 GB DDR 4 2666 MHz
-M.2 Samsung SSD

I really need help ... I payed much money for this build and I can't believe that there is only a small difference between my old computer and my new one!

Thank you!


Return to posts index

Wayne Waag
Re: Laging in preview-mode even with 4K Computer!
on Nov 2, 2015 at 12:25:31 am

If preview performance is that important to you, then use a proxy. Vegas has an option to automatically create proxies for 4K source material. You could also use Vegasaur or just create your own using a format that previews well on your system.

wwaag


Return to posts index

Sep Nolia
Re: Laging in preview-mode even with 4K Computer!
on Nov 2, 2015 at 1:03:17 am
Last Edited By Sep Nolia on Nov 2, 2015 at 1:04:18 am

Thank you Wayne Waag for your reply!

But I don't know any of these methods.
I'm using the germany Vegas, maybe that's why I don't know these methods.
Can you try to explain me what "proxy/vegasaur" is?
Any advantages/disadvantages using them?

"just create your own using a format that previews well on your system."
What do you mean?


Return to posts index


Wayne Waag
Re: Laging in preview-mode even with 4K Computer!
on Nov 2, 2015 at 2:23:01 am

A proxy is simply a copy of your original source material, but rendered at a lower resolution. For example, you can create an HD proxy (1920x1080) from your original 4K (3840x2160) files. Your computer can preview the HD proxy much better than the original 4K files. Once the proxy is created, you replace the original 4K file with the HD proxy file and do your editing. Once finished with editing, you simply replace the proxy file with the original 4K footage and do your render.

This can be done automatically inside of Vegas. From your project window, select your 4K files, right-click, and select Create Video Proxy. Once your proxy files are created, Vegas will use the proxy files if you preview using the Draft or Preview settings. If you use Good or Best, it will use the original material. For renders, it will use the original 4K material. The good thing about using the Vegas proxy builder is that it is all automatic.

Vegasaur is a script application for Vegas. http://vegasaur.com/ It is an extremely useful add-on that includes a proxy-builder. While Vegas is completely automatic, Vegasaur allows you to select whatever render template you want to use for your proxy. Of the two, my preference is to use Vegasaur because of its ability to allow you to choose the template you want. You can even create your own render template inside of Vegas and then use it when building proxies using Vegasaur.

By creating your own, I mean that you can render your 4K file to an intermediate that will preview well on your system, for example using one of the XDCAM EX templates. Once rendered, you can manually replace your 4K files with the XDCAM EX files and do your editing. Once editing is completed, you would manually replace the proxy files with the original 4K files. It's the same principle, except that you do the changing from original to proxy by manually replacing the files inside of Vegas. Nothing is done automatically.

Hope this brief explanation will be of use to you. Perhaps someone who is currently using proxies for 4K projects will chime in with their recommendations.

wwaag


Return to posts index

Sep Nolia
Re: Laging in preview-mode even with 4K Computer!
on Nov 2, 2015 at 10:06:15 am

Wow thanks so much!
I'll try to do the proxy one.

But I still don't understand why I have to lag with this build.
I noticed that my CPU almost reach 100%, while previewing a 1080P 60 FPS Video without any effects or other videos.

http://www.directupload.net/file/d/4159/y9zrki4v_png.htm


Return to posts index

Wayne Waag
Re: Laging in preview-mode even with 4K Computer!
on Nov 2, 2015 at 4:09:12 pm

I noticed that my CPU almost reach 100%, while previewing a 1080P 60 FPS Video without any effects or other videos.

That is definitely not right. I have an old i7-3770K that's overclocked a bit (4.2 Ghz) and a very weak video card (Nvidia 650) and it previews 1080 60P video on a second monitor at Best full without dropping frames with CPU at less than 50%. My suspicion is that your video card is not set up properly. I would check to see if the latest drivers are installed. Unfortunately, I'm no hardware expert. Hopefully, someone else can provided some assistance.

wwaag


Return to posts index


Aaron Star
Re: Laging in preview-mode even with 4K Computer!
on Nov 2, 2015 at 5:25:08 pm

What codec and file format is your source footage?

What camera is it from?

What is your workflow? Meaning are you dropping camera original on the timeline and rendering to mp4 to upload to YouTube or something else?

What is your display destination for your edited material?

What codec are you rendering to for the final?

Have you used "AMD system monitor" or GPU-z to verify that the GPU is being used during timeline playback? Is the GPU enabled under preferences? Is your GPU running the latest AMD driver?

What are your current project settings?


Have you tried converting your UHD footage to XAVC-I.mxf, and not using LGOP format the camera likely shoots in?

For HD material, have you tried XDCAM-ex, or 422, or HDCAM-SR-Lite 60P, or Cineform.AVI?


System Things to check:
  • Latest Video Driver from AMD
  • Latest BIOS from motherboard manufacturer
  • Latest Motherboard Chipset INF from Intel for your given chipset.
  • Latest Network & Sound from chipset manufacturers
  • All updates applied from MS, and non waiting to complete on system reboot


Return to posts index

Sep Nolia
Re: Laging in preview-mode even with 4K Computer!
on Nov 2, 2015 at 6:49:19 pm

What codec and file format is your source footage?
-MP4

What camera is it from?
-Go Pro Hero Black 4

What is your workflow?
What is your display destination for your edited material?
What codec are you rendering to for the final?
Well I just put the 1080P 60 FPS file into the timeline and the preview-windows starts laging if I want to preview the video-file on "Best-Full", even without any effects.

Have you used "AMD system monitor" or GPU-z to verify that the GPU is being used during timeline playback? Is the GPU enabled under preferences? Is your GPU running the latest AMD driver?
I don't know why but I think that my CPU is the only thing that is running for the preview-mode.
http://www.directupload.net/file/d/4159/sqyf4phc_png.htm
http://www.directupload.net/file/d/4159/9t7nflft_png.htm

And yes I think that I downloaded the latest driver for the GPU
I have chosen the "W8100" driver.
http://support.amd.com/de-de/download/workstation?os=Windows%207%20-%2064#c...

What are your current project settings?
A picture of it:
http://www.directupload.net/file/d/4159/7fkr8jdr_png.htm


Return to posts index

Wayne Waag
Re: Laging in preview-mode even with 4K Computer!
on Nov 2, 2015 at 7:19:07 pm

What camera is it from?
-Go Pro Hero Black 4


Are you running the latest version of Vegas, 4.53? There was a fix for GoPro footage on this release.

wwaag


Return to posts index


Wayne Waag
Re: Laging in preview-mode even with 4K Computer!
on Nov 2, 2015 at 7:28:28 pm

What are your current project settings?
A picture of it:


Your project settings are part of the problem. GoPro 1080 60P footage is progressive, not interlaced. Moreover, you are using NTSC settings. Presumably, you are in PAL land? In any case, make sure that your project settings are the same as your GoPro footage.

wwaag


Return to posts index

Aaron Star
Re: Laging in preview-mode even with 4K Computer!
on Nov 2, 2015 at 7:48:07 pm
Last Edited By Aaron Star on Nov 2, 2015 at 8:03:08 pm

Well the temps look good during render, I do not see much of an issue there.

In Vegas, make sure your GPU is selected under Options>Preferences> Video> GPU acceleration. Restart Vegas if it was not selected.

You might try posting some images from GPU-z : http://www.techpowerup.com/downloads/2524/techpowerup-gpu-z-v0-8-5/

On the sensor tab of GPU-z, you can monitor GPU utilization during playback. Try this with a simple straight up file, and then one with Sony Min and Max filter applied. With Min/Max applied you should see some heavy GPU utilization.

One the 1st page of GPU-z if you roll over the "Bus Interface" field, you should get a popup that shows your GPU interface speed. This should read max speed.


An alternate is AMD System Monitor: http://support.amd.com/en-us/kb-articles/Pages/AMDSystemMonitor.aspx

This app provides a Task Manger like view of CPU+GPU utilization during playback.


I personally like Speccy - If you could post a .speccy file, that gives a lot more comprehensive view of the system config. File > Save Snapshot.
In Speccy - you can verify memory settings, Storage interface connection standards, Heat, see details on drivers loaded, and motherboard specifics.



If you are trying to create 1080-60P material, your project settings frame rate should be 1920x1080-59.94 Progressive. You can use the Match media Icon Button in the upper right corner to match your project to the source material.

There have been other posts on Hero 4 footage issues. For HD most like to convert the footage to Cinform.avi using the Hero app, then edit the resulting files. Converting to HDCAM-SR-Lite, or XDCAM-EX.MXF would be another Vegas optimized way of editing that content. Since the Vegas render profiles are dated, you will need to create your own 60P profiles by changing the Frame rate to 59.94.

For the 4K hero footage in Vegas, converting your footage to Sony XAVC-intra.mxf Same here for the render profiles and 59.94/60P if you do not have one that matches.


8-Bit mode vs 32-bit Video Levels in project settings - for smoothest playback stay in 8-bit mode. 32-bit video levels for converting 10-bit video formats to 10-bit capable codecs (HDCAM, Cineform, XAVC-I.) Also most believe you should color correct in 32-bit VL mode. However, if do not have a deep color / wide gamut monitor attached properly, your display is just previewing in 8-bit color mode.

The w8100 is 30-bit/10-bit video capable, but does require proper monitor and cabling. Obviously you will not see 10-bit video levels while previewing in 8-bit playback mode.


***Note on 60P material - most people posting render times are doing so for 24-30P material. Rendering 60i or 60P is rendering 2x the amount of frames so render times will need to be correlated to like for like. 2x the amount of time to render 2x the amount of frames is logical.


Return to posts index

Sep Nolia
Re: Laging in preview-mode even with 4K Computer!
on Nov 2, 2015 at 10:33:26 pm

Thank you all for the answers!
But I can't test your ideas anymore ... =/

Someone suggested me to update my BIOS to solve this problem.
I downloaded the latest BIOS-Driver for my asus x99-a mainboard and installed it.
I had to wait a few secs and when it was done it restarted the computer.
Afterwards I had no screen and the LED thing on my mainboard turned to "99".

It's broken now =/

I have to send the mainboard back ...


Return to posts index


Aaron Star
Re: Laging in preview-mode even with 4K Computer!
on Nov 2, 2015 at 10:44:12 pm

wow that sucks man. Bios is normally a pretty easy to upgrade, what with manufacturer update apps and stuff now. Might be for the best, if you installed the correct BIOS, maybe there was something else wrong with the board if it failed.

Post again when you get back up, would like to know how things turn out.


Return to posts index

Wayne Waag
Re: Laging in preview-mode even with 4K Computer!
on Nov 2, 2015 at 11:00:25 pm

That's really terrible. What a bummer! Hopefully, you still have your old system to carry on till you get the new one up and running again. Good luck.

wwaag


Return to posts index

Sep Nolia
Re: Laging in preview-mode even with 4K Computer!
on Nov 2, 2015 at 11:06:50 pm

Thank you guys really!

Well yea that scks much =/
I hope they will send me the new mainboard as soon as possible.


Return to posts index


Sep Nolia
Re: Laging in preview-mode even with 4K Computer!
on Nov 10, 2015 at 5:10:19 pm

Hello my dear internet friends!

I have finally recived my new motherboard .. I had so much trouble with the company getting a new one...
At first they send me my old one back so I had to wait another week to get the new one.
Whatever at least I got it now! :)

@Wayne Waag & Aaron Star
"In any case, make sure that your project settings are the same as your GoPro footage."
"If you are trying to create 1080-60P material, your project settings frame rate should be 1920x1080-59.94 Progressive. You can use the Match media Icon Button in the upper right corner to match your project to the source material."

http://www.directupload.net/file/d/4167/u8g2m4ea_png.htm
Thank You!
After I have clicked on yes it doesn't lag anymore if I want to preview the video in vegas on "Best-full"
(CPU on 15%)

But it starts lagging again if I put just one effect inside the video =/
For example the "Glitzen effect" It even lags on "Draft-Quarter" (CPU almost on 100% again, even on draft-quarter)


@Aaron Star
"make sure your GPU is selected under Options>Preferences"
-It is selected.


Here are some GPU-Z pictures:
-http://www.directupload.net/file/d/4167/egckzl35_png.htm (Graphic-card first tab)
-http://www.directupload.net/file/d/4167/g72i82wu_png.htm (Render test)
-http://www.directupload.net/file/d/4167/ddqhhqfw_png.htm (Bus Interface ... It says the graphiccard is on PCI-Express x4 v.1.1 right now. Maybe that's the whole Problem !? I don't have much experience about Hardware. I don't know what it means)


-http://www.directupload.net/file/d/4167/vgsu9d23_png.htm (this is what I get on "best-full" without "glitzer effect")
-http://www.directupload.net/file/d/4167/qx974tbo_png.htm (this is what I get on "draft-quarter"without "glitzer effect")
-http://www.directupload.net/file/d/4167/y45chgj9_png.htm (this is what I get on "draft-quarter" with glitzer-effect) The values of these 3 aren't changing just the red-bar. Maybe I forgot to click on something to start the process?

-------------------------------------------
Here are the speccy-pictures:
M.2 SSD: http://www.directupload.net/file/d/4167/jsstwkkk_png.htm
DDR 4 2666 Ram: http://www.directupload.net/file/d/4167/3renuzgu_png.htm (weird .. it just shows 1333mhz frequenzy instead of 2666 mhz)
graphic card: http://www.directupload.net/file/d/4167/8k28rnyo_png.htm
motherboard: http://www.directupload.net/file/d/4167/4fdy56ac_png.htm


Return to posts index

Aaron Star
Re: Laging in preview-mode even with 4K Computer!
on Nov 10, 2015 at 8:48:45 pm

My question on the x16 GPU issue. Is the GPU installed in the PCIe slot closest to your CPU, or is it installed in the slot furthest away from the CPU. The 2 slots nearest the CPU should be x16 capable on an x99 board, meaning you should be able to run dual GPUs at full speed.

Could you post a photo of how you have your boards installed into the motherboard? Board placement for accessory boards is sort of important, so that you do not impede the GPU bandwidth.

x4 v1.1 is like 1GB/s when you should be getting 16GB/s through to the board.


Return to posts index

Sep Nolia
Re: Laging in preview-mode even with 4K Computer!
on Nov 10, 2015 at 9:06:06 pm

Yes it is installed in the PCie slot closses to the CPU.

http://www.bilder-upload.eu/show.php?file=d1009a-1447190121.jpg
http://www.bilder-upload.eu/show.php?file=cff6bd-1447190084.jpg
http://www.bilder-upload.eu/show.php?file=a3422e-1447190118.jpg
http://www.bilder-upload.eu/show.php?file=c889fc-1447190123.jpg
http://www.bilder-upload.eu/show.php?file=96d154-1447190061.jpg
(You have to zoom out to see the whole picture)
I connected all my fans on the mainboard instead to the powersuply. Maybe that's the problem.

by the way look at this.
I just noticed this in my bios.
http://www.directupload.net/file/d/4167/ar8449bh_jpg.htm
http://www.directupload.net/file/d/4167/44jz7pzg_jpg.htm
It says "NO VGA Card". =/


Return to posts index

Aaron Star
Re: Laging in preview-mode even with 4K Computer!
on Nov 10, 2015 at 9:31:41 pm
Last Edited By Aaron Star on Nov 10, 2015 at 9:41:15 pm

Since you have no other boards installed, you may need to contact ASUS and ask them what that means. It could also be a bug in GPU-z not correctly understanding the x99 board. It's hard to say what the issues really is. Have you check the motherboard manual for that X4 or Auto settings? I would think AUTO would work with such new hardware on both the MB and GPU.

I also have to correct my multi GPU statement. Depending on the 59xx series CPU you have, you may be able to run 2x GPUs at 16x speed. If you have the 59xx series CPU with only 28 lanes, obviously you can run only 1 GPU at 16 lanes speed. This should not really factor into what we are troubleshooting because you only have one card.


Return to posts index

Sep Nolia
Re: Laging in preview-mode even with 4K Computer!
on Nov 10, 2015 at 9:41:56 pm

"Have you check the motherboard manual for that X4 or Auto settings? I would think AUTO would work with such new hardware on both the MB and GPU."
I can't find anything about it it the manual.

But if I want to change to X4 in the BIOS.
It says:
[Auto:] Disable PCIEX16_4 Slot when a M.2 device is detected.
[X4 Mode]: Run at X4 mode for high performance support with m.2 Disabled.

And If I do this I can't boot to Win 7 anymore. It won't regocnize the M.2 in X4 Mode


Return to posts index

Sep Nolia
Re: Laging in preview-mode even with 4K Computer!
on Nov 10, 2015 at 10:44:20 pm

Do you think this graphic-card (pci-express) problem causes my lags?


Return to posts index

Aaron Star
Re: Laging in preview-mode even with 4K Computer!
on Nov 11, 2015 at 3:03:18 am

Read the expansion slots section in the manual, page 8. Clearly you need to keep the M2 enabled. The GPU needs to go in a non shared full bandwidth slot. The slots are marked on the board. The devil is in the details of the ** notes. The diagram on page 1-13 and 1-14 could help as well.

Due to the way they have implemented the M2, that slot shares bandwidth/pci lanes on the cpu side. You need to determine the slot that maintains full bandwidth when things like the M2 and USB 3. Supposedly slot pci16_1 one does this, but there is still something that is not right.

In bios look for advanced, then check the following:

DMI - gen 2.0 should be disabled.

NB PCIE Configuration - pcie16_1 should be Gen3, not auto. Per documentation on page 3-38. Auto for other pcie slots on the board.


I do not believe the x16 issue will solve all playback performance issues, especially if you drop a compute heavy plugins on a clip. For optimization reasons, you want to max the bandwidth from the memory/cpu to the gpu memory/gpu for the best opencl performance and playback.


Return to posts index

Sep Nolia
Re: Laging in preview-mode even with 4K Computer!
on Nov 11, 2015 at 10:47:20 am

DMI - gen 2.0 should be disabled.
-DMI gen 2.0 was enabled I switched it to disabled.

NB PCIE Configuration - pcie16_1 should be Gen3, not auto.
-pcie16_1 was on auto I switched it to Gen3.

But still nothing changed.
GPU-Z still shows the same thing.


Return to posts index

Sep Nolia
Re: Laging in preview-mode even with 4K Computer!
on Nov 11, 2015 at 11:33:05 am

Omg! This is really really weird ... haha Finally!
Look at this! I changed the slot to one below and it got recognized in the BIOS.
http://www.directupload.net/file/d/4168/34phcsp7_jpg.htm
Afterwards I went to Win 7 installed the latest driver for it but I still had not the full performance.

I put the graphic card back to the first slot and it got recognized!
I checked GPU-Z and these are the results. :)

http://www.directupload.net/file/d/4168/a7vx5s8n_png.htm (x16 v1.1)
http://www.directupload.net/file/d/4168/nnbcqmr7_png.htm (x16 v.3.0 while rendering)

But still having my stupid lag issue. =(
At least I'm having a good mind that I don't have any hardware-problems.
Well I think so ... but maybe my CPU has some problems !?


Return to posts index

Aaron Star
Re: Laging in preview-mode even with 4K Computer!
on Nov 12, 2015 at 2:38:58 am

GoPro as far as I know just records in h.264 at 60Mbs. I would think your system would decode even that high of a bitrate just fine. I would try using vegas to convert the gopro original file to Cinform.avi, HDCAM-SR-Lite.MXF, XDCAM-EX.MXF, or XAVC-intra.MXF. Try the playback of one of those formats and let us know if the playback is better.

Since the Vegas render profiles are dated, you will need to create your own 60P profiles by changing the Frame rate to 59.94.


Return to posts index

Sep Nolia
Re: Laging in preview-mode even with 4K Computer!
on Nov 12, 2015 at 3:01:33 pm

Wow I can't believe it! Seriously FINALLY!
It took so long to solve this Problem.
I never knew, that there are effects that are based on CPU and effects that are based on GPU.
I was using effects for the CPU all the time. That's why I coudln't see huge differences compared to my old computer.
It's still weird why It reaches almost 100% but since I noticed this Folder:
http://www.directupload.net/file/d/4170/cc7s4qut_png.htm
I can put tons of effects in the video and it doesn't lag.

Thank you so much Aaron & Wayne for your help!!!
Thank you for all these information! And I also solved my graphic-card PCIexpress 16 v.3.0 problem with your help!

But I sitll have a question.
What should I do if I want to use 2 different video-files at the same time?
For example a gopro 1080P 60 frames video and a 4K 24 frames Video.
Because of the different frames and different sony vegas settings it starts lagging again.
Any Ideas?


Return to posts index

Wayne Waag
Re: Laging in preview-mode even with 4K Computer!
on Nov 12, 2015 at 5:29:08 pm

Glad that your system is finally up and running.

What should I do if I want to use 2 different video-files at the same time?
For example a gopro 1080P 60 frames video and a 4K 24 frames Video.
Because of the different frames and different sony vegas settings it starts lagging again.


I'm not surprised that you are still experiencing preview lags with those disparate frame sizes and frame rates within the same project. My suggestion is to create proxies based on your final render settings. E.g. if your finally delivery is 1080 24P, then create a proxy with those settings for both types of footage using one of the formats suggested by Aaron. Your preview performance will now be the same, and you can revert back to the original footage for final render.

wwaag


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]