FORUMS: list search recent posts

Text moves when I render

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Jeff Cyr
Text moves when I render
on Sep 5, 2015 at 11:07:01 am

In my project I want to zoom out a part of my video (Namely the moving video) and add in a frame I made in paint.net that fits the resolution I'll be rendering at, ontop of the frame I have to put some text however the moment I render the text moves up and to the left. Any ideas as to what can cause this and how I can solve it?


Return to posts index

John Rofrano
Re: Text moves when I render
on Sep 5, 2015 at 1:41:27 pm

Whenever you're doing overlay work, you must be sure that your project properties match your render properties. Preferably the same resolution but definitely the same aspect ratio. Also if your project uses a non-square pixel aspect ratio, you must compensate for this when you create text graphic overlays because graphics always use square pixels. Without know more about the details of your project, render, and text like resolution, etc. this is the only advice I can give.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Jeff Cyr
Re: Text moves when I render
on Sep 5, 2015 at 1:44:48 pm

I've no idea... My video and the overlay are both 1280x720 and to be honest I don't know what aspect ratio that is, nor what else you'd need to know to be able to help. My project is set to that resolution and I render with the same settings (Tools > scripting > batch render > windows media video V11 > 6Mbps HD 720-30p Video)


Return to posts index


John Rofrano
Re: Text moves when I render
on Sep 5, 2015 at 1:55:09 pm

OK, that's good information. 1280x720 uses a pixel aspect ratio (PAR) of 1.0 which are square pixels. So if your project and graphic and render are all set to 1280x720 then pixel aspect ratio isn't your problem.

Would it be possible for you to take a screen capture of before and after to show us what is happening? You can add the screen shot to your post with this button on the COW:



I assume that in the Vegas Pro preview window the text is where you want it but in the render it moves. Is this correct? Make sure that you set your video preview window to at least Good quality to check. Renders use Good or Best quality so having your video preview window set to Draft or Preview will sometimes look different that Good or Best. Always check your work with Good quality set before you render.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Jeff Cyr
Re: Text moves when I render
on Sep 5, 2015 at 2:01:57 pm

Here it is, the wood-grain is the overlay, the text and color bars are all stand-ins for what I plan to do with them, currently using zoomed-out media generator but even when removing those the text "Subtitles go here" gets moved.



Return to posts index

Steve Rhoden
Re: Text moves when I render
on Sep 5, 2015 at 4:20:55 pm

Try rendering to a different format (like quicktime etc) and see if the
rendered result is the same.

Steve Rhoden (Cow Leader)
Film Maker & VFX Artist.
Owner of Filmex Creative Media.
Samples of my Work and Company can be seen here:
http://www.facebook.com/FilmexCreativeMedia


Return to posts index


Wayne Waag
Re: Text moves when I render
on Sep 5, 2015 at 6:46:03 pm

windows media video V11

I agree with Steve. Try a different format such as Sony AVC which will produce an MP4.

wwaag


Return to posts index

Jeff Cyr
Re: Text moves when I render
on Sep 5, 2015 at 7:26:49 pm

The result is the same, everything gets shifted again


Return to posts index

Wayne Waag
Re: Text moves when I render
on Sep 5, 2015 at 10:05:29 pm
Last Edited By Wayne Waag on Sep 5, 2015 at 10:06:32 pm

If your titles are still moving, it sounds to me that they are being animated. Open one of your titles and make sure it looks like this:



And not like this with an animation window being show.



If this isn't the problem, then check the Event Pan/Crop window to make sure there are no keyframes other than the first causing movement. And finally check track motion for the tracks with the titles and make sure that there is no movement. To be sure, set the preset for each track to Default.

Hopefully, one of these potential sources of movement will be the problem.

wwaag


Return to posts index


Jeff Cyr
Re: Text moves when I render
on Sep 5, 2015 at 10:07:53 pm

no none of those are the issue, I haven't added any keyframe nor modified anything other than zooming out the main video to fit the size of the slot in the overlay, the text is a template I used frequently and it has no motion to it by default, all I did to that was change it's location (without opening the keyframe section) and change the text.


Return to posts index

John Rofrano
Re: Text moves when I render
on Sep 6, 2015 at 3:14:20 pm

[Jeff Cyr] "I haven't added any keyframe nor modified anything other than zooming out the main video to fit the size of the slot in the overlay, the text is a template I used frequently and it has no motion to it by default"
Your overlay is not moving up and to the left. While the title looks like it has moved up, the "Name Here" boxes have actually moved down and in. This suggests that the entire frame is zooming out.
[Jeff Cyr] "all I did to that was change it's location (without opening the keyframe section) and change the text."
I'm guessing that you inadvertently added a keyframe somewhere without knowing it. The overlay is definitely zoomed out from it's original position in the rendered snapshot.

The question is why aren't you seeing the same behavior on the timeline? That can only be explained by your render properties not matching your project properties but you say they are the same so I don't know where to go from here. :(

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Jeff Cyr
Re: Text moves when I render
on Sep 6, 2015 at 3:15:42 pm

All right well thanks for trying to help.


Return to posts index


John Rofrano
Re: Text moves when I render
on Sep 6, 2015 at 3:38:39 pm

What I would do is start a new 720p project. Drop just the one video and one overlay into the timeline and render. If the render is OK, then it's something you changed in the project. if the render is not OK, then it may have to do with how Vegas Pro is interpreting the media.

(ok so I lied.. I do still have a few things to try LOL) ;-)

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]