FORUMS: list search recent posts

AVCHD rendering @60p w/ Intel Quick Sync Video problem - Vegas Pro 13

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Pablo Möckel
AVCHD rendering @60p w/ Intel Quick Sync Video problem - Vegas Pro 13
on Aug 19, 2015 at 2:39:39 pm

Hello! I'm Hambert from Argentina, I call myself a video enthusiast and I recently bought a Panasonic HC-v750 that shoots AVCHD 2.0 Progressive 1080 at 60p. I was trying to render some edits in Vegas Pro 13 using Sony AVC codec, and wanted to use Intel QSV as it improves the render times a lot.

The problem is that Sony AVC seems to be WAY too buggy when working with IQSV on. My situation is as follows:

[B]1- Using "Internet 1080 30p" template as base, changed FPS to 60 and selected QSV in "quality" mode:[/B]



Result: Video renders in half the time as expected but final file is corrupted showing artifacts and almost 1fps playback:



[B]2- Using same settings but QSV in "Speed" mode gives this error:[/B]



Extra info: If I use the "Internet 1080 30p" template but only changing to QSV (leaving the 30p alone, not what I want), Quality mode once again corrupts the final file, but Speed mode works OK (final file OK). Using other input file (like a 1080p AVC 30fps clip from my phone) gives similar results, so the problem is not the input file.

So, my goal is to render AVC, either in an MP4 container or M2TS (AVCHD), at 60fps using QSV to improve the render time (I really need it). ¿Do you know any way around this?

My system is an HP Envy 4 Ultrabook
Intel Core i5 3317u 2.6Ghz 3rd gen + HD Graphics 4000
6GB DDRRAM
Samsung 850 Evo 500GB SSD drive
Windows 10
Latest Intel HD Graphics Drivers

Thanks in advance!! Great to be here!


Return to posts index

Wayne Waag
Re: AVCHD rendering @60p w/ Intel Quick Sync Video problem - Vegas Pro 13
on Aug 19, 2015 at 3:32:50 pm
Last Edited By Wayne Waag on Aug 19, 2015 at 3:36:56 pm

Do NOT use Quick-sync for 1080 renders, use CPU only. It works OK for 720, but not 1080. For 720, only use the quick setting, not quality. Sony has acknowledged this problem, but as of yet, it hasn't been fixed. If you want to use quick-sync for 1080 60P renders (which I do all the time) then frameserve to Handbrake (faster than CPU only) or TMPGEnc's Mastering Works (even faster than Handbrake).

wwaag


Return to posts index

Pablo Möckel
Re: AVCHD rendering @60p w/ Intel Quick Sync Video problem - Vegas Pro 13
on Aug 19, 2015 at 3:38:10 pm

Thank you so much for the reply.

So I guess I'll have to stick with basic CPU rendering.

Is there any other editing software other than Vegas capable of encoding AVC 1080 @60p and using QSV as well? Despite the corrupted files I've observed a sweet reduction in rendering time thanks to QSV, nearly half as much.

Thaks!


Return to posts index


Wayne Waag
Re: AVCHD rendering @60p w/ Intel Quick Sync Video problem - Vegas Pro 13
on Aug 19, 2015 at 3:43:45 pm

Perhaps you didn't see the changes I made to my post. I recommend the use of Handbrake. There is an excellent script which permits one-click operation. http://www.vegasvideo.de/vegas-2-handbrake-en Takes awhile to install, but once set up, it works extremely well and also about twice as fast as CPU renders. The other alternative is TMPGEnc's Mastering Works 6, which I found to be even faster than Handbrake, but it costs around $100 US whereas the Handbrake approach is free.

wwaag


Return to posts index

Pablo Möckel
Re: AVCHD rendering @60p w/ Intel Quick Sync Video problem - Vegas Pro 13
on Aug 19, 2015 at 3:41:37 pm

Nevermind, I forgot the last part of your reply while typing. Will check those out, thanks!!


Return to posts index

Aaron Star
Re: AVCHD rendering @60p w/ Intel Quick Sync Video problem - Vegas Pro 13
on Aug 26, 2015 at 9:50:22 pm
Last Edited By Aaron Star on Aug 26, 2015 at 10:00:11 pm

This is interesting to me. Since your source footage is AVCHD2.0@60P, have you tried rendering a test clip to XAVC-I or SonyAVC in a 60p profile, then attempting the Quicksync render?

Have you made sure that you have the latest Intel video drivers for your chip, and chipset.INF?

Not saying that this sample of video is using Vegas to prepare, but there several examples on YouTube of 1080@60p quick sync.










Return to posts index


Pablo Möckel
Re: AVCHD rendering @60p w/ Intel Quick Sync Video problem - Vegas Pro 13
on Aug 27, 2015 at 6:36:54 pm
Last Edited By Pablo Möckel on Aug 27, 2015 at 6:37:59 pm

There's a description of what happens when I do not use QSV, look at the end of my first post.

Renders without QSV work OK no matter the profile

Graphics drivers are the latest. I couldn't find drivers for the HM77 chipset in Intel's website, I can only download outdated ones from HP's website from 2012, they seem to do nothing on Windows 10


Return to posts index

Wayne Waag
Re: AVCHD rendering @60p w/ Intel Quick Sync Video problem - Vegas Pro 13
on Aug 27, 2015 at 8:23:57 pm

Like I said in the second post of this thread, the inability to render 1080 60P using QSV is a Vegas problem. You can render 720 but not 1080. There is a thread on the Vegas Pro forum where Sony has acknowledged the problem and indicated it would be fixed in a future update. You can easily render QSV for 1080 60P using Handbrake or TMPGEnc's Mastering Works, just not Vegas. In a similar manner, Vegas will render Mainconcept MPEG-2 1080 at 60i, but not at 60P.

wwaag


Return to posts index

Pablo Möckel
Re: AVCHD rendering @60p w/ Intel Quick Sync Video problem - Vegas Pro 13
on Aug 27, 2015 at 8:31:12 pm

I read you and you're correct, Wayne. Thanks!

Will give them a try when I have time, little busy these days.


Return to posts index


Aaron Star
Re: AVCHD rendering @60p w/ Intel Quick Sync Video problem - Vegas Pro 13
on Aug 27, 2015 at 9:12:32 pm

It is really odd that Sony does not do a better job on keeping up with these new technologies. You have to wonder who is in charge over there. I mean NV, AMD, and Intel all have hardware mp4 integrated, and there is list of cheese ball apps that support the functions, but Sony Vegas....has issues. I just find this really weird.


Return to posts index

Pablo Möckel
Re: AVCHD rendering @60p w/ Intel Quick Sync Video problem - Vegas Pro 13
on Sep 1, 2015 at 1:20:26 pm
Last Edited By Pablo Möckel on Sep 1, 2015 at 1:21:39 pm

I've downloaded Handbrake, but it seems to be a standalone encoder, so I have to render a lossless file first with vegas and then transcode it to AVC with Handbrake? My target is to render directly from the editor software using QSV.

Isn't there a way to render directly from Vegas using Handbrake? I couldn't find any guide to do so, thanks!


Return to posts index

Wayne Waag
Re: AVCHD rendering @60p w/ Intel Quick Sync Video problem - Vegas Pro 13
on Sep 1, 2015 at 3:07:00 pm

Isn't there a way to render directly from Vegas using Handbrake? I couldn't find any guide to do so, thanks!

Yes. Here's the link. http://www.vegasvideo.de/vegas-2-handbrake-en

wwaag


Return to posts index


Pablo Möckel
Re: AVCHD rendering @60p w/ Intel Quick Sync Video problem - Vegas Pro 13
on Sep 1, 2015 at 6:24:15 pm

Success! Thank you so much for the help!

Besides the amount of extra software I had to install and the pre-render process, render time and quality are as expected with QSV working like a charm.

As a plus, Handbrake seems to be much more optimized for low bitrates than other Vegas integrated encoders, great!

Thanks again!

Hambert


Return to posts index

Wayne Waag
Re: AVCHD rendering @60p w/ Intel Quick Sync Video problem - Vegas Pro 13
on Sep 1, 2015 at 6:26:59 pm

Glad to be of help. The Vegas 2 Handbrake script is really quite brilliant and you're right about the value of Handbrake for low bit rate encoding. Much better than using the internal Vegas encoders.

wwaag


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]