FORUMS: list search recent posts

Rendering interlaced video from TV network, incorrectly identified by Vegas + strange MediaInfo

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Chris Lohr
Rendering interlaced video from TV network, incorrectly identified by Vegas + strange MediaInfo
on Jul 28, 2015 at 7:42:22 am
Last Edited By Chris Lohr on Jul 28, 2015 at 8:58:54 am

EDIT: I have received the go-ahead to render this de-interlaced. I still would like to figure this out, for the future, though.

__________________

Hello,

I am so confused by this footage I have to work with in Vegas. I am fairly new to working with interlaced footage, but I have used it successfully with another project before.

For this current project, the footage is straight from a major TV network, their German division.

The MediaInfo states:
Scan type : Interlaced
Scan order : Bottom Field First
Stored scan order : Top Field First


Vegas automatically interprets every clip as Field Order: None (Progressive scan), when I right-click the clips in Vegas and choose Properties.

I can't figure out any combination of changing clip properties, project properties, and rendering properties that can render this properly at 25 fps interlaced (as MediaInfo says the source footage is). I have tried every combination I could think of, including alternate codecs.

I am able to properly de-interlace the footage by right-clicking the clips and manually setting them to either Top Field First or Bottom Field First. But I don't even know which is right due to that MediaInfo. If I leave them with Vegas' default choice (Progressive), of course deinterlacing doesn't work.

I appreciate any insight.

Here is the full MediaInfo (with Audio and identifiable filename info removed):

Format : MPEG-4
Format profile : QuickTime
Codec ID : qt
File size : 39.7 GiB
Duration : 43mn 32s
Overall bit rate : 130 Mbps
Encoded date : UTC 2015-04-28 23:43:15
Tagged date : UTC 2015-04-29 00:57:45
Writing library : Apple QuickTime

Video
ID : 1
Format : VC-3
Codec ID : AVdn
Codec ID/Info : Avid
Codec ID/Hint : DNxHD
Duration : 43mn 32s
Bit rate mode : Constant
Bit rate : 121 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 25.000 fps
Color space : YUV
Chroma subsampling : 4:2:2
Bit depth : 8 bits
Scan type : Interlaced
Scan order : Bottom Field First
Stored scan order : Top Field First
Bits/(Pixel*Frame) : 2.339
Stream size : 36.9 GiB (93%)
Language : English
Encoded date : UTC 2015-04-28 23:43:16
Tagged date : UTC 2015-04-29 00:57:45

Other
ID : 6
Type : Time code
Format : QuickTime TC
Duration : 43mn 32s
Time code of first frame : 09:59:40:00
Time code settings : Striped
Language : English
Encoded date : UTC 2015-04-29 00:57:45
Tagged date : UTC 2015-04-29 00:57:45


Return to posts index

John Rofrano
Re: Rendering interlaced video from TV network, incorrectly identified by Vegas + strange MediaInfo
on Jul 28, 2015 at 1:21:52 pm

MediaInfo is telling you that the video is stored Upper Field First in the container and all HD media should be Upper Field First so that is what you should use. Vegas Pro is probably confused by the metadata in the QuickTime container. The only thing you can do is right-click on every event and change it to Upper Field First. We sell a plug-in at VASST called Property Assistant to help automate this for multiple events with a single click.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Chris Lohr
Re: Rendering interlaced video from TV network, incorrectly identified by Vegas + strange MediaInfo
on Jul 28, 2015 at 3:22:14 pm

Alright, thank you John. I must just need to learn how to properly work with interlacing (which I'll do on my own), because I still couldn't get the footage to render properly after choosing Upper Field on the clips, project properties, and render settings. But I am OK for this project because I rendered it deinterlaced which they were fine with.


Return to posts index


John Rofrano
Re: Rendering interlaced video from TV network, incorrectly identified by Vegas + strange MediaInfo
on Jul 28, 2015 at 3:30:52 pm

[Chris Lohr] "I must just need to learn how to properly work with interlacing (which I'll do on my own), because I still couldn't get the footage to render properly after choosing Upper Field on the clips, project properties, and render settings."
What do you have selected for the Deinterlace method in your Project Properties? It should have been set to Blend Fields if your footage was interlaced.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Chris Lohr
Re: Rendering interlaced video from TV network, incorrectly identified by Vegas + strange MediaInfo
on Jul 28, 2015 at 3:56:41 pm
Last Edited By Chris Lohr on Jul 28, 2015 at 4:01:14 pm

I set that to Interpolate Fields because it has constant very fast movement and I read that that was a better choice in that case, right?

But I was able to render de-interlaced fine. I just couldn't render the video properly while keeping it interlaced. It kept rendering the interlaced lines into the frames. This is with Upper Field First selected in clip / project / render settings, rendering to DNxHD 1080i / 50. Frame rate set to 25. Can't think of what else could possibly be set incorrectly, but if there's any more info I could share I will. I'll continue fiddling with this today.


Return to posts index

John Rofrano
Re: Rendering interlaced video from TV network, incorrectly identified by Vegas + strange MediaInfo
on Jul 28, 2015 at 4:09:34 pm

[Chris Lohr] "I set that to Interpolate Fields because it has constant very fast movement and I read that that was a better choice in that case, right?"
Yes, Interpolate Fields works better with fast motion but I would only use it if Blend Fields shows artifacts because the motion is too fast. This is because Interpolate Fields throws away 1/2 of your vertical resolution. So I would only uses it when absolutely needed.
[Chris Lohr] "I just couldn't render the video properly while keeping it interlaced. It kept rendering the interlaced lines into the frames."
What were you using to check this? Were you using an interlaced device like a TV? If not... if you checked it on your computer display then you are supposed to see the lines because a computer display isn't an interlaced device.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index


Chris Lohr
Re: Rendering interlaced video from TV network, incorrectly identified by Vegas + strange MediaInfo
on Jul 28, 2015 at 4:16:09 pm
Last Edited By Chris Lohr on Jul 28, 2015 at 4:18:05 pm

Oh, OK. Yeah I was checking on a computer monitor. But the studio told me they had the lines showing up in FCP-X which is why they asked me to fix it. I also didn't see the interlaced lines much when checking the original footage, only in my re-rendered footage, which is why I thought I messed up.

Thanks for letting me know about Interpolate Fields. They accepted the footage but I will re-render with Blend and send that to them.


Return to posts index


John Rofrano
Re: Rendering interlaced video from TV network, incorrectly identified by Vegas + strange MediaInfo
on Jul 28, 2015 at 5:01:15 pm

[Chris Lohr] "But the studio told me they had the lines showing up in FCP-X which is why they asked me to fix it. "
OK so it still may be messed up. But the two ways of telling are to view it on an interlaced device and see if the lines go away, and render it with a player that can de-interlace and see if the lines go away. One way to do this is to use Vegas Pro's secondary preview with the option to deinterlace the display. If you still see lines when deinterlace is enabled then it's not done properly.
[Chris Lohr] "Thanks for letting me know about Interpolate Fields. They accepted the footage but I will re-render with Blend and send that to them."
Well... I would watch it first and make sure that it looks OK before you send it.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Chris Lohr
Re: Rendering interlaced video from TV network, incorrectly identified by Vegas + strange MediaInfo
on Jul 29, 2015 at 3:42:39 am
Last Edited By Chris Lohr on Jul 29, 2015 at 3:50:58 am

Thank you, John. By using that information, I've realized what the final problem was:
I couldn't remove interlacing from some of the clips because I had done major cropping on them.

I'm now looking up how to fix this, which should lead somewhere since I now know exactly what was causing the problem.

edit: Looks like "Reduce Interlace Flicker" is the answer, on clips that have this problem. Guess that is basically just de-interlacing those clips. So no way to properly render heavily cropped+zoomed interlaced clips, retaining the interlacing? I guess that makes sense, since it is enlarging the field size.


Return to posts index


John Rofrano
Re: Rendering interlaced video from TV network, incorrectly identified by Vegas + strange MediaInfo
on Jul 29, 2015 at 1:55:07 pm

[Chris Lohr] "So no way to properly render heavily cropped+zoomed interlaced clips, retaining the interlacing? I guess that makes sense, since it is enlarging the field size."
Yes there is. You need to make sure that you have your Deinterlace Method set properly (which you do) and that in the Event Properties, Vegas Pro is interpreting the clips as Interlaced. If those two things are set properly, you can crop all you want and Vegas Pro will: Deinterlace -> Crop -> Re-Interlace properly.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Chris Lohr
Re: Rendering interlaced video from TV network, incorrectly identified by Vegas + strange MediaInfo
on Jul 29, 2015 at 11:34:49 pm

Hmm... then I am unsure what is wrong. If I render de-interlaced, it properly de-interlaces everything. If I render interlaced, there is a problem (I put the rendered interlaced footage into media players with de-interlacing, as you said is a good way to test if all was done properly, and they couldn't properly de-interlace the clips that had problems. But they properly de-interlaced all the rest of the footage). And checking the clips within Vegas with the de-interlacing preview also shows them properly de-interlaced. The problem is only in rendering them interlaced.

Confusing. At least the studio was OK with my de-interlacing.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]