FORUMS: list search recent posts

Sony Vegas Pro 12 Ghosting Issues/Render Issues

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Nikko Emilio
Sony Vegas Pro 12 Ghosting Issues/Render Issues
on Jun 22, 2015 at 6:03:43 pm

You've all probably seen posts like this over and over again, and I'm sorry about making another one of these. I've searched forum post after forum post trying to see if I could fix the issue myself, so now I'm resorting to asking for help.

My issue is (what I hope) simply, I get ghosting on videos after rendering them in Sony Vegas 12. My footage does not have any ghosting, nor is there any while editing. It's only after I render. I'll post my capture settings, project settings, and render settings to make everything as clear as I can.

HD PVR 2 Capture Settings- http://gyazo.com/79cd7e043ef0b914d6ba5f75df0bc435
Advanced Settings- http://gyazo.com/af66e313bb781228fa6d4f671a0a2bd2
Vegas Project Settings- http://gyazo.com/5558a63baf8673716963761a839d394e
Vegas Render Settings- http://gyazo.com/845e05234e195adb38de688c9907fcba
Vegas Video Properties- http://gyazo.com/d3523b17ac382a9cd67a7d5fb945fcff
(I do not change anything in the individual properties)
Video Properties-http://gyazo.com/acc37575b4db8f333406a7a2a32ad0b2

Lastly, I'll post something I notice when editing on preview quality best full - http://gyazo.com/9de3f33327e6635d14c299c6de1bce9f
I do not know if it's because my computer cannot handle editing at best settings, but these lines do go away when I change to lower settings such as preview or draft, or in the project settings, I change the field order to upper field first.

Lastly, I'll add what I have changed, because I have rendered out this video at least 10 times with different settings. I have tried changing the Vegas video properties field order to none, progressive scan, I have tried changing all to upper field first to field order in the project settings and render settings, I have rendered in 14,000,000 bps because my capture device renders in 14 mbps, I've changed the deinterlace method to blend fields (not sure if I have done interpolate method but most likely have), and I've done profile at main for rendering. Of course I disable resample, and I have GPU off. I'd also like to add that my footage is recorded in m2ts video format because Sony Vegas has trouble with mp4, especially with the HD PVR 2.

I do not have a great graphics card, but I do not see that being the reason I have ghosting in my clip. I hope that I do not have to reinstall sony vegas or replace my capture device, but instead be me having some stupid setting that causes this.

Lastly, here's the clip without ghosting (uploaded to youtube straight after capturing) -





And here is the clip after rendering with sony vegas -





Return to posts index


John Rofrano
Re: Sony Vegas Pro 12 Ghosting Issues/Render Issues
on Jun 22, 2015 at 6:55:12 pm

I'm assuming that by "ghosting" you mean the Interlace artifacts on moving objects (i.e., the comb effects on the edges). Given your current settings, this is happening because you set your Deinterlace Method to None but your footage is interlaced. So your footage is not being deinterlaceds because you told Vegas Pro not to deinterlace it therefore you are seeing interlace artifacts (what you call ghosting).

Here is how you fix it:
  1. Use the standard HD 1080-60i (1920x1080, 29.970 fps) project setting and don't change anything!
  2. Set your project Deinterlace Method to Blend Fields
  3. Render with MainConcept AVC with the Internet HD 1080p template and don't change anything!
The ghosting should now be gone. If you still see some interlace artifacts, change your Deinterlace Method to Interpolate Fields but blending them should be enough.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Nikko Emilio
Re: Sony Vegas Pro 12 Ghosting Issues/Render Issues
on Jun 22, 2015 at 7:13:39 pm

Thank you sooo much! I ended up having to interpolate fields. Also I have two questions, can I change the bit rate for rendering, and what does field order do?


Return to posts index


John Rofrano
Re: Sony Vegas Pro 12 Ghosting Issues/Render Issues
on Jun 22, 2015 at 7:38:08 pm

[Nikko Emilio] "Also I have two questions, can I change the bit rate for rendering?"
Yes, you can change the bit rate. You can also check the Two-pass option to get the highest quality possible from the bit rate that you choose. The Average bit rate will determine the overall quality and file size. The Maximum bit rate will determine how many bits can be used for the frames with the most details and motion. It's always good to have the maximum set higher than the average.
[Nikko Emilio] "and what does field order do?"
Field order determines how the video is interlaced. When video is encoded with Interlacing, it can either display the Upper Field First (UFF) or the Lower Field First (LFF). If you get this wrong, the video will seem very jerky. If you turn this off, the video will have ghosting. It's best to leave the Field Order alone and let Vegas Pro take care of handling it for you.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]