FORUMS: list search recent posts

Sony Movie Studio Steam Edition not loading VASST Plugins

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Daniel Gilbert
Sony Movie Studio Steam Edition not loading VASST Plugins
on Jun 18, 2015 at 6:47:35 pm

Hi folks,

I hope I'm right here, although it's not Vegas. But I became desperate.

I bought Sony Movie Studio Platinum via Steam (Summer Sale! \o/) to edit and render my "Let's code"-Clips. However, as Movie Studio is not able to render regions to different files, I did a quick search here and bought "RenderAssistant" from Fasstapp.

Unfortunately, the Steam Version doesn't load the plugin. Now, I did some research, as I'm a Software engineer and a curious nature:

SMSP is searching at different locations for plugins. One is "C:\Users\[USERNAME}\AppData\Local\Sony\Movie Studio Platinum - Steam Powered\Application Extensions"

I did install the standalone Demo of SMSP from the Sony page, and the plugin is successfully installed in "C:\Users\{USERNAME}\AppData\Local\Sony\Movie Studio Platinum\Application Extensions" (notice the difference).

I copied the plugin, and monitored SMSP again. Now it finds the plugin, but still isn't able to load it, I guess.
And here I'm lost.

Any idea how I can get the plugin to work with SMSP Steam Edition?

P.S.: Haven't received a mail from the Fasstapps-Support so far, so maybe they are investigating, or maybe not. I thought I could ask here though.


Return to posts index

Jorma Nippala
Re: Sony Movie Studio Steam Edition not loading VASST Plugins
on Jun 18, 2015 at 10:32:34 pm
Last Edited By Jorma Nippala on Jun 18, 2015 at 10:48:03 pm

See Help > About and check the build number of SMSP 13 you have got.
The SMSP 13 "standard" version build 931/932 had an issue that prevented VASST Fasst Apps from loading. If you have that build, see if updating to build 942/943 helps.


Return to posts index

Daniel Gilbert
Re: Sony Movie Studio Steam Edition not loading VASST Plugins
on Jun 19, 2015 at 4:43:47 am
Last Edited By Daniel Gilbert on Jun 19, 2015 at 4:52:35 am

Hi Jorma,

thanks for your reply. I checked the build number on startup, it's 953. However, after a restart (between now and yesterday), SMSP crashes on startup when initializing the GPU rendering. I have a Radeon HD 7750.

It's frustrating. :\

//Edit:
Ok, just a follow up: I pressed "Ctrl" & "Shift" on startup of the application, so I could wipe the Settings.
After that, I had to enable the GPU Rendering (weird, I know) and select the video card I use for rendering.

Short explanation: I have a three monitor setup, using the AMD card and the internal Intel video card. Must have confused SMSP somehow.

However, the problem with the plugin still persist. It's not showing...


Return to posts index


John Rofrano
Re: Sony Movie Studio Steam Edition not loading VASST Plugins
on Jun 19, 2015 at 12:05:40 pm

[Daniel Gilbert] "I bought Sony Movie Studio Platinum via Steam"
Sony never informed VASST that they were making a Steam Edition of Movie Studio. This is why the plug-in doesn't install into the proper folder. You might want to contact Sont and ask if Movie Studio Steam Edition was meant to work with VASST FasstApps.
[Daniel Gilbert] "I copied the plugin, and monitored SMSP again. Now it finds the plugin, but still isn't able to load it, I guess. And here I'm lost."
Did you also copy the license file? There is a license file with the same name as the dll with a ".license" extension. That must be in the same folder as the .dll file in order for it to load. Without that file the plug-in is ignored by Movie Studio.

Let me know how you make out because as I said, we (VASST) are totally unaware that Sony was doing this.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Daniel Gilbert
Re: Sony Movie Studio Steam Edition not loading VASST Plugins
on Jun 19, 2015 at 1:18:55 pm
Last Edited By Daniel Gilbert on Jun 19, 2015 at 1:34:58 pm

John,

thanks for your reply. The more I look at the version, the more it seems unfinished.

Sony not telling its' partners what they are doing is clearly not speaking for Sony. I mean, it's on the store since feburary.

I'll contact the sony support, but I've read that they have quite a long respond time. And they are also on the Steam forums, but haven't replied yet. (related thread: http://steamcommunity.com/app/330070/discussions/0/620712364031640628/ )

The license file is contained in the same folder. Maybe it's related to how the steam version is started, because you cannot start it from the installation folder by double clicking the executable. It seems to me that some manager just thought "Oh, there is this "Steam" thingy. We need that!!".

I'll keep you posted.

//Edit: Created the ticket. Let's keep our fingers crossed, otherwise I'll ask Valve for a refund...


Return to posts index

John Rofrano
Re: Sony Movie Studio Steam Edition not loading VASST Plugins
on Jun 19, 2015 at 2:56:04 pm

Thanks for that link! I also posted to the Steam forum so that it can be tracked there. I'm trying to contact Sony and see what's going on. Hopefully I'll be able to get back to you soon with an answer.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]