FORUMS: list search recent posts

Track Motion doesn't move object where I need it to be

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Ivan Petrov
Track Motion doesn't move object where I need it to be
on Dec 16, 2014 at 11:58:07 pm

I use Vegas Pro 11.0. For example, I need this lightning to touch the oval.



But for some reason the lightning doesn't stop moving after it reaches the keyframe, it keeps moving for a few next frames and ends up being a bit away from the oval.


What's that?? Isn't keyframe supposed to define the object's final position? Don't remember having this problem in Vegas Pro 9.0 too.


Return to posts index

John Rofrano
Re: Track Motion doesn't move object where I need it to be
on Dec 17, 2014 at 1:42:08 am

Try setting the preview to Best (Full) before you try and do any accurate positioning. Sometimes Preview (Auto) doesn't give you an accurate enough representation for precise keyframing.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Andrew Lenczycki
Re: Track Motion doesn't move object where I need it to be
on Dec 17, 2014 at 3:13:15 pm

Do you know how to zoom in on the keyframe timeline? I've had it happen for me in the past that while working on a keyframe, I inadvertently created a new one that is very close to the original. If you are too zoomed out on the keyframe timeline, it may not be visible (they may appear as a single keyframe marker).

The other thing to double-check is that there is not another keyframe further (sometimes MUCH) down the timeline that is a little different, and as the event progresses, will cause this slow movement.

Andrew Lenczycki


Return to posts index


Ivan Petrov
Re: Track Motion doesn't move object where I need it to be
on Dec 17, 2014 at 4:03:47 pm

Thanks for replies!
No, preview quality doesn't seem to affect it, I tried every available option from Draft - Auto to Best - Quarter before and after positioning.
I tried to zoom in to the max and out, tried to switch between keyframes with Previous / Next Keyframe buttons, and no, there are no other keyframes, neither close to that one you see on the pics above nor down the timeline.
I thought maybe something changed in 11.0 version and I'm missing something obvious, but now it seems like some strange bug. Because I did it many times in 9.0 without any problems.


Return to posts index

John Rofrano
Re: Track Motion doesn't move object where I need it to be
on Dec 17, 2014 at 4:47:17 pm

Try right-clicking on the keyframe and set it's property to Hold.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Ivan Petrov
Re: Track Motion doesn't move object where I need it to be
on Dec 17, 2014 at 6:21:59 pm

Doesn't help.
So, that's what I have:
2 keyframes (1st is default position, 2nd is 'touching the oval', both Linear) - I click 2nd keyframe and the lightning seems to be in the right position. I press right arrow key to switch to next frames, the lightning keeps moving for 1 frame to the wrong 'a bit away from oval' position and then stops.
2 keyframes (1st Linear, 2nd Hold) - the same as previous case.
2 keyframes (both Hold) - I click 2nd keyframe and the lightning somehow is in default position (not moved/rotated, nothing). I press right arrow key - the lightning moves for 1 frame to the wrong 'a bit away from oval' position and then stops.
1 keyframe (no matter Linear or Hold)- I don't create 2nd keyframe, just change the lightning position in the 1st one, and it's ok, the lightning doesn't move away from the oval.

So this problem only happens when there 2 or more keyframes and the object changes its position from one to another.
And once again, I never had anything like that in 9.0, never had to change properties to Hold etc. Okay, at least now I'm almost sure there's some bug.


Return to posts index


John Rofrano
Re: Track Motion doesn't move object where I need it to be
on Dec 17, 2014 at 6:48:38 pm

That definitely sounds like a bug. I would report it to Sony.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Tyson Onaga
Re: Track Motion doesn't move object where I need it to be
on Dec 17, 2014 at 9:16:56 pm

You might check to see that you don't have any unwanted Pan/Crop keyframes. If you do, then the Event will "move" relative to its Track Motion position.



Return to posts index

Ivan Petrov
Re: Track Motion doesn't move object where I need it to be
on Dec 17, 2014 at 11:17:11 pm

No, I didn't even use Pan/Crop. But okay, I think I found a workaround: I create a new project, adjust track motion using only 1 keyframe, save the preset and select it in my other project. After that, things become opposite to what I had: the position seems wrong when I click the keyframe to which I applied the preset, but in the next frame the object moves to the right position (that was saved with preset). Fighting fire with fire here, but well...


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]