FORUMS: list search recent posts

Rendered Sony Vegas 11 Videos Get Choppy

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Reinis Lacis
Rendered Sony Vegas 11 Videos Get Choppy
on Jul 5, 2014 at 3:17:53 pm

Hello, guys!

I was wondering whether anyone could help me with a rendering problem I have with Sony Vegas 11. It's quite simple, the rendered videos tend to get a bit choppy at the parts where one clip shifts on to another one.

It looks like this:
http://i.imgur.com/LgfYe3R.jpg

I've searched for similar posts in the past and seemingly none of the solutions have worked:

I turned off the GPU acceleration;
I ticked out "close media files when not the active application" (from time to time I have the "black screen" problem);
I disabled resample for all of the clips involved (ditto);
I tried rendering it both in CBR two-pass and then quality VBR.

I don't know what to do now.

Should I, perhaps, render it in a different output format? I mostly use HD Mpeg-4 videos and render the montage in WMV since it seemingly offers the most quality while not being over-sized. (If this is the problem, then I have to add that it hasn't been a problem in the past).

I look forward to any recommendations.

Thanks!


Return to posts index

John Rofrano
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 5, 2014 at 4:25:32 pm

[Reinis Lacis] "the rendered videos tend to get a bit choppy at the parts where one clip shifts on to another one. "
What bit-rate are you rendering at? Try using a higher bit-rate. That choppiness is caused by not having enough bits to accurately represent the scene change.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Reinis Lacis
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 6, 2014 at 7:22:03 pm

I'm not sure as I'm not as crafty as I should be when it comes to issues like this.

After I choose to customize the template for format I have selected, under the section "Bit Rate" the window that is ticked in is titled "Internet/LAN". The number next to it is "4,80 M". Am I looking at the correct thing?


Return to posts index


John Rofrano
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 6, 2014 at 8:48:23 pm

[Reinis Lacis] "After I choose to customize the template for format I have selected, under the section "Bit Rate" the window that is ticked in is titled "Internet/LAN". The number next to it is "4,80 M". Am I looking at the correct thing?"
It's probably best if you post screen shots of the windows you are seeing. I need to know what render format you are using and what template under that format in order to sufficiently answer your questions because every render format has a different screen with different parameters.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index


John Rofrano
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 6, 2014 at 11:46:01 pm

Oh you're using Windows Media Video. Try using MainConcept AVC with the Internet 720p template. You will need to change the frame rate to 23.976 if you really want 24p as that template defaults to 30p. That should give you better results.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index


Reinis Lacis
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 7, 2014 at 9:29:04 am

An error occurred.

http://i.imgur.com/TVGZ9NM.png

Are there any alternatives?


Return to posts index

John Rofrano
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 7, 2014 at 11:55:03 am

[Reinis Lacis] "An error occurred."
Do you have any codec-paks like 'K-Lite' installed? Codec paks can mess up rendering.
[Reinis Lacis] "Are there any alternatives?"
Try using Sony AVC with the Internet ... template instead and see if that works,

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Reinis Lacis
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 7, 2014 at 12:32:07 pm

I only had XviD Codec installed which I then uninstalled (it didn't change a thing).

When I went the Sony AVC route, the rendered video looked like this:
http://i.imgur.com/y31TGGz.png

This is really frustrating since a couple of days ago a video I rendered in WMV turned out fine:







Return to posts index


John Rofrano
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 7, 2014 at 12:45:22 pm

[Reinis Lacis] "When I went the Sony AVC route, the rendered video looked like this:"
That has nothing to do with your codec. Those are interlace artifacts because you are using interlaced footage and not deinterlacing properly.
[Reinis Lacis] "This is really frustrating since a couple of days ago a video I rendered in WMV turned out fine"
You can try raising the bit rate on the WMV template to 6 M or 8 M. That might also fix it.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Reinis Lacis
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 7, 2014 at 2:15:10 pm

[John Rofrano] "That has nothing to do with your codec. Those are interlace artifacts because you are using interlaced footage and not deinterlacing properly."

So how does one deinterlace properly?



[John Rofrano] "You can try raising the bit rate on the WMV template to 6 M or 8 M. That might also fix it."

Raising it to 8 M or even 20 M didn't help. There still are like 8 or 10 occasions of the picture becoming choppy.

Is there any significance to the fact that it happens right at the end of a clip?


Return to posts index

John Rofrano
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 8, 2014 at 11:07:42 am

[Reinis Lacis] "So how does one deinterlace properly?"
You start by selecting an appropriate deinterlace method in your project properties. What does your project properties say under Deinterlace method?
[Reinis Lacis] "Is there any significance to the fact that it happens right at the end of a clip?"
Yes, this happens because the encoder is only encoding the pixels that have changed from frame to frame. When a scene changes, every pixel in the frame changes and it may not have enough bits to represent the entire change. This is why you don't want to use WMV. The fix is to use the Two Pass option which WMV doesn't have.

This is why I recommended that you use MainConcept AVC because it has the Two pass option that you need. You really need to figure out why MainConcept AVC doesn't work. Perhaps it's just this one project? Try using it on a single piece of media just to see if it works at all.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index


Reinis Lacis
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 9, 2014 at 8:26:17 am

[John Rofrano] "You start by selecting an appropriate deinterlace method in your project properties. What does your project properties say under Deinterlace method?"

It says "blend fields" under Deinterlace method.



[John Rofrano] "This is why I recommended that you use MainConcept AVC because it has the Two pass option that you need. You really need to figure out why MainConcept AVC doesn't work. Perhaps it's just this one project? Try using it on a single piece of media just to see if it works at all."

For some reason it doesn't work at all.


Return to posts index

John Rofrano
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 9, 2014 at 5:33:28 pm

[Reinis Lacis] "It says "blend fields" under Deinterlace method."
That's good. Right-click on one of the Video Events on the timeline that is showing the interlace lines and go into Properties | Media and see what the Field Order is set to. It should be set to Upper field first or Lower field first but not to None (progressive scan).
[Reinis Lacis] "For some reason it doesn't work at all."
That's not good. This should work. There is something wrong with the configuration of your computer. I would uninstall and re-install Vegas Pro to try and get all of your codecs working. The solution to your bit-rate problem is using the Two Pass option and the codec that has that options doesn't work on your PC. As I said... that's not good.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Reinis Lacis
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 12, 2014 at 4:00:02 pm

[John Rofrano] "That's good. Right-click on one of the Video Events on the timeline that is showing the interlace lines and go into Properties | Media and see what the Field Order is set to. It should be set to Upper field first or Lower field first but not to None (progressive scan)."

It didn't change anything.


Return to posts index


John Rofrano
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 13, 2014 at 11:48:21 am

[Reinis Lacis] "It didn't change anything."
What was it set to?

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Reinis Lacis
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 13, 2014 at 12:01:01 pm

[John Rofrano] "What was it set to?"

It was set to None.


Return to posts index

John Rofrano
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 13, 2014 at 12:23:22 pm

[Reinis Lacis] "It was set to None."
That's the wrong setting and explains why you are seeing interlace artifacts in your final video.

So let's review:
  • Your project is set up correctly to deal with deinterlacing.
  • Your video is interlaced
  • Yet when you place the video on the Vegas Pro timeline it thinks the video is progressive
The solution is to tell Vegas Pro that the video is interlaced OR maybe the video was previously rendered in the wrong format and it really isn't interlaced in which case the problem is your source video.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Reinis Lacis
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 16, 2014 at 3:40:06 pm

[John Rofrano] "That's the wrong setting and explains why you are seeing interlace artifacts in your final video.

So let's review:

Your project is set up correctly to deal with deinterlacing.
Your video is interlaced
Yet when you place the video on the Vegas Pro timeline it thinks the video is progressive

The solution is to tell Vegas Pro that the video is interlaced OR maybe the video was previously rendered in the wrong format and it really isn't interlaced in which case the problem is your source video."


Shouldn't setting it to "upper field first" change that?


Return to posts index

John Rofrano
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 17, 2014 at 1:14:03 am

[Reinis Lacis] "Shouldn't setting it to "upper field first" change that?"
Yes, if the video is really interlaced. Where did you get the video from? It looks like they are being recorded from a TV but that does't mean that the device that's recording it is recording interlaced. It may be incorrectly recording interlaced video as progressive without properly deinterlacing it first. There is no way to fix that. I would use a tool like MediaInfo to determine if the video is really interlaced or not and if it is, what the field order should be.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Reinis Lacis
Re: Rendered Sony Vegas 11 Videos Get Choppy
on Jul 25, 2014 at 1:00:48 pm

[John Rofrano] "Yes, if the video is really interlaced. Where did you get the video from? It looks like they are being recorded from a TV but that does't mean that the device that's recording it is recording interlaced. It may be incorrectly recording interlaced video as progressive without properly deinterlacing it first. There is no way to fix that. I would use a tool like MediaInfo to determine if the video is really interlaced or not and if it is, what the field order should be."

This stuff is going over my head.

In related news, I found out that I can render in MainConcept AVC if I switch the encode mode from "Automatic" to "Render using CPU only".

The choppiness remained in a couple of places, yet I hope to solve it by upping the BPS (which was at 16 000 000 at the maximum and 8 000 000 at the average).


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]