FORUMS: list search recent posts

"Failed to initialize script host" Error (Sony Vegas Pro 11, Windows 8.1)

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Rob Doe
"Failed to initialize script host" Error (Sony Vegas Pro 11, Windows 8.1)
on Jun 29, 2014 at 5:01:28 am

I recently switched computers and have installed Sony Vegas Pro 11 (I understand Sony Vegas Pro 13 is out but i prefer to use Pro 11 as i have been using it this entire time and have installed tons of plugins specifically for Pro 11). When i start the program, i get a message with "Error 0x80131902 (message missing)" and two options: Ok and Details>>. When i click on Details, it tells me that it has "Failed to initialize script host."

I have searched online for days now trying to figure out how to solve this problem and can't seem to find a fix. My microsoft.netframework is currently at the latest version of 4.5.2 and i have all the other microsoft.netframeworks from version 2 up installed as well.

I have also tried downloading "TuneUp Utilities 2014" and cleaning/defragmenting registry, which has yielded no results.

All important updates from my action center have been installed as well.

I have tried reinstalling close to 8 times now so that surely can't be it.

Anyone have any suggestions on how to fix this? I would love to continue using Sony Vegas Pro! Thanks in advance for your help!


Return to posts index

John Rofrano
Re: "Failed to initialize script host" Error (Sony Vegas Pro 11, Windows 8.1)
on Jun 29, 2014 at 11:41:06 am

[Rob Doe] "When i start the program, i get a message with "Error 0x80131902 (message missing)" and two options: Ok and Details>>. When i click on Details, it tells me that it has "Failed to initialize script host.""
Vegas Pro 11.0 requires Microsoft .NET Framework 3.5 SP1. I believe that is dependent on the .NET Framework 3.0 and 2.0 libraries as well. You'll need all three for Vegas Pro 11.0 scripting to work. While Vegas Pro 11.0 only "officially" supports Windows 7, I have installed it on a clean copy of Windows 8.1 without any problems. It sounds like something is wrong with the various .NET Framework installations on your computer. Only you can figure that out.

Try removing all of the .NET Frameworks and then re-install Vegas Pro 11.0. This will trigger them all to be re-installed in the proper order again.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Rob Doe
Re: "Failed to initialize script host" Error (Sony Vegas Pro 11, Windows 8.1)
on Jun 29, 2014 at 6:23:57 pm

Thank you for taking the time to respond to my question.

Sorry if this sounds a bit stupid but how do i remove all my .NET Frameworks? I know that they appear in the registry but is that all i need to delete? Or is in another location?

Also, when you say to delete all the .NET Frameworks, do you mean all of the ones associated with Sony Vegas Pro 11 (3.5 SP1, 3.0, and 2.0) or all of them up until 4.5.2?

And one last thing, i tried using the 3.5 SP1 installer to see if i could repair the Framework, but when i open the installer nothing happens. Oddly enough, the same happened with 3.0 and 2.0. Is this something to do with Windows 8.1? Is Windows 8.1 compatible with Frameworks 2.0, 3.0, and 3.5 SP1?

Sorry for all the questions, when it comes to Net.Framework im quite lay


Return to posts index


John Rofrano
Re: "Failed to initialize script host" Error (Sony Vegas Pro 11, Windows 8.1)
on Jun 29, 2014 at 7:33:31 pm

[Rob Doe] "Sorry if this sounds a bit stupid but how do i remove all my .NET Frameworks? I know that they appear in the registry but is that all i need to delete? Or is in another location?"
That's a good question. I would go into the Control Panel, and select Add/Remove Programs, and remove anything that has .NET Framework 2.0, 3.0, or 3.5 in the name. Those are the ones that Vegas Pro 11.0 needs and will re-install if not present.
[Rob Doe] "Also, when you say to delete all the .NET Frameworks, do you mean all of the ones associated with Sony Vegas Pro 11 (3.5 SP1, 3.0, and 2.0) or all of them up until 4.5.2?"
The former. just the ones need by Vegas Pro 11.0.
[Rob Doe] "And one last thing, i tried using the 3.5 SP1 installer to see if i could repair the Framework, but when i open the installer nothing happens. Oddly enough, the same happened with 3.0 and 2.0. Is this something to do with Windows 8.1? Is Windows 8.1 compatible with Frameworks 2.0, 3.0, and 3.5 SP1?"
Before I answered your original post, I took a fresh install of Windows 8.1 and added Vegas Pro 11.0 to it and Vegas Pro 11.0 installed .NET Framework 3.5, and Windows 8.1 warned me that I also needed 3.0 and 2.0 so I said "yes" to install them, and when all was said and done.... Vegas Pro 11.0 worked perfectly on Windows 8.1. I even ran the "Add Timecode to All Media" script just to be sure and it worked. So yes, this should work. Is it supported? No. But it does work.

I don't know if reinstalling the .NET Framework will fix your situation. I only know that it is causing the problem.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Rob Doe
Re: "Failed to initialize script host" Error (Sony Vegas Pro 11, Windows 8.1)
on Jun 29, 2014 at 8:04:28 pm

Thanks for addressing all of my questions! However, i seem to be confronted with a new problem.

There is no microsoft.net frameworks in my control panel. None of the versions are there (they do all show up in my registry though). Is this the problem? Where can i go to install them? I've went through pretty much every version of microsoft.net framework on Microsoft's website and have been prompted to install something on my pc. Whatever is being installed is not showing up in control panel though, and that is probably the problem.

I appreciate your continuing effort in helping me solve this problem, thanks a ton!


Return to posts index

John Rofrano
Re: "Failed to initialize script host" Error (Sony Vegas Pro 11, Windows 8.1)
on Jun 30, 2014 at 11:40:16 am

[Rob Doe] "There is no microsoft.net frameworks in my control panel. None of the versions are there (they do all show up in my registry though). Is this the problem?"
No it's not a problem. In Windows 8 these are considered Windows Features and are removed using the Turn Windows features on or off option in the Control Panel.


Try to remove them from there.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index


Rob Doe
Re: "Failed to initialize script host" Error (Sony Vegas Pro 11, Windows 8.1)
on Jun 30, 2014 at 5:10:20 pm

That did it for me! Thank you so much for your help, i can finally use Sony Vegas Pro 11 again!


Return to posts index

John Rofrano
Re: "Failed to initialize script host" Error (Sony Vegas Pro 11, Windows 8.1)
on Jun 30, 2014 at 7:39:45 pm

You're welcome, Rob. Glad that got it working for you.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]