FORUMS: list search recent posts

Sony Vegas Pro 13 Color flicker problem

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Aleksandar Joksimovic
Sony Vegas Pro 13 Color flicker problem
on Jun 28, 2014 at 4:16:16 am

Hi all !

I have this strange problem with Sony Vegas Pro 13 64 bit.
Here, check this video






See how the color gets messed up for a second here and there, and that happens often throughout the video.
I recorded that video with Bandicam into AVI file.

Help anyone ?


Return to posts index

Kyle Messenbrink
Re: Sony Vegas Pro 13 Color flicker problem
on Jun 28, 2014 at 4:27:40 am

Just to be sure, watch over your clip WITHOUT it being in Sony Vegas. If the error persists, then you know for sure it's Vegas.
Are you getting the flicker when you are watching the clip in Preview?
Try different rendering templates when rendering the clip.
Is anything happening to your client or desktop when you are on the loading screen?
Try some of these steps and reply back when you attempt them.


Return to posts index

John Rofrano
Re: Sony Vegas Pro 13 Color flicker problem
on Jun 28, 2014 at 2:28:10 pm

[Aleksandar Joksimovic] "I recorded that video with Bandicam into AVI file."
What codec did you use to capture? It looks like you may have used DivX.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index


Aleksandar Joksimovic
Re: Sony Vegas Pro 13 Color flicker problem
on Jun 28, 2014 at 2:32:56 pm

I used x264vfw.


Return to posts index

John Rofrano
Re: Sony Vegas Pro 13 Color flicker problem
on Jun 28, 2014 at 2:34:31 pm

[Aleksandar Joksimovic] "I used x264vfw."
You've correctly identified the problem. Vegas Pro does not like H.264 video in an AVI container. Stop doing that. Try capturing using M-JPEG instead.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Aleksandar Joksimovic
Re: Sony Vegas Pro 13 Color flicker problem
on Jun 28, 2014 at 2:31:46 pm

This doesn't happen if I preview this video in other players like Windows Media Player,Windows Player Classic or VLC Player.
Only happens in Vegas.
Yes this problem does happen when I preview my video in Vegas and when I render the video.(no matter what template I choose)
I also tried "disable resample" option, and that doesn't work.
I have also tried installing different codec packs, K Lite, CCCP, and problem is still there.

Also I figured this only happens with AVI file that Bandicam creates.But If I convert that AVI to MP4 then problem is gone.
But my video is 1 hour long and plus I might lose on quality so I don't feel like doing the convert option.

Any Sony Vegas solution ?


Return to posts index


John Rofrano
Re: Sony Vegas Pro 13 Color flicker problem
on Jun 28, 2014 at 2:36:59 pm

[Aleksandar Joksimovic] "Also I figured this only happens with AVI file that Bandicam creates.But If I convert that AVI to MP4 then problem is gone."
The problem is your capture format then. H.264 in an AVI container is a hack used before MP4 became popular. People are still using it today but it's unsupported by a lot of software because H.264 belongs on an MP4 container not AVI. Don't use H.264 to capture or have Bandicam create a proper MP4 file and not an AVI file.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Norman Black
Re: Sony Vegas Pro 13 Color flicker problem
on Jun 28, 2014 at 6:01:56 pm

[Aleksandar Joksimovic] "But If I convert that AVI to MP4 then problem is gone.
But my video is 1 hour long and plus I might lose on quality so I don't feel like doing the convert option."


You can use a program like Avidemux or ffmpeg to remux your AVI video into an MP4 file and use that MP4 in Vegas. The video/audio is just copied to the new container so it is a quick operation.

Vegas will only support AAC or PCM audio (AFAIK) in MP4 files with your AVC/H.264 video. AVidemux and ffmpeg will allow you to copy video and convert audio if necessary.

That should cover all possibilities without knowing the full details on your file(s).


Return to posts index

Aleksandar Joksimovic
Re: Sony Vegas Pro 13 Color flicker problem
on Jun 29, 2014 at 12:52:35 am

Yea, if I convert the AVI file to MP4, problem does stop, but video file is 1 hour long and 3 GB big.
I guess its my only option.

Thanks.


Return to posts index


John Rofrano
Re: Sony Vegas Pro 13 Color flicker problem
on Jun 29, 2014 at 11:19:55 am

[Aleksandar Joksimovic] "Yea, if I convert the AVI file to MP4, problem does stop, but video file is 1 hour long and 3 GB big. I guess its my only option."
Yea, unfortunately, you have learned a valuable lesson. Never try and edit h.264 in an AVI container with Vegas Pro. This includes DivX, Xvid or any other codec that is h.264 based. It always has glitches like this.

Try to remux them with AviDemux as Normal suggested. This should go very fast because it just places the video in a new container without rendering. It should work very quickly.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Aleksandar Joksimovic
Re: Sony Vegas Pro 13 Color flicker problem
on Jun 29, 2014 at 6:55:40 pm

Haha, yea I have used XVid as well, same thing happens.
OK, I will try with AviDemux, thank you guys :)

Btw, what coded should I use with AVI ? Can you tell me few most popular ones ?


Return to posts index

John Rofrano
Re: Sony Vegas Pro 13 Color flicker problem
on Jun 29, 2014 at 7:38:26 pm

[Aleksandar Joksimovic] "Btw, what coded should I use with AVI ? Can you tell me few most popular ones ?"
AVI was designed for codecs that use Intraframe compression. This means each frame is a complete picture. Codec's like MPEG4 (AVC/H.264) use interframe compression where only some frames are full frames and others are delta frames. You want to use codecs like Motion-JPEG (M-JPEG), Lagarith, Huffyuv, & CineForm with AVI files.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index


Douglas Armkencht
Re: Sony Vegas Pro 13 Color flicker problem
on Aug 2, 2014 at 3:21:19 pm

I have been having a similar problem with files from a video camera that came with a quadcopter package. They, too, were H.264 files in the AVI container. It looks like I'm having luck with converting them AVIDemux, but it doesn't like converting them with sound. Fortunately, I don't need sound for my clips.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]