FORUMS: list search recent posts

Use less CPU

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Joe Morris
Use less CPU
on Jun 7, 2014 at 7:37:19 pm

How do I make Vegas use less CPU when rendering?


Return to posts index

Graham Bernard
Re: Use less CPU
on Jun 8, 2014 at 5:07:13 am

Why? What benefits are you hoping to achieve?

G

Video Content Creator and Potter
PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
Cameras: Canon XF300 + PowerShot SX50HS Bridge


Return to posts index

Steve Rhoden
Re: Use less CPU
on Jun 8, 2014 at 6:30:46 am

Why do you want to use less CPU when rendering?
It's advisable you leave your computer alone during a render process!

Steve Rhoden
(Cow Leader)
Film Editor & Compositor.
Filmex Creative Media.
http://www.facebook.com/FilmexCreativeMedia
1-876-461-9019


Return to posts index


Larry Brewer
Re: Use less CPU
on Jun 8, 2014 at 5:31:21 pm

While everyone is correct in asking why you would want to do this, and most PCs are best left alone during rendering... if this is something you need to do, or if maybe you are just curious how it could be done... then try this. press ctrl, alt, and delete and the same time to open TASK MANAGER. Select the PROCESSES tab. locate VEGAS and right click on it. go to the SET AFFINITY and start unchecking cores.

Having said that.. if your goal is to improve multitasking during rendering, that is not such a good idea for many reasons. Slows down rendering, and it introduces the possibility of a glitch in the render.

On my PC after Vegas is closed and reopened the settings go back to ALL cores running, and that's probably where you need to leave it. Hope this helps! Proceed at your own risk.


Return to posts index

Steve Rhoden
Re: Use less CPU
on Jun 8, 2014 at 8:10:08 pm
Last Edited By Steve Rhoden on Jun 8, 2014 at 8:11:10 pm

I do understand Joe that you want a direct answer, and Larry
has detailed a good solution for the process.
But be aware of many a problem that can arise.

Steve Rhoden
(Cow Leader)
Film Editor & Compositor.
Filmex Creative Media.
http://www.facebook.com/FilmexCreativeMedia
1-876-461-9019


Return to posts index

Norman Black
Re: Use less CPU
on Jun 8, 2014 at 10:00:05 pm

If you are looking to use your PC while it it rendering there are two things you can do.

Set the number of render threads in video prefs to some amount less than the number of cores (or logical CPUs).

Or better yet. Open the task manager and find the Vegas process and right click and set its priority to Below Normal. Vegas 13 is vegas130.exe in the task manager. Vegas 12 vegas120.exe.

With the priority below normal, then when you are doing something on the PC it will get priority for CPU cycles. When you are not doing anything, then the render will get full CPU cycles. Even when you are doing something the background process can get full CPU cycles because e.g. when you are browsing and reading something, nothing is really going on.

This Below normal priority thing is typically how external encoders default. Handbrake is an example.

Too bad Vegas does not give us a preference for encoding priority, but it is easy enough to do.


Return to posts index


Aleksey Tarasov
Re: Use less CPU
on Jun 10, 2014 at 4:37:06 am

> "Too bad Vegas does not give us a preference for encoding priority"

Norman, Vegasaur Render Assistant has this feature:


Return to posts index

Norman Black
Re: Use less CPU
on Jun 10, 2014 at 7:45:48 pm

One problem with lowering the priority of an encode is screen savers. If you actually walk away and the screen saver kicks in it will likely steal CPU cycles from the encode. Screen savers tend to run at normal priority.


Return to posts index

Graham Bernard
Re: Use less CPU
on Jun 11, 2014 at 5:03:45 am

[Norman Black] " If you actually walk away and the screen saver kicks in it will likely steal CPU cycles from the encode."

Norman speaks the TRUTH! - I was working on another "TouchScreen" PC. I was having real issues with getting straightforward DVD prep, until . . . Got to the MS screen saving menus and killed 'em. That and the wandering Power Saving options. Once these were tamed rendering was likety spit!

Grazie

Video Content Creator and Potter
PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
Cameras: Canon XF300 + PowerShot SX50HS Bridge


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]