FORUMS: list search recent posts

Disable resample on interlaced video source but retain deinterlaced interpolation?

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Rick Anvican
Disable resample on interlaced video source but retain deinterlaced interpolation?
on May 6, 2014 at 12:12:06 pm
Last Edited By Rick Anvican on May 7, 2014 at 1:00:31 pm

Hi all,
I have this interlaced source video (50i) which needs an effect or two applied, but
the Vegas project needs to be rendered as progressive (59.94p, not 50p), the project is using
Interpolate Fields as its deinterlace method, however as source and project
framerate are mismatched and with Smart Resample enabled, there is unwanted blending,
I'm assuming that resampling occurs after deinterlacing.

I disabled Smart Resample, which the blending disappeared but the source
runs at 25p(not smooth) after deinterlacing instead of 50p (it has interpolated
frames but half of them are missing), what I wanted was the source to
be deinterlaced from 50i to 50p using interpolation but duplicate frames (not blend)
to fill in the 60p timeline. Currently looking at alternative methods to do this,
any ideas?

I could do the following:
deinterlace 50i to 50p
render 50p
import 50p into 59.94p timeline and <b>Disable Resample</b>
render 59.94p
but most sources I have that I want to use are interlaced, so that would
be a lot to do...

Thanks,
RickAVC


Return to posts index

John Rofrano
Re: Disable resample on interlaced video source but retain deinterlaced interpolation?
on May 9, 2014 at 5:22:54 pm

[Rick Anvican] "deinterlace 50i to 50p"
I just want to be sure that you understand that 50i is 25 frames per second. The "i" standard for "interlaced fields" where it takes 2 fields (odd and even) to equal one frame. So your video is currently 25 frames per second. Deinterlacing 25 fps video will give you 25 fps video because interlacing has nothing to do with frame rate. So Vegas will deinterlace 50i into 25p.

If you are saying that you want to make 50i into 50p by splitting the fields into frames by doubling the fields (via interpolation) then you can try and set your project to 50 fps, progressive, interpolate fields, and make sure Smart Resample is enabled and render to 50 fps, progressive. That should produce a 50p file that uses each field as a frame but it might just blend the frames instead. I'm not sure which Vegas will do and I don't have any interlaced footage handy to try it. You would still need to render this as 60p later and this time disable resample so that it doubles frames where needed.

You are correct that it take several steps but what you are trying to do is not normal so you would have to expect that the workflow is more involved.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Rick Anvican
Re: Disable resample on interlaced video source but retain deinterlaced interpolation?
on May 10, 2014 at 1:42:52 am

Hi John,
Thanks for replying, I understand that 50i is 25 frames/50 fields per second and will deinterlace to 25p, I know that interpolating fields from the 50i source to a 50p timeline produces no unwanted blending usually, but I'm not sure if the resample switch has correlation to the behaviour of discarding frames made after field interpolation/doubling.

For example, if I set Deinterlace method to None in a 50p timeline, the 50i source would show up interlaced regardless of resample switch(i.e. unseparated fields in the preview), when I set to Interpolate Fields and Disable Resample on the event, the preview is deinterlaced correctly to fields (i.e. no interlaced lines) but it reverts to 25p (i.e. only 25 of the 50 frames per second made from field interpolation remain), I think this is part of Resample's nature if there's no other explanation for it.

RickAVC


Return to posts index


John Rofrano
Re: Disable resample on interlaced video source but retain deinterlaced interpolation?
on May 10, 2014 at 12:55:15 pm

[Rick Anvican] "I'm not sure if the resample switch has correlation to the behaviour of discarding frames made after field interpolation/doubling."
I would have to do some tests to observe the behavior in Vegas. Normally Deinterlace and Resample have nothing to do with each other. Deinterlace works on a single frame. Resample works on synthesizing a third frame from two adjoining frames. If you turn resample off, Vegas will simply duplicate existing fames to correct for the frame rate.

As you know, interpolation throws away one field (or half of your resolution). The behavior you are looking for would take the odd fields to create one frame and the even fields to create the next. I read the leaving Smart Resample on will create this behavior but I haven't confirmed this so it might not. You should test and see.
[Rick Anvican] " if I set Deinterlace method to None in a 50p timeline, the 50i source would show up interlaced regardless of resample switch(i.e. unseparated fields in the preview)"
If you have source that is interlaced, you NEVER want to set Deinterlace to None regardless of what your project properties are. Interlaced source video requires a deinterlace method to be set unless you are manually using a 3rd party deinterlacer.
[Rick Anvican] "when I set to Interpolate Fields and Disable Resample on the event, the preview is deinterlaced correctly to fields (i.e. no interlaced lines) but it reverts to 25p (i.e. only 25 of the 50 frames per second made from field interpolation remain), I think this is part of Resample's nature if there's no other explanation for it."
As I said, if you turn Resample Off then Vegas will simply duplicate frames. It will take the 25 frames and make a copy of each to get to 50. If you want to synthesize new frames, you need to have Resample turned On.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Rick Anvican
Re: Disable resample on interlaced video source but retain deinterlaced interpolation?
on May 10, 2014 at 2:26:28 pm

John,
I understand that for interlaced sources I shouldn't have the project's deinterlace method
set to None, I was only trying to describe what I saw in the preview (at Best|Full)
with a 50p timeline:

Deinterlace method None: both fields in same frame (has interlaced lines artifacts)

Deinterlace method Interpolate Fields:
Smart resample: fields separated into individual frames with frame sequence A,B,C,D,E,F,G...
Disable resample: same as above(i.e. no interlaced line artifacts) but with frame sequence
A,A,C,C,E,E,G,G,...

If Deinterlace and Resample don't affect each other, I assume that by setting the
deinterlace method to Interpolate Fields, the interlaced source should be
deinterlaced where each field has its own frame (i.e. from AB,AB,CD,CD,EF,EF,...
to A,B,C,D,E,F,... assuming it is in a 50p timeline), but maybe I'm just picky
this time...


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]