FORUMS: list search recent posts

Vegas Pro Generic Control - doesn't work in 15 but seems does in 14

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Sonic Vision
Vegas Pro Generic Control - doesn't work in 15 but seems does in 14
on Mar 22, 2018 at 6:29:27 am

Hello,

Any advice for Vegas Pro Generic Control ?

I'm trying to setup my MIDI Control Surface and have some basic transport functions working in VP14 but nothing at all in VP15 (all same settings).

I have done extensive setup in Digital Audio Workstations and was really hoping to get this going VP15.



Return to posts index

Graham Bernard
Re: Vegas Pro Generic Control - doesn't work in 15 but seems does in 14
on Mar 22, 2018 at 2:36:45 pm

MCU. I’ve got a PreSonus FaderPort8 and I’ve got some control. What you got and what has happened so far?

* Grazie

Video Content Creator and Potter
PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
Cameras: Canon XF300 + PowerShot SX50HS Bridge


Return to posts index

Sonic Vision
Re: Vegas Pro Generic Control - doesn't work in 15 but seems does in 14
on Mar 23, 2018 at 2:09:00 am

Thanks for your reply.

I have tried both Generic and MCU and neither do a single thing. They both do work in VP14.

Quite frustrating.



Return to posts index


Graham Bernard
Re: Vegas Pro Generic Control - doesn't work in 15 but seems does in 14
on Mar 23, 2018 at 5:02:10 am

Do make sure VP14 isn’t being active as a Control Surface when you check out VP15. Be assured it does work in VP15. And yes, it’s very frustrating.

* Grazie

Video Content Creator and Potter
PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
Cameras: Canon XF300 + PowerShot SX50HS Bridge


Return to posts index

Sonic Vision
Re: Vegas Pro Generic Control - doesn't work in 15 but seems does in 14
on Mar 23, 2018 at 8:04:18 am

I'm assuming if I have completely closed VP14 then it isn't conflicting. Even before I tried all this in VP14 it woudn't work in VP15. That is what lead me to trying VP14 and finding out it is working there.



Return to posts index

Graham Bernard
Re: Vegas Pro Generic Control - doesn't work in 15 but seems does in 14
on Mar 23, 2018 at 8:31:02 am

[Sonic Vision] "I'm assuming if I have completely closed VP14 then it isn't conflicting."
Yeah, so would I . . . Just try and disable anything MIDI Control Surface or anything related in VP14 and then start over with VP15.

* Grazie

Video Content Creator and Potter
PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
Cameras: Canon XF300 + PowerShot SX50HS Bridge


Return to posts index


Sonic Vision
Re: Vegas Pro Generic Control - doesn't work in 15 but seems does in 14
on Mar 24, 2018 at 6:53:57 am

Still nada.



Return to posts index

Graham Bernard
Re: Vegas Pro Generic Control - doesn't work in 15 but seems does in 14
on Mar 24, 2018 at 7:55:31 am
Last Edited By Graham Bernard on Mar 24, 2018 at 7:57:47 am

[Sonic Vision] "Still nada."
Hmm...

This is what I have.

Timeline with that RED Alert Line on the Track Header:



Have you got these setup correctly?
MIDI Tab:

External Control and Automation:


"External Control" - Activated under Options:


And finally this is what I get when played and the Latched and Written Volume Envelope using the Faders on the Presonus FaderPort8:


* Grazie

Video Content Creator and Potter
PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
Cameras: Canon XF300 + PowerShot SX50HS Bridge


Return to posts index

Sonic Vision
Re: Vegas Pro Generic Control - doesn't work in 15 but seems does in 14
on Mar 26, 2018 at 1:22:15 am

Good Sir Graham!

I most appreciated this clear pictorial! You solved the issue!

It was the 2nd to last screen shot "Options Menu > External Control > Checked". Mine wasn't checked, doh!

Thank you, thank you!

I owe you a beverage ☺

Grazie!!!



Return to posts index


Sonic Vision
Re: Vegas Pro Generic Control - doesn't work in 15 but seems does in 14
on Mar 26, 2018 at 7:34:54 pm

Graham,

I do have another question, if you don't mind:

I believe you are using MCU - are you able to edit the functions? I know how to this in the Generic mode but in MCU I can't figure it out, if it's even possible. I have lots of buttons, and some knobs, on my surface and it would be nice to be able to assign them so I know what is where. Right now all I know is fast forward, rewind, play, stop, record and jog/shuttle wheel (all transport commands).

In the Generic editor I can set these but the jog/shuttle won't work like it does in Mackie MCU mode.

So I can have a decent transport and shuttle wheel setup in MCU, or assignable functions in Generic but non working shuttle ☺

Finally is there way to mark a post as "Resolved". Most forums I can edit a post to state that but haven't found any such thing here.

Thanks.



Return to posts index

Graham Bernard
Re: Vegas Pro Generic Control - doesn't work in 15 but seems does in 14
on Mar 26, 2018 at 8:05:41 pm

[Sonic Vision] "I believe you are using MCU - are you able to edit the functions?"
Yes, MCU. When you say edit functions do you mean assign KEYS on your external controller to functions within Vegas? Then yes, yes I can using MCU. BUT, depending on your Control Surface - mine's that Presonus FaderPort8 - it is limited and not a smooth ride!

[Sonic Vision] "I know how to this in the Generic mode but in MCU I can't figure it out, if it's even possible."
Sure, that could be the case. I don't use Generic and stayed with MCU. Does your Control Surface allow for MCU Emulation?

* Grazie

Video Content Creator and Potter
PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
Cameras: Canon XF300 + PowerShot SX50HS Bridge


Return to posts index

Sonic Vision
Re: Vegas Pro Generic Control - doesn't work in 15 but seems does in 14
on Mar 26, 2018 at 10:19:04 pm

Yes, my surface does MCU emulation and that is working mainly for some transport fucntions.

I would like to try to assign/reassign functions within MCU emulation. I saw something not too clear wording on this in the Vegas manual.

As you found, I expect it won't be a smooth ride.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]