FORUMS: list search recent posts

Getting Interlace looking edges when rendring - screen shot attached

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Don Cobble
Getting Interlace looking edges when rendring - screen shot attached
on Apr 11, 2017 at 10:04:30 pm

I am trying to render out GV HQX 10bit AVI files to ProRes mov. The Edges look like I rendered interlace? I have attached screen shots (I think) of settings and a jpeg capture of the screen zoomed in so you can see what I am talking about. I have tried every setting I know about.
Thank you for help
dc


Return to posts index

Don Cobble
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 11, 2017 at 10:06:54 pm







Return to posts index

Marco Baer
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 11, 2017 at 10:36:31 pm

Which version and which build of Vegas Pro do you use?

Did you check your rendered ProRes video inside Vegas Pro?

What does MediaInfo say about the properties of the rendered ProRes file?

Hope you are aware Vegas Pro can't process GV HQX as 10 bit but will process as 8 bit instead.


Return to posts index


Don Cobble
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 12, 2017 at 12:54:28 am

Build Vegas Pro 14 Build 244

[Did you check your rendered ProRes video inside Vegas Pro?]
Yes it is what I took the still of

ProRes Info:


I did not know that about no 10 bit processing, I do not understand enough to know, would that cause that look?

I need the files to end up in ProRes, I think it is the way the files are interpreted by Vegas Pro because even the AVI files look that way in Vegas.

I receive most of my files in GV HQX 10 bit and they seem really only compatible efficiently, with Edius I think?

Thank You
dc


Return to posts index

László Kovács
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 12, 2017 at 6:11:27 am

Hi Don,

Is it possible by any chance, that your source footage is really interlaced, and wrongly detected by Vegas as progressive?
The opposite happens to me every time I use a secondary cam Canon XA10 set to 25P.
Vegas always interprets the file as interlaced, however it is progressive. I have to flag it manually as progressive.
You may want to flag your source as interlaced.

Best regards

László Kovács


Return to posts index

Lisa Defelice
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 12, 2017 at 5:57:03 pm

László,
I thought that might be the case so I went into properties and changed it to upper field first, which is how it is recognized in Edius (the native NLE for the codec). But it does not change that interlaced look? I did not if there was a setting to de-interlace the clip that i do not know about.

My current workflow due to this problem is to take the HQX clips into Edius render the clips out to XAVC then take them into Vegas pro color match - then export to ProRez.

I was trying remove the Edius step and go from Vegas to ProRes.
Thank You
Don


Return to posts index


Guillaume Jeffrey
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 13, 2017 at 2:09:07 am

For Interlaced footage, set your project properties to Interlace, not Progressive.
It should then work as expected.


Return to posts index

Lisa Defelice
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 12, 2017 at 6:05:49 pm

László,
So you dont get confused i work with Lisa Defelice and she was in the forum so i responded with her account
Thank You
Don

IMAC Retina 5K 27in
4.Ghz i7 32gb Ram
AMD R9 M395X 4Mb
El Capitan


Return to posts index

László Kovács
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 13, 2017 at 5:25:15 am

Hi Don and Lisa ☺
No problem.

Vegas sometimes does not detect correctly weether a file is interlaced or not. I think this is the reason it has the option to set it manually. If you need progressive output, but have interlaced footage, deinterlacing has to be done.
Vegas does not deinterlace a footage it thinks it is progressive. So tell Vegas that it is interlaced, set media proerties as you mentioned you did. If you render a progressive project to progressive output format, the interlaced media will get deinterlaced with the method set in the project properties (blend/interpolate/adaptive (Vegas14)).
Note, that there are different render and preview, render qualities. In draft, preview, Vegas omits deinterlacing.
Good and best includes the deinterlacing, if it is needed. So to really get your footage deinterlaced you need:
-footage marked as interlaced (if movement is jittery/jerky, the field order is reversed)
-render to a progressive format (render quality set to good or best)
-a deinterlace method set in project properties. If it is set to "none", then the deinterlace will be done with the "none" method...

The similar applies to preview, so if you preview your timeline, and preview quality is set to draft/preview, Vegas will not deinterlace the preview. Set preview quality at least to "good" (preferably good-full), so in your preview the deinterlacing will be present.
I hope I could help ;)

Best regards

László Kovács


Return to posts index


Don Cobble
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 15, 2017 at 2:03:56 pm

László,
Thank You for all the information. I will give these settings you have said a try. I did not know about the preview monitor settings, not showing deinterlace !

If I may ask you another monitor setting question, Should I have the monitor set to computer RGB during edit and then turn the filter off when rendering?
Thank You
Don


Return to posts index

László Kovács
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 15, 2017 at 4:12:30 pm

Hi Don,

In my workflow I use computer RGB all across the entire project, as well as on preview.
I adjust colors to 0..255 range from my source footages. For me this is easyer for me to maintain the colors and see on my monitor.
When I need to render to a 16..235 target (say mpeg2 for DVD or avc for youtube), before actually doing the render, I do apply the levels FX (with the computer RGB to Studio RGB preset) to the video out (it's over the preview window).
That makes the picture look a bit washed on the monitor, but this is how it's going to be good in the target file.
Also, if there are tranparent parts anywhere in my project, I dedicate a full solid black color track on the most-below track.
Because if you fade out an event, and there's nothing below it, it really gets transparent instead of a real black. Levels FX doesn't touch that transparent "black", and sends it as 0 black -illegal level- to the encoder instead of a 16 black.

Best regards

László Kovács


Return to posts index

László Kovács
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 15, 2017 at 4:14:09 pm

Oh, forgot to say happy easter! ☺

Best regards

László Kovács


Return to posts index


Don Cobble
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 15, 2017 at 10:50:38 pm

Laszlo,
I still have a problem in Magix Vegas Pro 14 - I assume it a setting, because I have not heard of anyone else complaining about no deinterlacing. I took the same footage into Sony Vegas Pro 13 and in the settings you can choose deinterlace blend and it smooth's right out. I see the same choices in Magix -VP14 but it is not working?? If I could render out ProRes in VP13 I would just use it instead of MVP14.

Thank You Happy Easter to you! - He has Risen! ☺
Don


Return to posts index

László Kovács
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 16, 2017 at 8:35:22 pm

Indeed, He has Risen. ☺

I get 45 minutes of interlaced media every week, and I use them in progressive projects. Deinterlace works for me in Vegas14 (though I'm still on build 211 - didn't upgrade to the latest). Also, what I get so is always regular AVC recordings, not something special 10 bit thing..
I can think of 2 things if deint. doesn't work for you:
-you don't render/preview using "good" or "best" setting
-there's a special bug in V14 which gets noticeable with your file formats.
Could you send me a short sample from your source, so that I can experiment with it? If yes, I'd send you a link where to put that sample - contact me privately:
info (at) kovacsoltvide.hu

Best regards

László Kovács


Return to posts index

László Kovács
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 16, 2017 at 8:41:44 pm

Sorry. There's no way to edit a post, and I mistyped my e-mail. Oooops.
Correctly: info (at) kovacsoltvideo.hu

Best regards

László Kovács


Return to posts index


Don Cobble
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 23, 2017 at 11:54:47 pm

Laszlo,
Thank you for all your help. It was the (clip level) setting that had to be set to (upper field) not the project setting. I looked through all the settings you sent and noticed my clips were set (progressive) and you had the clips set upper field. I had it backwards, I had my project properties set to upper field and the clips progressive.
So now it deinterlace's fine. I can now convert to ProRes 422 looks great.

Thank You - köszönöm!
Don


Return to posts index

László Kovács
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 24, 2017 at 7:37:14 am

You are most welcome!
(Nagyon szívesen!)

Best regards

László Kovács


Return to posts index

Don Cobble
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 27, 2017 at 1:15:13 am

Laszlo,
One more question on deinterlcing, please. Now that I see that changing to upper field on the clip level starts the blending of fields, do I need the project setting upperfield or progressive?
I am going to output DNxHD 1080 29.97P and ProRes 1080 29.97P

Thank You
Don


Return to posts index


László Kovács
Re: Getting Interlace looking edges when rendring - screen shot attached
on Apr 28, 2017 at 4:59:16 am

Hi Don,

I always keep project settings that matches the output.
So I'd keep it progressive.

Best regards

László Kovács


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]