FORUMS: list search recent posts

Vegas Pro After-Render Video Pixelation/Sharp Gradient Problem

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Liubomir Smekhov
Vegas Pro After-Render Video Pixelation/Sharp Gradient Problem
on Jan 26, 2017 at 5:26:00 pm

I have a MOV-file directly from Canon DSLR. And as stated above, I have a post-render issue with video image quality. Meaning I have a perfect image in Vegas preview window but after rendering it the video becomes somewhere heavy pixelated and gradients have very sharp edges. To get a better idea of what I'm talking about, I added screenshots.
First screenshot is what Vegas preview window displays:

(After uploading the image here the quality went down, so just note that original screenshot is cleaner, for which I've provided the link to original screenshot just in case you'd like to make sure.) 10998_image1.jpg.zip

Second screenshot is what I see after the render - the resulting video file (no matter which player I use):

Again, just in case here's the original screenshot: 10999_image2.png.zip

The difference is drastic: in Vegas's preview window I see clean image with smooth beautiful gradients. After rendering it - heavily pixelated areas with sharp-edged gradients.
My Project Settings:


Steps I've already tried (with no luck obviously):
- disabling resampling in timeline event's properties
- matching project and render settings
- using 8-bit and 32-bit with floating point project settings
- rendering to different formats (MP4, WMV, AVI)
- using different render codecs (AVC, AVCHD, H264)
- converting original MOV-file into editing codec beforehand (Avid DNxHD, Cineform)
- bypassing all the FXs
- using two-pass on variable bitrate
- using constant bitrate instead of variable

None of the above solved the problem. With FXs bypassed the problem is simply less visible due to less contrasty image but still there.

After all I've come to two conclusions:
- either all the render settings I've tried were wrong (chosen codec, settings, bitrate, etc)
- or my system (Windows 7 x64) is missing some codecs/other minor software.

Can anyone shed any light on the issue? Maybe I'm missing the very process of rendering straight-out-of-the-preview-window-quality-image video in Vegas PRO? Cause I have run out of options.
Thank you

P.S. will provide any info requested.


Return to posts index

Aaron Star
Re: Vegas Pro After-Render Video Pixelation/Sharp Gradient Problem
on Jan 27, 2017 at 6:18:34 am

What is your camera / timeline source footage format , codec, and bitrate?

What is your Render As settings when you render out to say AVC/.264?

What it looks like to me from the images posted is 8-bit banding due to a low bitrate.


Return to posts index

Liubomir Smekhov
Re: Vegas Pro After-Render Video Pixelation/Sharp Gradient Problem
on Feb 11, 2017 at 12:53:59 pm

Thank you for your answer and I'm sorry for that late reply, for some uknown reason I haven't been receiving notifications about answers in this topic.

The camera was Canon 60D, timeline source footage had .MOV format as such as it went directly from the camera. I'm not sure the in-camera codec used and the bitrate, so here is Mediainfo printscreen of that very footage:



Render As settings for AVC:


Render As settings for H.264:


"8-bit banding due to a low bitrate"
After you've mentioned that I realise that indeed might have been the problem. But I suppose this 8-bit has nothing to do with timeline source footage bitrate which is around 42-44 Mb/s, as those represent completely different characteristics of the video, right? If so how do I properly set the camera shooting settings and/or project settings to avoid 8-bit banding?
Thank you very much for your help.

P.S. By the way, question is still there - if the problem seem to be with timeline source footage why do I see perfect image in Vegas preview window anyway?


Return to posts index


Steve Rhoden
Re: Vegas Pro After-Render Video Pixelation/Sharp Gradient Problem
on Feb 5, 2017 at 4:40:54 am

The issue is with your chosen render settings, simple!

Steve Rhoden (Cow Leader)
Film Maker & VFX Artist.
Owner of Filmex Creative Media.
Samples of my Work and Company can be seen here:
http://www.facebook.com/FilmexCreativeMedia


Return to posts index

Liubomir Smekhov
Re: Vegas Pro After-Render Video Pixelation/Sharp Gradient Problem
on Feb 11, 2017 at 1:01:23 pm

Good point.
In my answer to Aaron above I provided my Render As settings using AVC and H.264. Can you please point out what settings might be wrong to your mind and give any advice on how I can improve my render settings in this case?
Appreciate your help.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]