FORUMS: list search recent posts

Vegas 14 Pro Suite - Can't find NewBlueFX Titler Pro/Looks

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
David West
Vegas 14 Pro Suite - Can't find NewBlueFX Titler Pro/Looks
on Oct 27, 2016 at 10:57:37 pm

Hey guys, I apologize if this is a really, really stupid question, but after upgrading from my very-well-used copy of Vegas Pro 12 to the Vegas Pro 14 Suite yesterday I cannot for the life of me figure out how to get the NewBlueFX looks and Titler Pro 3 working. I managed to get the proDad Mercalli plugins and BorisFX effects working easily enough, but I can't find anywhere online to download NewBlueFX Titler 3 or even figure out how to access the NewblueFX looks at all. It's pretty frustrating so any help would be greatly appreciated!


Return to posts index

Francois Pénzes
Re: Vegas 14 Pro Suite - Can't find NewBlueFX Titler Pro/Looks
on Oct 28, 2016 at 5:00:06 pm

Hi David

This is the e-mail you should have received from Magix (Ya, mine was in French but still, it would look the same in English) And for obvious reasons, the numbers are blank out but the last line is for the Titler Pro and Looks Try re-installing from your original Magix e-mail and if you have any problems, Edward from support at NewBlue will get you on your way promptly.

Any other bundled version (V11, V12, V13) will have a watermark.

Cheers !



Return to posts index

Francois Pénzes
Re: Vegas 14 Pro Suite - Can't find NewBlueFX Titler Pro/Looks
on Oct 28, 2016 at 5:15:50 pm

Hi David

Forgot to add this: Please also see this thread.

https://forums.creativecow.net/thread/24/1013876

Cheers !

PC Win 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz NVIDIA GEFORCE GTX 550 Ti
Cameras: Canon XF305 + Canon XH-A1

''When the cutting stops, the editing begins...''


Return to posts index


David West
Re: Vegas 14 Pro Suite - Can't find NewBlueFX Titler Pro/Looks
on Oct 28, 2016 at 5:20:28 pm

Huh... My email doesn't look like that at all. I do have all the serial numbers, though. I think I've figured out what my problem is, though. I just used my serial number to activate the trial version of the program that I'd been using instead of installing the actual "suite" version linked to in the email. Stupid mistake I guess!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]