FORUMS: list search recent posts

Interlacing issue in Vegas Pro 13

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Martin Stanesby
Interlacing issue in Vegas Pro 13
on Jul 5, 2016 at 11:24:53 pm

I wonder if someone can shed some advice on this issue for me....

I am working in a 1080 50i project in Vegas Pro (upper field first) with 50i footage shot on a Canon C100 mkii. The footage appears ok. But if I crop and zoom in you can clearly see the awful field lines? It just distorts the image. I usually work progressive but this project needed to be interlaced. I've never had this issue with progressive.
Is this right with interlaced footage? I know it won't look the best on a PC/laptop LCD monitor as progressive but as bad as this?
If I de-interlace (blend/interpolate) in the project settings it solves it, but what if I want this project interlaced?


Below are images of the differences

Original


Zoomed


Zoomed further


Zoomed further still



As you can see, the further it's cropped and closer it becomes....the finer the lines become?

I appreciate any help.

Thanks
Martin


Return to posts index

john bolton
Re: Interlacing issue in Vegas Pro 13
on Jul 6, 2016 at 7:32:14 am

Have to tried to Disable Resampling from the Time line properties ? It does cause that wobbling appearance..


Return to posts index

Graham Bernard
Re: Interlacing issue in Vegas Pro 13
on Jul 6, 2016 at 7:36:35 am

[Martin Stanesby] " 50i footage shot on a Canon C100 mkii."
Are you sure that that footage is 50i? Did you "Match Media" for your Project Settings or manipulate the settings manually yourself?

* Grazie

Video Content Creator and Potter
PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
Cameras: Canon XF300 + PowerShot SX50HS Bridge


Return to posts index


Graham Bernard
Re: Interlacing issue in Vegas Pro 13
on Jul 6, 2016 at 7:50:14 am

Just when and where in your workflow are you seeing these de-interlace "steps" artifacts? In Vegas? After Render? Viewed in a 3rd Party Player?

* Grazie

Video Content Creator and Potter
PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
Cameras: Canon XF300 + PowerShot SX50HS Bridge


Return to posts index

Martin Stanesby
Re: Interlacing issue in Vegas Pro 13
on Jul 6, 2016 at 8:05:30 am

Thank you both for your replies.

I always disable resample.
The C100 setting was AVCHD 50i so I'm sure it was, and it looks so different to my progressive footage. I didn't match media, maybe I should see what it suggests if I did, but the media settings gs are the same as the clip properties.

I am seeing this within sony vegas pro time line.

Thanks again for your help.
Martin


Return to posts index

John Rofrano
Re: Interlacing issue in Vegas Pro 13
on Jul 7, 2016 at 4:22:47 am

What is your deinterace setting in your project properties? If it's set to None, that's what's causing the problem.

~jr

http://www.johnrofrano.com
http://www.vasstsoftware.com



Return to posts index


Martin Stanesby
Re: Interlacing issue in Vegas Pro 13
on Jul 7, 2016 at 9:53:00 am

Hi John,
Thanks for the response.

Yes you are correct it is set to none. However, it's no de-interlacing that I'm wanting to do. This does resolve the issue by de-interlacing, but I needed to produce an interlaced 50i project which may be used for broadcast.

I have since done some tests and found the combing field lines are visible on my work flow on a PC monitor due to the monitor being progressive. Once produced a clip on DVD it resolved this fine. However, the zooming in on an interlaced clip of footage would need to be de-interlaced first as this, so I've now heard, cannot be done as it makes the field lines worse effectively.

Martin


Return to posts index

John Rofrano
Re: Interlacing issue in Vegas Pro 13
on Jul 8, 2016 at 3:41:41 am

[Martin Stanesby] "Yes you are correct it is set to none. However, it's no de-interlacing that I'm wanting to do. This does resolve the issue by de-interlacing, but I needed to produce an interlaced 50i project which may be used for broadcast."
It's not about what you want to do. It's about what Vegas Pro needs to do. If you have interlaced footage you MUST select a deinterlace method because Vegas Pro may need to deinterlace the footage to process it and then re-interlace it. If you disable this, you will only get horribly squiggled video like in your example.

This has nothing to do with delivering interlaced video for broadcast. This is purely about Vegas Pro processing the video internally. Essentially what this parameter is asking is, "If Vegas should need to deinterlace the video for any reason, which method should it choose?" It doesn't cause the video to be deinterlaced. It just tells Vegas how to handle deinterlacing when it needs to. For example, if you zoom in, Vegas needs to first deinterlace the video, then zoom in, then reinterlace it. By selecting None, it is zooming in without deinterlacing which makes the interlacing look like big squiggles.

~jr

http://www.johnrofrano.com
http://www.vasstsoftware.com



Return to posts index

Martin Stanesby
Re: Interlacing issue in Vegas Pro 13
on Jul 8, 2016 at 7:01:05 am

Hi John,
Thanks for the advice.
That's rather confusing then...if it's not about deinterlacing the footage...why does Vegas call this option 'deinterlace'? I would h ae thought Vegas would default this option if interlaced footage MUST be deinterlaced....why have the option for none??

Thanks
Martin


Return to posts index


John Rofrano
Re: Interlacing issue in Vegas Pro 13
on Jul 8, 2016 at 11:39:14 am

[Martin Stanesby] "if it's not about deinterlacing the footage...why does Vegas call this option 'deinterlace'?"
Sorry if I didn't explain it clearly. It absolutely is about deinterlacng the footage but not about you "wanting" the footage to be deinteraced but rather Vegas Pro "needing" the footage to be deinterlaced to perform some operations. Confusing I know.
[Martin Stanesby] "I would h ae thought Vegas would default this option if interlaced footage MUST be deinterlaced....why have the option for none?? "
It's an option because you might want to use a 3rd part deinterlacer like the one that comes with Boris Continuum Complete. So Sony gives you the option of using theirs or providing your own but you need to provide your own deinterlacer if your footage is interlaced and you set this to None. They forget to warn you about that one and allow you to "shoot yourself in the foot".

~jr

http://www.johnrofrano.com
http://www.vasstsoftware.com



Return to posts index

Martin Stanesby
Re: Interlacing issue in Vegas Pro 13
on Jul 8, 2016 at 3:30:58 pm

Hi John,
So even though Vegas needs to deinterlace.......will the project still be interlaced when rendered? I'm presuming so as this is the point to shooting interlaced and having an interlaced project running. Otherwise I'd be really confused.....

Thanks
Martin


Return to posts index

John Rofrano
Re: Interlacing issue in Vegas Pro 13
on Jul 10, 2016 at 12:23:55 am

[Martin Stanesby] "So even though Vegas needs to deinterlace.......will the project still be interlaced when rendered?"
The Project will retain the properties of the project settings. So if you set up the project to be interlaced, Vegas will keep everything interlaced. How you render the project is completely a separate thing. You can render it as interlaced or progressive. But setting the project properties to be interlaced and selecting an appropriate deinterlace method (like Blend Fields) will keep everything interlaced throughout the editing process.
[Martin Stanesby] "I'm presuming so as this is the point to shooting interlaced and having an interlaced project running. "
Yes, exactly!

~jr

http://www.johnrofrano.com
http://www.vasstsoftware.com



Return to posts index


Martin Stanesby
Re: Interlacing issue in Vegas Pro 13
on Jul 10, 2016 at 4:17:23 pm

Thanks John,
That's helped lot.
As always....thanks for your sound expert advice.

Martin


Return to posts index

John Rofrano
Re: Interlacing issue in Vegas Pro 13
on Jul 12, 2016 at 2:03:40 pm

You're welcome. Glad I could help.

~jr

http://www.johnrofrano.com
http://www.vasstsoftware.com



Return to posts index

Graham Bernard
Re: Interlacing issue in Vegas Pro 13
on Jul 7, 2016 at 10:00:56 am

[John Rofrano] "If it's set to None, that's what's causing the problem."
John, look at the first post. I'd surmised from this he'd applied a deinterlace method and not "None". What do you think?

* Grazie

Video Content Creator and Potter
PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
Cameras: Canon XF300 + PowerShot SX50HS Bridge


Return to posts index


Martin Stanesby
Re: Interlacing issue in Vegas Pro 13
on Jul 7, 2016 at 11:58:07 am

Yes Grazie, to be clear I have tried and tested de-interlace and this was fine and looks ok, as mentioned in the post. However, I am wanting this footage to remain interlaced.
As mentioned in my reply to John, I have concluded the field lines will be visible in my work flow as I am viewing on a progressive monitor until either played on DVD (my test worked fine) or broadcasted.

I had this below reply with regards to the zooming/cropping which was making it look worse:

"OK
I'm assuming you understand that in interlaced footage, the camera alternately records odd and even scan lines In other words filming at 1080/50i The image is split into 1080 lines and in the first 50th of a second the camera records 540 "even" lines with the image in position "A", then in the next 50th of a second it will record the "odd" lines of the image in position "B", so if you superimpose the first image onto the second you will get a very fine "comb" effect.

But, in the normal course of events, we don't superimpose one on top of the other we show them alternately and our eyes are tricked into seeing a nice smooth motion image.

Now imagine what happens if you zoom in - lets say to double height.
Each one of your lines now takes up the height that two lines previously took up so your "odd" line is now split across one odd and one even "output" line (for want of a better way of describing it). In other words half of the image from the lines that were in "position A" are now being replaved on the second 1/50th of a second. Depending on how much you zoom in, you can see that the effect of doing this will differ which is exactly the phenomenon we can see above.

You need to de-interlace any footage if you are going to zoom even if your output will be interlaced.

(It took me a while to understand this as well as it sounds contrary to what we are trying to do)."


So I'm clearer now.
Thanks
Martin


Return to posts index

Bob Mark
Re: Interlacing issue in Vegas Pro 13
on Jul 8, 2016 at 3:05:48 pm

Yes, many broadcasters still use interlaced formats. So the "jaggies" live on. Sorry, I don't have a good answer for you.
I have usually selected "blend fields."

Here is an interesting article. http://www.cnet.com/how-to/1080i-and-1080p-are-the-same-resolution/

Bob


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]