FORUMS: list search recent posts

New Worry: Older versions will be activate-able for 5 years

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Francois Blawat
New Worry: Older versions will be activate-able for 5 years
on Jun 20, 2016 at 6:57:18 pm

A user (vkmast) under the SCS forums indicated that Magix will only allow activation of older SCS software up to 5 years!


Link: https://www.custcenter.com/app/answers/detail/a_id/5200


I really hope this is NOT true and I hope that Magix reconsiders this or at least provides something to not require activation for older software to all the legally Registered users.

With all the faults of SCS, at least I could STILL activate and use my older PAID FOR Sonic Foundry / SONY Creative Software.

I am not happy to see this new news. Seriously, this Magix acquisition has caused me some serious Ups and Downs...

- - - - -
FixitMad


Return to posts index

George Dean
Re: New Worry: Older versions will be activate-able for 5 years
on Jun 20, 2016 at 7:20:44 pm

From what I have read, most of the concerns about Magix's acquisition of SCS software have been put to bed with reasonable explanations and future plan announcements. Sooner or later, I'm sure Magix will make a clarification about this issue as well.

Until Magix provides a new version release and finalizes all the support, licensing and customer service intentions, including the SCS forums, we will not know for sure. However, from what I have read, Magix hasn't been hiding from the concerns voiced by customers. Time will tell, and I'm still optimistic about the sale and future of Vegas Pro and other SCS software now being developed by Magix.


Best Regards......George


Return to posts index

Mike Kujbida
Re: New Worry: Older versions will be activate-able for 5 years
on Jun 20, 2016 at 7:40:13 pm

George, thank you for being a voice of reason. All of the comments so far on the Sony Vegas Pro forum about this issue are similar in nature to what Francois posted.
I'm with you in that MAGIX will do the right thing for all Vegas users and that everyone just needs to be patient.


Return to posts index


Francois Blawat
Re: New Worry: Older versions will be activate-able for 5 years
on Jun 20, 2016 at 8:12:04 pm

Hi George & Mike,

The Link that was provided under the SCS forums indicating the new EULA from Magix was posted on Sony's website. I only bring it up now so we are not blind-sided once a new version of Vegas comes out.

I am a firm believer to make sure we get an answer from MAGIX.

I only bring it up here since I am not sure who frequents the SCS forums.

- - - - -
FixitMad


Return to posts index

Eric Dettman
Re: New Worry: Older versions will be activate-able for 5 years
on Jun 20, 2016 at 10:23:17 pm

I am not seeing any official stipulation that there is a cut off date for activations at 5 years out. I have changed the FAQ to reflect that previous versions of the software will still be able to be activated. When I find out more about any specific time frames I will keep the community updated.

MAGIX see.feel.hear.create


Return to posts index

Steve Rhoden
Re: New Worry: Older versions will be activate-able for 5 years
on Jun 21, 2016 at 12:19:32 am

Thanks for being continuously on the ball Eric....

Steve Rhoden (Cow Leader)
Film Maker & VFX Artist.
Owner of Filmex Creative Media.
Samples of my Work and Company can be seen here:
http://www.facebook.com/FilmexCreativeMedia


Return to posts index


Francois Blawat
Re: New Worry: Older versions will be activate-able for 5 years
on Jun 21, 2016 at 1:58:04 am

Eric,

Thank you for responding and updating the official FAQ page located at: https://www.custcenter.com/app/answers/detail/a_id/5200. I no longer see the 5 year mention.

Good News!

Thanks again.

- - - - -
FixitMad


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]