FORUMS: list search recent posts

Simple Transparency

COW Forums : particle Illusion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
john McGeoch
Simple Transparency
on Dec 13, 2012 at 8:41:14 pm

I`ve just been following a transparency thread from earlier and had no success at all. All I want to do is put say smoke over a transparent background for later compositing. No layers in Particle illusion, nothing complex. There seems no way for PI to display the typical chequered transparent background whilst working and no way to activate the `save alpha` button in the render path. Yes I can select RGBA in the Lagarith codec, but all I get is a black background by default presumably because this is after the `save alpha` button which is grayed out in the previous window. So what I would like is to be able to test the particle over a `chequered` style background and render it with the Alpha. Can anyone tell me where I am going wrong, how can I not escape the black background and how can I activate the `save alpha` in the render dialogues ? many thanks for any assistance , John McGeoch


Return to posts index

Alan Lorence
Re: Simple Transparency
on Dec 13, 2012 at 8:51:19 pm

pI will never show a checkerboard.

If the "save alpha" option is not available, then the codec you're choosing is not configured to save alpha (or can't save alpha).

Try selecting PNG image sequence as output, and you'll see "save alpha" is available.

To configure Lagarith correctly, open the options for it (in the pI dialog where you select the codec) and choose RGBA output. You should only have to do this one time, as it's a Windows setting not a pI setting. If "save alpha" isn't available in pI, then you did something wrong or there is a problem.

In that case why not just use a PNG sequence? Save all of the files in a folder if you're worried about a "mess" of too many files. Every modern editing app can load a sequence and treat it just like a single movie file.

Alan.

....................
Alan Lorence
Product Manager
GenArts, Inc.
http://www.genarts.com
http://www.wondertouch.com


Return to posts index

john McGeoch
Re: Simple Transparency
on Dec 13, 2012 at 9:11:39 pm

Cheers Alan - I`ll try that but I have already checked the RGBA in Lagarith and I use it all the time in after effects. I`ll try the png sequence, it`s just a bit messier than a single lagarith file ................ so I just did all that and yes I can do a PNG sequence but it is much less convenient - it has to be imported as a folder, put in a seperate composition, after effects has to be told how long to make each picture, overlap etc and then the composition has to be imported into the composition you wanted the effect in in the first place or re-rendered as a lagarith with alpha for use and future resource. With a Lagarith + alpha I could just render it and plonk it straightaway where I wanted it. I just can`t get the avi selection to come up with a save alpha button even though on the next page Lagarith remains checked with the RGBA. It`s obviously not getting through somehow - anything I could try? As an aside I also use the DXV codec a lot which also has transparency. DXV though is in a Quicktime wrapping, will PI support Quicktime at all? Thanks for your help, John



Return to posts index


Alan Lorence
Re: Simple Transparency
on Dec 13, 2012 at 9:21:09 pm

Well, Lagarith works with alpha on my pI Windows setup. I wonder if it's something to do with pIRender? Try a really small frame size -- like 320x240 and see if "save alpha" is available.

Alan.

....................
Alan Lorence
Product Manager
GenArts, Inc.
http://www.genarts.com
http://www.wondertouch.com


Return to posts index

john McGeoch
Re: Simple Transparency
on Dec 13, 2012 at 9:48:43 pm

Aha yes that looks like it , no problem without PI Render perhaps because the `save alpha` box comes after the lagarith selection with the rRGBA enabled and in PI Render it comes a step before it? Problem is of course is that I`m mostly working in HD or at least 1024 x 768. Is there a workaround? cheers John



Return to posts index

Alan Lorence
Re: Simple Transparency
on Dec 13, 2012 at 9:58:15 pm

It should work in pIRender too... try launching pIRender manually, then load the project you're trying to render and see if that fixes it. Or maybe you need to set the Options or AVI options in pIRender to the right codec...

I admit it's a bit confusing because pIR can have different settings.

Alan.

....................
Alan Lorence
Product Manager
GenArts, Inc.
http://www.genarts.com
http://www.wondertouch.com


Return to posts index


john McGeoch
Re: Simple Transparency
on Dec 13, 2012 at 10:21:31 pm

Hooray again! Getting closer! It does indeed work if the project is loaded into PI render separately, once again the `save alpha` box is on the same page as the lagarith code and not one step before it and it works straight away. This is better for me than PNG sequences with all the attendant processing and should the route through PI itself prove impossible is at least a reasonable workaround. I`ll perservere a bit more in PI itself. What happens on your machine if you try with a 1920 x 1080 project? Do you get the same problem with your Lagarith codec? Thanks for the help so far, best wishes John



Return to posts index

john McGeoch
Re: Simple Transparency
on Dec 13, 2012 at 10:38:08 pm

Hi Alan - just went through the PI route with a 720P file via PI Render and got it to work. Somehow getting it to recognise the Alpha by going straight to PI Render the time before seems to have kicked off recognition of the codec and it`s Alpha - so great and thanks for your all help, best wishes John



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]