FORUMS: list search recent posts

No alpha in pngs with 0 particle information (should be fully transparent)

COW Forums : particle Illusion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Tony Salvaggio
No alpha in pngs with 0 particle information (should be fully transparent)
on Oct 16, 2012 at 10:32:33 pm

System specs:
Particle Illusion 3.0.43
PC
Windows 7 64 bit 12 GB ram
Dual Geforce GTX 295, Direct X 11 Driver 296.1


I have been having a problem where any .png files rendered out that do not have any particles on screen are rendering as the background color(in this case black)with no alpha information. I have tried various combinations of Save alpha settings and both general preferences and open GL preferences to no avail.
Shouldn't an image that has not particle information be rendered as completely transparent? Lately I have just been resorting to taking these begin/end frames into Photoshop and creating transparent frames. It doesn't seem like that is something I should HAVE to do though.
I've been using Particle Illusion for quite a while, but this seems to be happening more and more lately.

Thanks in advance for any information/help you can provide.


Return to posts index

Alan Lorence
Re: No alpha in pngs with 0 particle information (should be fully transparent)
on Oct 16, 2012 at 10:37:33 pm

So the frame with no particles has a solid (255) alpha channel, but as soon as a particle is drawn the areas with no particles go to transparent (0) ?

That doesn't make any sense. What alpha channel settings are you using? Try the "run with software rendering" option in the Start menu and see if that fixes it. If it does, you need to update your video drivers.

Alan.

....................
Alan Lorence
Product Manager
GenArts, Inc.
http://www.genarts.com
http://www.wondertouch.com


Return to posts index

Tony Salvaggio
Re: No alpha in pngs with 0 particle information (should be fully transparent)
on Oct 16, 2012 at 10:47:14 pm

That's exactly what is happening. Solid background images have a 255 alpha. I even rendered out tgas and a couple of other formats just to double check. As soon as the particle show up, the alpha for the particle works.

To make matters worse when turned off Hardware acceleration and restarted Particle Illusion my recent files show up as gibberish and opening a file OR trying to render a new file results in an error "Encountered an improper argument" I don't think I've ever seen that error when using the the software.

I'll try updating the drivers and see if that helps.


Return to posts index


Tony Salvaggio
Re: No alpha in pngs with 0 particle information (should be fully transparent)
on Oct 16, 2012 at 11:19:17 pm

I think the new drivers may have fixed it, but I'm still not sure why turning off hardware rendering causes such strange errors now. That one is new. It will load some files with alpha, others just look like flat alpha cards and then I load it again and it displays fine. All of the loaded files have garbled task bar names. Switching back to hardware fixes this. Sorry this is really two issues I can start another thread if necessary.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]