FORUMS: list search recent posts

November library delay -- test?

COW Forums : particle Illusion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Alan Lorence
November library delay -- test?
on Nov 14, 2011 at 7:34:26 pm

I've had the November library ready for release for about a week, but there's a small problem with it: it sometimes crashes pI3 when adding a new emitter to the stage. I've been trying to figure out what crazy stuff these emitters are doing to cause this, but it's slow going. Tom Granberg (who created the library) doesn't get the crashes, but I do quite regularly.

If you've got some time and are willing to give this a try, please email support at wondertouch dot com and put "want to test emitter library" in the subject. Maybe with enough people messing around with this we can figure out what exactly is the problem.

Note that I've tested on pI3 Windows and pIAE Win only. It doesn't seem to be a problem on pIAE.

Alan.

....................
Alan Lorence
Product Manager
GenArts, Inc.
http://www.genarts.com
http://www.wondertouch.com


Return to posts index

Alan Lorence
Re: November library delay -- test?
on Nov 17, 2011 at 4:11:16 pm

Thanks to those who assisted or offered to assist. I've figured out the problem, and it's a bug in pI3, not an issue with the library.

I'm not sure of the exact conditions, but if you have a non-zero "preload frames" value for an emitter and that emitter uses "attached to emitter" for some of the particle types, adding an emitter to the stage will crash under some conditions.

I've released the November library with "attached to emitter" turned off for all of those emitters. Shouldn't be needed, but there is a note in the zip file on how to turn them back on if needed.

Alan.

....................
Alan Lorence
Product Manager
GenArts, Inc.
http://www.genarts.com
http://www.wondertouch.com


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]