FORUMS: list search recent posts

Rendering black

COW Forums : particle Illusion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Dave Cockburn
Rendering black
on Dec 6, 2010 at 3:27:57 pm

Help!
I'm trying to render out a 2048 x 1152 project (double project size to allow for a zoom in) on a quad core PC with a ATI HD 4800 (1024mb memory) Windows 7

When I try to render I get the following errors:

could not find acceptable pixel format

Can't create opengl context

Error allocating ouput color DC

Pi then renders the project as a series of black frames. I am really stuck here. Any suggestions gratefully received!!!!

Huge Regards
Dave


Return to posts index

Alan Lorence
Re: Rendering black
on Dec 6, 2010 at 3:45:10 pm

Open pIRender manually, click the "Options" button, then uncheck "use hardware acceleration".

This is a workaround, and I'll be releasing an update that fixes this any other issues in the next week or so.

Alan.

http://www.wondertouch.com


Return to posts index

Dave Cockburn
Re: Rendering black
on Dec 6, 2010 at 3:59:51 pm

Hi Alan:
That doesn't help I'm afraid. I don't get the warnings but I still get the 300 frame project rendered as black (plus a couple of green frames thrown in for good measure)
Do you have any other ideas. I need to have this done and to the client this week :-(

Huge Regards
Dave


Return to posts index


Dave Cockburn
Re: Rendering black
on Dec 6, 2010 at 4:02:38 pm

For your information - I don't know if this is relevant but the particle shape is my own full colour png (64x64 with alpha)

Huge Regards
Dave


Return to posts index

Alan Lorence
Re: Rendering black
on Dec 6, 2010 at 4:06:55 pm

When pIRender is running, is there a line at the bottom of the dialog that says "software rendering" -- in red text I think? If not, then you didn't actually turn it off.

If it definitely is using software rendering and you're still getting black frames, then as a test:

1) in particleIllusion, zoom the stage to fit the window
2) when you render, click "no" on the "set the zoom to 100%" question
3) it will render in particleIllusion. Is the output you get here what you expect?

Alan.

http://www.wondertouch.com


Return to posts index

Dave Cockburn
Re: Rendering black
on Dec 6, 2010 at 4:16:27 pm

Hi Alan:
In Pi render there is a line at the bottom of the box that says using software rendering. it isn't in red though. 'Use openGL hardware' is not checked in the settings panel.


Not zooming seems to render fine but obviously at the wrong size.

Huge Regards
Dave


Return to posts index


Alan Lorence
Re: Rendering black
on Dec 6, 2010 at 4:27:45 pm

Sorry -- it's red text on the Mac version. What version is pIRender? (click the "?" buttom in the bottom right corner).

Alan.

http://www.wondertouch.com


Return to posts index

Dave Cockburn
Re: Rendering black
on Dec 6, 2010 at 4:34:42 pm

Version 3.0.7 30 Dec 2008

Huge Regards
Dave


Return to posts index

Alan Lorence
Re: Rendering black
on Dec 6, 2010 at 4:41:19 pm

Strange. Ok, if there is any background footage in the project, remove it from each layer and try again and see if the problem persists.

If it does, zip the project file (ip3) and send it to me at support at wondertouch dot com.

You could also try turning off motion blur, or switching from HQ to regular blur, or try with not saving alpha, or some combo of those. Those are the first things I'll try anyway with your project if I see the same results you do.

Alan.

http://www.wondertouch.com


Return to posts index


Dave Cockburn
Re: Rendering black
on Dec 6, 2010 at 4:45:09 pm

Hi Alan:
No Motion blur. No Bg and I have tried without alpha all with the same effect. Meh
I'll zip and upload and maybe try a smaller version and hope we can sort this.

Huge Regards
Dave


Return to posts index

Andreas Hohl
Re: Rendering black
on Dec 7, 2010 at 9:16:17 am

I am experiencing the same issues all of a sudden. My first assumption was that it may have to do with the new ATI drivers. They boogered up a lot of other software as well as plug-ins (Magic Bullet Quick Looks for example) - We got those working again by reverting back a few versions of the stupid video drivers, but that in itself is not a clean solution. So, what now? Red Giant released some new versions (patches) to handle the new driver pretty quickly. I don't know what the heck ATI is doing at this point. Looking deeper - I reverted the driver back again for testing PI (rollback) - but it made no difference. However, if I use PIRender standalone and render uncompressed AVI (so that I can get an alpha channel) - it works. This is totally weird. I guess for now it just will be a two step process. I will keep experimenting and if I find a real good solution, I will certainly share it. - Just for some specs: software rendering only (using an ATI Radeon 4800 on Win7 64 bit 6GB ram) - follow up - I did move back to the latest driver - and it does work as the two step process - hence, it most likely is not a video driver issue. But rendering from within PI is simply no longer working. :( - The only thing I can think of now is that the codecs have somehow been modified or updated.


Return to posts index

Alan Lorence
Re: Rendering black
on Dec 7, 2010 at 5:17:36 pm

I'm posting an update to pIRender on Windows (via AutoUpdate) that should fix this problem.

Alan.

http://www.wondertouch.com


Return to posts index


Andreas Hohl
Re: Rendering black
on Dec 7, 2010 at 6:02:01 pm

Hi Alan,

Got the fix - downloaded and installed. But no luck. Still need to render as standalone. I verified that the fixes were installed.

Just as an FYi -

Trying to render to AVI uncompressed, Alpha, and remove black bg are checked.
Also tried without checking Alpha - still no luck.

No worries though - I know these types of bugs are not easy. So for now I will simply do a two step process until we can help you figure out what's at bay. :)

Thanks for your speedy support and replies in any case. - Andy


Return to posts index

Dave Cockburn
Re: Rendering black
on Dec 7, 2010 at 6:24:56 pm

Thanks Alan!
I updated and it all seems to be working fine for me now.

Andreas:
I have a similar set up. Windows 7 (32) Radion HD 4800 (1024mb) I am using the latest drivers - 10.11 though.
I am also rendering out as a png sequence and PI calls the stand alone renderer as my scene size is over 200 pix. That works fine. My actual sized rendering - so it fit on the screen always worked. (It still does with the update) I don't know if this helps at all.

Huge Regards
Dave


Return to posts index

Andreas Hohl
Re: Rendering black
on Dec 7, 2010 at 8:34:21 pm

Yeah - I am on 10.11 (ATI Catalyst) as well - but still no luck.. I am on 64 bit. The weird thing is this all worked beautifully only a couple of weeks ago. So I have been reviewing what has changed. The only two things that I can imagine are the drivers (ATI) and Neoscene - but since I am not using the neoscene codecs ( They give erroneous errors, really.) for this, it should not impede this process. I have now tried to output a series of PNG with alpha - same results - all black. Same result with TIF sequence - all black. As said - if I do the renders separately using PIRender, no problems. This is totally weird.


Return to posts index


Alan Lorence
Re: Rendering black
on Dec 7, 2010 at 8:49:41 pm

When pI3 calls pIRender, it saves your project in a temporary project file called "pirender_project.ip3". Why don't you search for that file and delete it -- perhaps it got set to read-only or something, so pIR is never getting the real project info.

Alan.

http://www.wondertouch.com


Return to posts index

Andreas Hohl
Re: Rendering black
on Dec 7, 2010 at 9:39:03 pm

I did a search - found one in the "virtual store" under AppData (created 090110) - deleted it - but no change.


Return to posts index

Alan Lorence
Re: Rendering black
on Dec 7, 2010 at 9:50:56 pm

Ok, I just remembered something. Launch pIRender manually, then uncheck the "autoload" option, close pIRender, and try again from pI3.


If that doesn't help try this:

1) Save your project file.

2) when pIRender is launched by pI3, if the render starts right away click the little "?" button to bring up the "about" window and pause the render. If it doesn't start right away, don't start it.

3) When pIR isn't rendering (not yet started or paused with "about" box), search for "pirender_project.ip3" then compare its size to the project file you saved in step 1. If you can't find the project file, or if the project files aren't identical, let me know the details.

Alan.

http://www.wondertouch.com


Return to posts index


Andreas Hohl
Re: Rendering black
on Dec 8, 2010 at 12:11:41 am

Ok did what you asked - it created a pirender_project.ip3 file and yes, it is the same size as the project ip3 file. Just to make sure - searched the entire puter. :) - Also checked to make sure that there was plenty of drive space on potentially used drives. And just to play it safe - I tried once more while running as "Administrator" - no change. Set compatibility up to WinXP SP 3 - no change. Also for the heck of it used a different drive - no change. I bet it will turn out to be something really silly. I am at a loss of any more ideas of things that could have changed. So logically thinking - if really all PI does when you ask for a render, it opens the PI Renderer. Maybe it is a memory issue or lack there of. But with 6 GB it should be fine. In any case - I proceeded to render a different file with a different size, and it still showed the original render file - so it is not creating a new file as it I suppose should. So I stopped the render altogether - deleted the pirender file and now I am totally locked out of the software with the sitecode MID screen. It now asks me for the activation code. --= Under application status it says it's "locked" - now what? :( scratching my head. I probably blew it up by deleting that file eh?


Return to posts index

Andreas Hohl
Re: Rendering black
on Dec 8, 2010 at 12:32:47 am

Ok, I verified that it is NOT consistently creating the pirender file, even when just using the render program as stand alone. It does create some weird shortcut files under my users dir and under the "AppData\roaming.... " - but one thing that really sticks out is that video memory is being eaten up by PI. For example, while PI is running, and you have a window open and move it, it give that echo effect and it is really jumpy. Forget about trying to bring up the task bar. It is hidden behind PI if PI is maximized. Could be something, could be nothing. It is just acting very strangely now.


Return to posts index

Alan Lorence
Re: Rendering black
on Dec 8, 2010 at 2:47:11 am

It will only create the pirender_project file when called from pI3.

You're definitely using the latest version of pIR that I just released, 3.0.7.1, right? If not, that's your problem.

Otherwise, make sure "auto load" is NOT checked in pIR. You didn't mention if you tried that.

Alan.

http://www.wondertouch.com


Return to posts index

Andreas Hohl
Re: Rendering black
on Dec 8, 2010 at 4:02:54 am

Yes - it is the version downloaded this morning 3.0.7.1 - and yes - auto load is unchecked and has always been unchecked.


Return to posts index

Alan Lorence
Re: Rendering black
on Dec 7, 2010 at 6:45:56 pm

Uncompressed AVI doesn't work for some people with pI. I've never been able to figure out why. Try a different format and see if that helps.

Alan.

http://www.wondertouch.com


Return to posts index

Alan Lorence
Re: Rendering black
on Dec 8, 2010 at 2:46:59 pm

Here's another thing to try:

1) Create a smaller project in pI3, 640 x 480

2) Add a single emitter to the project

3) Ctrl+click the "Save Output" button (hold down the Ctrl key when you click the toolbar button). This will force pIRender to be used even though pI3 can do the render itself.

See if that works in pIR.

Alan.

http://www.wondertouch.com


Return to posts index

Andreas Hohl
Re: Rendering black
on Dec 9, 2010 at 12:13:32 am

Ok I did that - getting very weird results. If the particle is bright enough - it does a horrible job, but at least puts more than just black out. I can send you a sample if you like. The result is different each and every time. Even on the same project. This is totally weird.. I won't be back till Friday, so no rush on my part.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]