FORUMS: list search recent posts

No Library Access: "Invalid Argument"(One il3 File Only)

COW Forums : particle Illusion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Philip Knight
No Library Access: "Invalid Argument"(One il3 File Only)
on Nov 25, 2009 at 2:43:53 am

I did a search here on this same "An invalid argument was encountered" error but I can't see how it relates to drivers as mentioned in what I found at this forum.

Sys Info: Updated PI 3 on XP Home SP3, Pentium D

Here is what happened:

-- I spent considerable time cleaning out/trimming down my main library saving it as a new name via the double pane library management modality.

-- Once satisfied, I did the final save of the new library, closed the management window and returned to PI. That's when the error started. Then I got the "Runtime" error freezing PI.

-- So I closed PI, reset to default settings, opened PI, tried again. No-go: same error. Did a system reboot thinking maybe something was stuck in RAM but...

-- PI went right into the "Runtime" error on launch, so had to set to default again, and same problem with that library occurred again. Any time I try to open that library, close PI, it won't open due to the "Runtime" error, so I have to default.

-- This ONLY happens with this new library and its backup. Other libraries load fine.

Quite frustrating considering the time I put into this re-organization which vastly reduced the size of the library too.

Q: Would it be worth the while to send this library to you at PI to see if you can diagnose the problem? It smells of a file corruption, and so perhaps not even you can access it.

Thanks.

PS: Just in case this doesn't get resolved, I'm going to start a whole new library from scratch and hope for the best...


Return to posts index

Philip Knight
Re: No Library Access: "Invalid Argument"(One il3 File Only)
on Nov 25, 2009 at 4:35:20 am

Update:

I gave up trying to resurrect that library file or to bother you with it. I've created a new one as stated in my PS. above and so far, so good: each time I save it, exit Manage and load it anew in PI, no errors.

One guess on what may have occurred--maybe:

--- I had exited Manage Libraries using the red "X" close button instead of clicking on the "OK" at the bottom. That may have freaked something out corrupting said library somehow even though I had saved the library prior to exit.

Feel free to delete this question/topic if deemed of no use to others.


Return to posts index

Alan Lorence
Re: No Library Access: "Invalid Argument"(One il3 File Only)
on Nov 25, 2009 at 2:00:00 pm

Did you look in the "library backups" folder?

I've posted tips before about modifying libraries using the library manager -- can't remember if it was in this forum or in a video tutorial or both.

FYI: clicking the "X" to close a window is the same thing as clicking a "cancel" button if one exists.

The main thing when making many changes to libraries: save the file and close the manager often.

Alan.

http://www.wondertouch.com


Return to posts index


Philip Knight
Re: No Library Access: "Invalid Argument"(One il3 File Only)
on Nov 25, 2009 at 8:58:15 pm

I didn't think of looking in backups, will keep that in mind for the future. That said, I just cleared out that folder last night since I've re-created the new library.

While it's hard to know what really happened, I think there may be a clue in your stating to save and close the manager often:

-- Yes, I saved often and made my usual manual backup.
-- No, I didn't close the manager after saves. Just kept editing.

I say the latter may be a clue because I perhaps instinctively applied it during my library re-do--mainly to make sure PI would load it in after a save.

Once PI accepted the library-in-creation enough times, I didn't load after every save.
But I did close the manager down often.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]