FORUMS: list search recent posts

Video as background image slows down everything

COW Forums : particle Illusion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Sven I. Nilsen
Video as background image slows down everything
on Jan 17, 2009 at 12:04:05 pm

I am new to particleIllusion, so I am perhaps missing something. As I understand, I can use a video as a background, for positioning emitters exactly where I want them on moving picures.

Please tell me how to do this:
My video project is 1920 x 1080 HDV. When I try to use a WMV file as the background video, everything slows down to a crawl. I have tried to render video as small as 480x270 pixels, still everything is extremely slow. How can I speed up things?

If I cannot play back video in real time, there will be difficult to use the record functions on the stage. Any help and advice appreciated.


Return to posts index

John Holste
Re: Video as background image slows down everything
on Jan 19, 2009 at 2:09:13 pm

Sven,

in "play" mode and "record" mode the video( shown in particleIllusion ) is sometimes slower( inversely proportional to the number of emitters * the size{w x h} of the output ) than real time. However, once recorded to a movie file the video WILL playback at normal speed.




John


Return to posts index

Sven I. Nilsen
Re: Video as background image slows down everything
on Jan 21, 2009 at 4:27:03 pm

John,
I have discovered this. The question is why it can't play back at full speed, since the video does not interact with PI in any way at all. No calculations on PI's hand is needed, why not play back the video at full speed? I assume it uses the same codecs as Windows media player, so if Windows media player can, why not PI?
Now - what's important is how to circumvent this problem. Any suggestions about video format, video aspect ratio and size is very welcome.
As you understand, having an emitter following something moving in the video is very hard to record when the video is as jerky as it is in my case.
--Sven



Return to posts index


Alan Lorence
Re: Video as background image slows down everything
on Jan 21, 2009 at 4:49:24 pm

Don't try to record in realtime (don't use "record position"). Just advance a few frames then move your emitter.

You could also try converting the movie into a sequence of PNG or JPG files. I've found that image files load faster for some reason.



Alan.

http://www.wondertouch.com


Return to posts index

Sven I. Nilsen
Re: Video as background image slows down everything
on Jan 22, 2009 at 7:30:06 am

>Don't try to record in realtime (don't use "record position").
Well, the function is there, isn't it? :-)
So I want to use it because it is there

I am experimenting with AVI formats and will come back when I find out more. Please note - the playback is jerky even before any emitter at all has been added.

--Sven



Return to posts index

Alan Lorence
Re: Video as background image slows down everything
on Jan 22, 2009 at 2:31:11 pm

Also test an image sequence as comparison.



Alan.

http://www.wondertouch.com


Return to posts index


Richard Clark
Re: Video as background image slows down everything
on Apr 20, 2009 at 12:50:01 am

I'm actually having the same problem. Not using HDV but it seems any video is jerky and slow to play or scrub. First I used a 5-sec AVI file and it was terrible. Other formats yield the same results. Then I tried sequenced PNG files and the same problem albeit slightly better but still too poor for workflow.

Not sure what the problem is but I'm running Windows XP64 SP1 which still has plenty of bugs in it on a robust system.

Digital Fire Studios
Precision Homebuilt: Asus P6T Deluxe V2, Core i7/920 OC-3.4GHz, OCZ 12G DDR3 RAM, Nvidia GTS250 w/1G DDR3, 3.2 TB, LG Blu-Ray/HDDVD RW. Adobe Creative Suite CS4, Sony Vegas Pro 8, Particle Illusion 3


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]