FORUMS: list search recent posts

Pi ALPHA into SONY VegasPro8

COW Forums : particle Illusion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Graham Bernard
Pi ALPHA into SONY VegasPro8
on Jan 12, 2009 at 5:59:33 pm

I am following Alan's recommendations.

I have tried Uncompressed and now Lagarith lossless CODEC. Both do this for me:

Pi to Pi = Alpha

VegasPro8 to VegasPro8 = Alpha

Pi to VegasPro8 = NO Alpha

I have done the usual change of Alpha option in Vegas - STRAIGHT;Premulitplied etc . ..

What IS going on?

Also, when I set for Lower Field in Pi, I am getting back UPPER field in Vegas?

I can render Alpha, but this appears to becoming opaque when going INTO VegasPro8

Not happy, not happy at all.

Just as a piece of information, I have tried the RENDER "Save Output" in Pi and the first menu I get is: "Output Options" - where the Alpha channel is grey-out. The next menu is the AVI options where I can CHOOSE which CODEC - and I choose Larg; I then get to the piRender menu and THEN I can choose ALPHA. Oh, and all the while I am checking for Lower Field First.

Is there anything, ANYTHING else I need to select?

Grazie




Return to posts index

Alan Lorence
Re: Pi ALPHA into SONY VegasPro8
on Jan 12, 2009 at 7:15:47 pm

You're actually rendering with pIRender, not with pIllusion itself.

Have you tried rendering to a PNG sequence instead and seeing if the alpha comes into Vegas?

I don't have Vegas 8, but in Vegas 7 Lagarith pI3 to Vegas works fine (after I tell Vegas that the clip has an alpha channel).



Alan.

http://www.wondertouch.com


Return to posts index

Graham Bernard
Re: Pi ALPHA into SONY VegasPro8
on Jan 12, 2009 at 8:45:42 pm

Thank you Alan.

I now have Uncomp from pi to V working with Alpha. Excellent! I have no idea why? All I did was start a completely new Pi session and project.

I have had no success with Larg in either V7 or V8. Larg is coming in at 15mbs and Uncomp is 980mb. Maybe THAT is a clue?

PNGs work fine.

Grazie



Return to posts index


Alan Lorence
Re: Pi ALPHA into SONY VegasPro8
on Jan 12, 2009 at 9:03:08 pm

That *is* a clue... that you're wasting 900 MB of drive space. Lagarith uses lossless compression (like a ZIP file). Uncompressed just doesn't make sense -- unless it's the only thing that works of course.

If you don't configure Lagarith to save alpha by choosing RGBA in the Lagarith codec "configuration" page, it won't save alpha at all, even though pIllusion enables the "save alpha" option.



Alan.

http://www.wondertouch.com


Return to posts index

Graham Bernard
Re: Pi ALPHA into SONY VegasPro8
on Jan 12, 2009 at 9:16:23 pm

Hah! That was it - of course, now that I KNOW!!! I wasn't saving from Pi using the config of RGBA - fool!!!

I was thinking that AS Pi does "Save Alpha" I was good to go. But I wasn't. That was blatantly clear.

I now have Lagarith working in V8.

The files sizes are remarkable. It has only gone from 15mbs to 23mbs. Amazing!

Alan, thanks for your patience and your person-to-person skills.

Best regards

Grazie





Return to posts index

Alan Lorence
Re: Pi ALPHA into SONY VegasPro8
on Jan 12, 2009 at 9:19:43 pm

Well, pIllusion is a little misleading in that the "Save Alpha" option is enabled, but we couldn't figure out how to get the true alpha channel status from a codec. So we just enable alpha for any codec that we know supports alpha (even if there is some internal configuration that is not correct in the codec).



Alan.

http://www.wondertouch.com


Return to posts index


Graham Bernard
Re: Pi ALPHA into SONY VegasPro8
on Jan 12, 2009 at 8:58:12 pm

Alan? Can you please note the size of your Lagarith and Uncomp files.

I am getting:-

Uncomp = 980mbs

Lagarith = 15mbs

That is a ratio of 65:1

IS this a clue?

TIA,

Grazie





Return to posts index

Theo van Laar
Re: Pi ALPHA into SONY VegasPro8
on Jan 22, 2009 at 10:43:42 pm

I have the same problem: Export from PI as PNG gives a file with transparancy in Vegas 8 pro. But export from PI to avi with the lagarith codec (yes, I used the RGBA setting plus the SAVE ALPHA option) still gives a black background in Vegas without transparancy.
So it appears I´m still doing something wrong. But what?
(PI version 3.0.4.1 and Vegas 8 Pro 8.0b).

Theo


Return to posts index

Graham Bernard
Re: Pi ALPHA into SONY VegasPro8
on Jan 22, 2009 at 10:58:25 pm

You'll be okay . . .

Once imported into Vegas you have to manually set & select the Alpha Channel - it will NOT do it by itself.

So: - Right Click on the Event in Vegas > Properties > Media (tab) > Stream Properties > Alpha Channel ( nearly there!) > Select "Straight (un matted)"

HTH

Grazie





Return to posts index


Theo van Laar
Re: Pi ALPHA into SONY VegasPro8
on Jan 22, 2009 at 11:12:38 pm

Yes, that works! Thanks a lot.

Theo


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]