FORUMS: list search recent posts

Custom particles exporting with strange alpha.

COW Forums : particle Illusion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Cedric Lavergne
Custom particles exporting with strange alpha.
on Sep 4, 2008 at 6:12:08 pm

I've got an 8 frame cycle of a butterfly (1024x1024 PNGs). Using it as a particle. The frames come out semi transparent (PNG). If I put a black BG behind it it looks correct. I've tried every combination of "Remove Black" and "Non-Intense", and I always get the same output.

Example Particle PNG. (Frame6of8)


Rendered frame from PI3.


What am I doing wrong?

-ced


Return to posts index

Alan Lorence
Re: Custom particles exporting with strange alpha.
on Sep 5, 2008 at 3:50:37 pm

It's all about how you imported the particle shape image.

If the original PNG contained an alpha channel, you should use that wnen importing. If not, it looks like you selected "use dark colors". That doesn't work if the important parts of the image contain black or near-black colors.



Alan.

http://www.wondertouch.com


Return to posts index

Cedric Lavergne
Re: Custom particles exporting with strange alpha.
on Sep 5, 2008 at 5:17:37 pm

Thanks for the reply Alan,

PNG had alpha? :: The PNGs (like the one in my original post) did have transparency/alpha information.

Selected "Dark Colours"? :: No, that option yielded a blocky mess around my butterfly. Obviously wrong.

(>_<) ~~ Frustrated!!

You did help me solve my problem though. (^_^)
"It's all about how you imported the particle shape image. "


That statement made me take a second look at the Particle Shape Import Options.

Shape Type :: Was obviously correct set to Full-Colour
Transparency :: I knew Use Existing was right, but did end up trying the other options out of frustration (only furthering my frustration).
Shape Size :: This was the only settings I had constantly overlooked. Assuming the default option (Resize with 1024w and 1024h) was the safe choice. The fact that Resize enabled the High Quality option made it seemed like the best choice for the job. When actually it was the culprit all along!! I knew that PI requires power of 2 dimensions, so my particle PNGs where rendered at 1024x1024. Ready for action. So I tried the only option I didn't try yesterday.. Crop (with 1024w and 1024h selected). Works like a charm! My butterflies now render correctly.

I'm assuming PI internally generates resized raster bitmaps even if the PNGs are already at the target dimensions. Looks like something is happening to the PNG's alpha when it is resized. You guys might want to look into it.

Thanks for the help.

-ced


Return to posts index


Alan Lorence
Re: Custom particles exporting with strange alpha.
on Sep 5, 2008 at 5:53:37 pm

Please send one of the original butterfly PNGs to support at wondertouch dotcom.



Alan.

http://www.wondertouch.com


Return to posts index

Cedric Lavergne
Re: Custom particles exporting with strange alpha.
on Sep 5, 2008 at 6:10:50 pm

Drats!! Foiled again!!!

I thought I had it... but didn't.
PI is still rendering my butterflies all semi transparent and useless.

(Like an idiot ... I was looking at the PNG frames from the 3D flock simulation that was made when PI proved itself incapable of outputting frames properly. They weren't PI renders.)

I was SOOOOOO happy for about 20 minutes there.

(>_<) ~~ Frustrated again..

-ced


Return to posts index

Cedric Lavergne
Re: Custom particles exporting with strange alpha.
on Sep 7, 2008 at 7:52:35 pm

Found the culprit. I've been rendering at to high a resolution.

Rendering at 1280x1024 (my desktop resolution) gives me messed up frames. (>_<)

If I use the 1280x720 preset. My scenes render correctly (perfect alpha information). Yay?

I really like PI. It is very easy to quickly get something that looks nice, but this render issue continues to severely limit how much we can use PI in our productions (which are all 1920x1080 final frames). Are you guys looking into this issue? It's frustrating to have this be the only piece of software on my box that can't output frames at the desired resolution.

Thanks again for the help.
-ced


Return to posts index


Alan Lorence
Re: Custom particles exporting with strange alpha.
on Sep 8, 2008 at 5:21:23 pm

The key here is that pIRender is doing the rendering, not particleIllusion itself.

Run pIllusionRender manually and turn off hardware acceleration in it(click the Options button).

Now do your render again and I think it will be fine.



Alan.

http://www.wondertouch.com


Return to posts index

Cedric Lavergne
Re: Custom particles exporting with strange alpha.
on Sep 8, 2008 at 6:03:11 pm

Worked!

You are a wizard... I know it. Thanks again.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]