FORUMS: list search recent posts

Recording issues

COW Forums : particle Illusion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Leonard Rivera
Recording issues
on Aug 7, 2008 at 4:46:20 am

Every time I try to record (export video) I get this error -

"Can't connect ImageOutPin to FileInPin"

No matter what format or codec I choose. Please help.


Return to posts index

Leonard Rivera
Re: Recording issues
on Aug 7, 2008 at 4:49:36 am

I'm running Vista 64 on a Phenom X4 2.5Ghz with 4 GBS ram and an ATI HD 3450 PCIe


Return to posts index

Alan Lorence
Re: Recording issues
on Aug 7, 2008 at 2:44:38 pm

Is this with a background image/movie loaded?

Try this: create a new project, 640x480. No emitters, no background image/movie. Click "Save Output", save as AVI, select any codec you normally use.

Also try:

- WMV
- restarting the computer
- Download "Lagarith" or "Huffyuv" codecs and try those.



Alan.

http://www.wondertouch.com


Return to posts index


Leonard Rivera
Re: Recording issues
on Aug 7, 2008 at 4:00:56 pm

OK your test worked fine.

Yes I had a background image. Here's my work flow.

I have a huge image in photoshop. I'm using it for a game using gamemaker7. I want to use PI to create flames for torches and stuff. Basically want to take PI's output (wish it could do animated gifs) - convert to animated gif, import to gamemaker, create sprite from animated gif and use.

So in Photoshop, I'm cropping out just the small pieces I need. I bring those in to PI as backgrounds, setup the animation and attempt to render.

I think the issue is the non-standard pixel x pixel sizes and aspect reations of the cropped images I am using. I know many vieo codecs will not support it. I was hoping I cound exprt as PSD and construct the gif that way but I stick get the same issue.

I would prefer the ability to export firectly to animated gif, but I can convert many movie formats to AG as this is not the hard part. I just need to figure out how to get past this issue. I'm kind of working on another part of our game so I left this alone until I heard back.

Would you suggest I crop my images to 640x480 for backgrounds to import?


Return to posts index

Alan Lorence
Re: Recording issues
on Aug 7, 2008 at 4:08:13 pm

Some codecs don't like weird sizes -- you're probably better off saving an image sequence out of pIllusion, not a movie.



Alan.

http://www.wondertouch.com


Return to posts index

Leonard Rivera
Re: Recording issues
on Aug 7, 2008 at 4:43:06 pm

I'm trying PSD, BMP etc.. But now I'm getting

"Can't find acceptable pixel format"



Return to posts index


Alan Lorence
Re: Recording issues
on Aug 7, 2008 at 5:10:54 pm

Make sure your desktop is set to 24 or 32 bpp color.

Also try restarting the computer.

You may need to update your video drivers too.



Alan.

http://www.wondertouch.com


Return to posts index

leonard rivera
Re: Recording issues
on Aug 7, 2008 at 5:14:50 pm

I wish it were that easy - I've done all that.


Return to posts index

Alan Lorence
Re: Recording issues
on Aug 7, 2008 at 5:29:01 pm

Ok, then I guess the answer is: make sure the output size (stage size) is not a weird number. Make sure it's divisible evenly by 4 and you should be fine.



Alan.

http://www.wondertouch.com


Return to posts index


Leonard Rivera
Re: Recording issues
on Aug 7, 2008 at 5:53:58 pm

OK. Will do. I'd bet that solves it...but I don't gamble.

;)

I'll let you know.


Return to posts index

Leonard Rivera
Re: Recording issues
on Aug 7, 2008 at 6:01:40 pm

Nope. I get the same pixel format error and when I click OK it says "Can't Create OpenGL context"

This was trying to do AVI no compression. I'm going to try PSD again, if I get the same error, I'm going to take a closer look at my video card's opengl settings. In the meantime, If you want me to send you the project and files (background), email me at my FirstInitialLastName at digital-church.com.

I tried setting the stage size to a standard resolution from the project settings drop down that was slightly higher than my background.


Return to posts index

Alan Lorence
Re: Recording issues
on Aug 7, 2008 at 6:28:15 pm

Is it trying to render within particleIllusion, or is it launching pIRender? If pIRender, open pIR manually, click the options button and uncheck hardware acceleration.



Alan.

http://www.wondertouch.com


Return to posts index


Leonard Rivera
Re: Recording issues
on Aug 7, 2008 at 7:35:27 pm

That worked.

ATI Radeon HD 4850 must have OGL issues. I only saw two check boxes for OGL in the settings. One was to enable Triple Buffering and the other was to force 24-bit Z-buffer depth. Neither is enabled.

Thanks, I'm able to continue now, if anything else comes up (like something to do with those settings), please let me know. Your always helpful Alan, thank you so much, speaks volumns of you and your product. Cheers.

-lenny


Return to posts index

Alan Lorence
Re: Recording issues
on Aug 7, 2008 at 7:59:48 pm

Just to be clear, it was the pIRender hardware acceleration that was the problem? Turning it off works now?

It's really best if the rendering is done in pIllusion itself -- to make sure this happens most of the time, maximize the particleIllusion application so it fills the entire desktop at rendering time. It will then maximize the stage window size automatically, and if it still can't fit the output size you want, it will then call pIRender.

Unless you're working at a relatively low desktop resolution, this should ensure that pIllusion does the rendering almost all of the time.



Alan.

http://www.wondertouch.com


Return to posts index

Leonard Rivera
Re: Recording issues
on Aug 7, 2008 at 9:13:20 pm

Yeah, it works with hardware turned off in pIllusionRender. That's the same dialog that pops up when ever I try to render, the same one that was giving me the errors. My desktop is set to 1680x1050 32 bit and Illusion is always run full screen.


Return to posts index


Alan Lorence
Re: Recording issues
on Aug 7, 2008 at 9:26:01 pm

So what size output are you trying to render?



Alan.

http://www.wondertouch.com


Return to posts index

Leonard Rivera
Re: Recording issues
on Aug 7, 2008 at 9:43:42 pm

1440 x 1080 - the original image I cropped it from is 8192x2304 - Are you saying I can not rener at a resolution greater than my monitor resolution with hardware enabled? 0 I can do a tighter crop and bring the size down a little bit.


Return to posts index

Alan Lorence
Re: Recording issues
on Aug 7, 2008 at 9:51:21 pm

Well, it seems YOU can't, since pIRender doesn't seem to want to work hardware-accelerated with your video card/drivers.

It is possible normally to render larger sizes with hw accel in pIRender.



Alan.

http://www.wondertouch.com


Return to posts index


Leonard Rivera
Re: Recording issues
on Aug 7, 2008 at 10:11:02 pm

That's just wierd - The drivers are so new they were released a few weeks ago. ATI Catalist V 2008.0703.2236.38526

Not that that means anything to you. But it's causing me issues. Never had an issue on my older machines like I did today.

Anyway, thanks again for you help. Hopefully you won't hear back for a while. Well, I think I might get more involved in the community, start posting up and sharing my Illusion works. As time allows...


Return to posts index

Alan Lorence
Re: Recording issues
on Aug 7, 2008 at 10:39:02 pm

If they are beta drivers, you may want to go back to the latest non-beta version.



Alan.

http://www.wondertouch.com


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]