FORUMS: list search recent posts

Loop - but not in Export! Why?

COW Forums : particle Illusion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Major123
Loop - but not in Export! Why?
on Feb 24, 2007 at 12:14:02 pm

Hi!

i try the demo particleillusion 3, the software is very cool and i thing i will buy it soon.

my problem: i have make a animation, the animation is a loop (i have read the tutorial "loop" ;-) .. the loop is great and functionally, but when i export the final animation in PNG's, the images are not a loop! why?
When i export to an avi, i have a loop!

thanks!


Return to posts index

Alan Lorence
Re: Loop - but not in Export! Why?
on Feb 24, 2007 at 2:39:36 pm

There's no reason that the saved frames would be different if you chose PNG or AVI. The only difference is that with PNG you could have "save alpha" checked, which would could mask out part of your background images.

So uncheck that option, or make sure you view the PNGs without the alpha channel.



Alan.

http://www.wondertouch.com


Return to posts index

major123
Re: Loop - but not in Export! Why?
on Feb 24, 2007 at 9:25:52 pm

Hi!

that was a misunderstanding ;-) i have uploaded a .swf and a .avi file. now you can see my problem.
the video is a loop, the swf too but the swf starting the animation new but not non-stop!! the avi
is an non-stop animation. why?

won't exactally export the animation that i see on my screen? the exported frames are not exactally the animation
that i have created.

i hope you can understand me ;-)

here the Files (only 2 MB's)

http://www.dwerbung.de/smoke.avi
http://www.dwerbung.de/smoke.htm


Return to posts index


Soniclight
Re: Loop - but not in Export! Why?
on Feb 25, 2007 at 9:16:51 am

I compared the two clips side-by-side, and this is my observation:

--- The one on your .htm page looks like the full loop in that there is a "fade out," if you will: the smoke thins out to nothing, then loops again. That looks like the full animation.

--- The .avi version has no "fade out" so those last frames seem to be missing before it loops again.

So first, what this looks like to me is that the number of frames you are exporting in .avi are less than as in your project (I'm assuming you want the full "fade out"). What you have to check is that the number of frames is exactly the same in:

--- The frame box in the project's floating or docked tool bar
--- View/Preferences - Frames
--- Action/Save Output (in whatever dialog box you get when you export, which differs with formats chosen).

Second, as a precaution (though this has to do with playback format and speed, not number of frames), make sure your frame rate (i.e. 15, 24, 30, whatever you wish) is also the same in:

--- View/Preferences - Frame Rate
--- View/Project Settings - Frame Rate

I have PI-3 and as far as I understand it, what one sets in Preferences (global settings for any new project created) should default/carry over into any new project on the stage, but check it anyway.

___________________

As far as the looping issue after export:

--- That may depend on what editing or encoding software and/or post-render players you use. I use Sony Vegas 6 for video editing. As far as player, I have Windows Media Player 11 set to repeat, so your .avi looped fine.

For Flash formats, most encoders can create infinite loops, some can't. Your .htm Flash file looped just fine: I tested in in both Firefox 2 and IE 7.

___________________

I hope the above turns out to be helpful. And, indeed, this program is cool and fun -- and worth taking the time to learn. The tutorial is one of the best I've seen, both as a reference and as a step-by-step guide.

Good luck and happy "magic making" :)


Return to posts index

Major123
Re: Loop - but not in Export! Why?
on Feb 25, 2007 at 9:54:01 am

Big thanks for you help, but my english is not very good, i come from germany.
i have understand your thread a little bit ;-)
ich have exported all 80 images in avi and swf!! i don't understand.. is PI 3 not WYSIWIG? when i create
a animation with a fine loop, i thing i have a loop when i export, but only in avi. Hmm... i'm addle...

can you help me with a thread in easy english? ;-)

how can i export my animation !!without!! the fade out images/frames in PNG's??
the joke: i see my created animation as fine loop without fade of.. its a fine loop!!
but a fine loop only in avi.. i don


Return to posts index

Soniclight
Re: Loop - but not in Export! Why? (Deutche Version...)
on Feb 25, 2007 at 10:35:31 pm

Mein Deutsch ist sehr rostig (ich war in der Schweiz geboren aber kein Deutsch in 30 Jahren gesprochen). Also ging ich zu den Google


Return to posts index


Major123
Re: Loop - but not in Export! Why? (Deutche Version...)
on Feb 26, 2007 at 12:43:38 pm

Hi!

i have found the problem, but not a answer ;-( when i export my animation to JPG's, then
i have a fine loop without fade-out!! very great! the problem is now the JPG's are not
transparent!! how can i export transparent PNG's with a fine loop? who is the problem by
export to PNG's? I cant understand it.. jpges good, pngs not good

my question: is it not possible to export my animation with loop in pngs, only in jpegs??

Hmmm.. thank you fou your biiiig help! your german is good! ;)


Return to posts index

Alan Lorence
Re: Loop - but not in Export! Why? (Deutche Version...)
on Feb 26, 2007 at 1:03:23 pm

I think I already answered this: Alpha channel.

If you save PNG, you need to uncheck the "Save Alpha" option.

You can't use this technique in particleIllusion with an alpha channel, since particleIllusion creates an alpha channel for the particles only.

If you really need a looping animation with an alpha channel, then you need to do the "crossfade" in a compositing application, not in particleIllusion itself.



Alan.

http://www.wondertouch.com


Return to posts index

Major123
Re: Loop - but not in Export! Why? (Deutche Version...)
on Feb 26, 2007 at 4:57:40 pm

Hi Alan!

thank you very much! i have now understand it! i will crossfading in Flash..

thank you very much!


Return to posts index


Soniclight
Re: Loop - but not in Export! Why? Good/Gut :)
on Feb 26, 2007 at 9:15:30 pm

Major123,

I am glad things have worked out for you. Have fun and learn :)


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]