FORUMS: list search recent posts

Slow performance, pixellated images.

COW Forums : particle Illusion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Tom Wood
Slow performance, pixellated images.
on May 22, 2006 at 5:15:48 pm

I loaded the Pro abstract emitters but there's a problem. The emitters start off okay but as they progress the refresh gets slower and slower, both in preview and in the stage. The image also pixellates, even in the saved image. I have a dual 2.4G Xeon with 2G RAM. How do I get smooth performance and imagery?

Here's a link to a screen capture of the Ethereal Wave at frame 252:

http://i18.photobucket.com/albums/b113/tomwood2/animation/particles.png

Thanks,

TW



Return to posts index

Alan Lorence
Re: Slow performance, pixellated images.
on May 22, 2006 at 9:58:15 pm

Do you have Motion Blur on? You should only use motion blur on emitters that have "(mb)" in the name. Otherwise, performance will suffer, and you will get the "banding" artifacts you're seeing.




Alan.
wondertouch


Return to posts index

Tom Wood
Re: Slow performance, pixellated images.
on May 22, 2006 at 10:32:40 pm

Motion Blur is not on.

It seems run okay for about thirty frames, then goes slower and slower with the pixellation getting worse and worse.



Return to posts index


Alan Lorence
Re: Slow performance, pixellated images.
on May 23, 2006 at 11:06:31 am

I have a feeling your graphics card (or drivers) are the problem. On my 2.4 GHz laptop, Even at frame 300 I'm getting 10 fps. I suggest checking your graphics card manufacturer's website for updated video drivers -- they can make a BIG difference.

The "pixelation" is actually how that emitter is designed -- the particle shape images have a sharp edge. If you want to get rid of that edge, you'll need to export the shape image, modify it in a paint app (blur it probably), then import it back in and assign it to that particle type.




Alan.
wondertouch


Return to posts index

Tom Wood
Re: Slow performance, pixellated images. Driver update no help.
on May 23, 2006 at 1:48:37 pm

I updated the driver, it's a Quadro 500FX/600FX with 128 MB. No help at all. Performance in the stage window eventually slows to a crawl. The saved output doesn't look anything at all like the sample movie, it's very rough. It seems like there's something fundamentally wrong here. Anything else I can try?

Thanks,

TW



Return to posts index

Alan Lorence
Re: Slow performance, pixellated images. Driver update no help.
on May 24, 2006 at 11:32:38 am

Try "run with software rendering" in the Start - Programs - particleIllusion 3 menu. This will be slow, but see if visually it is any different.

Have you looked at the still images of the ethereal emitter? It's on the Pro Emitters page. There are SD and HD versions. Compare to what you're getting -- it should not be different.




Alan.
wondertouch


Return to posts index


Tom Wood
Re: Slow performance, pixellated images. Driver update no help.
on May 24, 2006 at 8:08:52 pm

Well, slow is right. That pretty much makes using the emitters impossible, since you can't see what they are doing. The render time is not acceptable either. I stopped after ten frames. Here's what frame 404 looked like using the software render mode.

http://i18.photobucket.com/albums/b113/tomwood2/animation/rwsoftrend0404.pn...

Are you saying that a dual 2.4G hyperthreaded Xeon machine is already obsolete for these emitters?

TW



Return to posts index

Alan Lorence
Re: Slow performance, pixellated images. Driver update no help.
on May 25, 2006 at 5:28:39 pm

So are you saying that the image you're rendering on your machine (with hardware or software) is different from the images that are posted on the Pro Emitters web page? You need to make that determination yourself.

I think it's not the CPU speed that is the issue -- it's the video hardware speed. I'm not sure why you're not getting better results with the Quadro -- it really should fly. Are other OpenGL apps open?

Anybody else using a Quadro FX 500 (or Quadro 500 FX or whatever it's called) with particleIllusion?

Actually, I just read back over all of the posts in this thread, and you said a few things that indicate it may be a CPU issue. Here are a few things to try:

1) In the Preview Window, select 25% zoom and see if it goes faster. Select 400% and see if it goes slower. If changing the preview zoom changes the speed significantly, then it's probably not a video card issue (when using software rendering, changing preview zoom size changes speed dramatically)

2) Check the properties for that emitter and make sure that "keep particles in order" is not checked. Or, if it is not checked, try checking it.

That's all I can think of right now.



Alan.
wondertouch


Return to posts index

Matt-WMFS
Re: Slow performance, pixellated images. Driver update no help.
on May 26, 2006 at 12:49:11 pm

Hi,

Just thought i'd also say i have experienced PI being slow my machine has Quadro 500FX/600FX Card also, i assumed that i was simply using too many emmiters in the project causing it to slow down and often crash.

I dont have a solution but thought i'd raise it to you guys that their could possibly be issues with the above device.


Matt

Matt

West Midlands Fire Service
Email = Matthew.Hamm@wmfs.net


Return to posts index


Alan Lorence
Re: Slow performance, pixellated images. Driver update no help.
on May 26, 2006 at 7:30:24 pm

A few years ago (back in 2001) I knew that the Quadro cards were slower than the GeForce cards with particleIllusion (I assume with games too), even though the Quadro was much more expensive, and more capable in many respects.

I thought that they "fixed" this, with the Quadro cards now having equal (or better) performance than the corresponding GeForce cards in games.

Do the Quadro drivers have a bunch of settings that allow you to tweak the performance? There may be some settings that result in better performance for gaming -- anybody know about this? Do you play any games on this system?




Alan.
wondertouch


Return to posts index

Tom Wood
Re: Slow performance, pixellated images. How to turn off software rendering?
on May 27, 2006 at 12:22:24 am

How do you turn software rendering OFF? It now starts in that mode automatically when double-clicking the desktop icon, and I can't find where to turn it off.

No games or other OpenGL apps are running on this machine when using PI.

I'll run the tests you suggested when I can turn off software rendering.

TW



Return to posts index

Tom Wood
Re: Slow performance, pixellated images. Ooops, found it.
on May 27, 2006 at 2:03:38 am

Got the software rendering turned off by turning on hardware acceleration in preferences.

On the ethereal wave emitter, changing the zoom in the preview window seems to slow down at 400%, but it's hard to tell with it in that close. Other Pro emitters it didn't have any effect. The 'keep particles in order' button had no effect, checked or unchecked.

I've had a similar problem with some of the fireworks emitters that have the "super emitters" (?) in them.

When the images are rendered, is the video card involved in any way? Because if you look at that first still I posted, it's very rough. If the video card is not involved, then it's the CPU.

TW



Return to posts index


Alan Lorence
Re: Slow performance, pixellated images. Ooops, found it.
on May 27, 2006 at 7:30:34 pm

particleIllusion uses the video card to render if hardware acceleration is being used.




Alan.
wondertouch


Return to posts index

Tom Wood
Re: Slow performance, pixellated images. Video card settings
on May 28, 2006 at 1:06:54 am

The video card has a boatload of settings that can be changed. It also comes preloaded with a set of profiles for a variety of software programs, like Maya, LightWave, Combustion, etcetera, but PI isn't listed. Changing the profile optimizes all the settings for a particular program. Is there another program out there that acts like PI to a video card that might be on the list?

TW



Return to posts index

Elvis Deane
Re: Slow performance, pixellated images. Video card settings
on May 28, 2006 at 10:19:55 pm

The Combustion preset may help, since its particles are based on particleIllusion's.

--
Elvis Deane!

The Apprentice Magician's Guide to particleIllusion


The particleIllusion FAQ


Return to posts index


Tom Wood
Re: Slow performance, pixellated images. Video card settings - no help
on May 30, 2006 at 10:22:12 pm

I tried most of the profiles, no help.

Dunno.

TW



Return to posts index

Alan Lorence
Re: Slow performance, pixellated images. Video card settings - no help
on May 31, 2006 at 2:38:06 am

If there are any profiles for games (like Quake, or similar) then try one of those.




Alan.
wondertouch


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]