FORUMS: list search recent posts

All Layer Style Outer Glow Opacity Expressions Error

COW Forums : Adobe After Effects Expressions

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Gary New
All Layer Style Outer Glow Opacity Expressions Error
on Jan 15, 2020 at 10:38:52 am

Hi All!

I am working on a project in Adobe After Effects CC 16.0.1 (Build 48).

When attempting even the most rudimentary opacity expression within an Outer Glow Style Layer I receive a warning that there is an error and that the expression has been disabled.

The following basic expression gives the previously mentioned warning:

layerStyle.outerGlow.opacity

When previewing the composition, I can see that the expression works as desired with the error, but when rendering the same effect is disabled in the final product.

What gives? Are opacity expressions not permitted with the Outer Glow Style Layer?

Thank you for your time and assistance.

Kind Regards,


Gary

layerStyle.outerGlow.opacity


Return to posts index

Dan Ebberts
Re: All Layer Style Outer Glow Opacity Expressions Error
on Jan 15, 2020 at 8:56:50 pm

Two questions-- where did you apply the expression, and what's the error message?


Dan



Return to posts index

Gary New
Re: All Layer Style Outer Glow Opacity Expressions Error
on Jan 15, 2020 at 11:33:55 pm

Hi Dan!

It appears that the main body off text of my original message, that described the issue in detail, was not included in my original post.

That being said, the issue is with any expression (simple or complex) that I add to the opacity control of an Outer Glow layer style.

The error is a warning that the expression had been disabled because of an error in line 1.

Even the basic alt/opt-click expression produces the same error.

Ignoring the warning, I am able to see that the expression is working correctly in the AE visualizer. However, when I export the composition, the final rendered product does not include the effect of the expression.

I am using Adobe After Effects CC 16.0.1.

Thank you for your time and assistance.

Kind Regards,


Gary


Return to posts index


Dan Ebberts
Re: All Layer Style Outer Glow Opacity Expressions Error
on Jan 16, 2020 at 12:42:56 am

I can't reproduce your problem, but the closest version I have to what you're using is 16.1.3. Expressions on the Outer Glow Opacity property work fine for me.


Dan



Return to posts index

Gary New
Re: All Layer Style Outer Glow Opacity Expressions Error
on Jan 16, 2020 at 1:02:46 am

Hi Dan!

Do you receive any expression errors when you pickwhip from the Outer Glow opacity control to the Audio Amplitude > Both Channels > Slider?

Expression:

thisComp.layer("Audio Amplitude").effect("Both Channels")("Slider")

It produces the same error (Warning: expression disabled. Error on line 1.) for me, visualizing fine in AE, but isn't included in the final, exported rendering.

If I provided you with my .aep file, would you try to reproduce it in AE CC 16.1.3?

Thanks, again, for your time and assistance in tracking this issue down.

Kind Regards,


Gary

thisComp.layer("Audio Amplitude").effect("Both Channels")("Slider")


Return to posts index

Dan Ebberts
Re: All Layer Style Outer Glow Opacity Expressions Error
on Jan 16, 2020 at 1:24:56 am

>Do you receive any expression errors when you pickwhip from the Outer Glow opacity control to the Audio Amplitude > Both Channels > Slider?

No error when I do that.

>If I provided you with my .aep file, would you try to reproduce it in AE CC 16.1.3?

Sure.

Dan



Return to posts index


Gary New
Re: All Layer Style Outer Glow Opacity Expressions Error
on Jan 16, 2020 at 1:28:39 am

Hi Dan!

What's the best method to get the .aep and source files too you?

Would you mind exporting the composition to validate the final rendering as well?

Thanks, again.


Gary


Return to posts index

Dan Ebberts
Re: All Layer Style Outer Glow Opacity Expressions Error
on Jan 16, 2020 at 1:59:03 am

You can get my contact info from my web site. If it's too big to email, WeTransfer, maybe?

Dan



Return to posts index

Gary New
Re: All Layer Style Outer Glow Opacity Expressions Error
on Jan 16, 2020 at 2:43:56 am

Hi Dan!

Sent you a private message to your personal email address.

Thank you for your assistance!

Kind Regards,


Gary


Return to posts index


Dan Ebberts
Re: All Layer Style Outer Glow Opacity Expressions Error
on Jan 16, 2020 at 3:06:16 am

I'm not getting any errors. The glow pulsates on and off with the auido.

Dan



Return to posts index

Gary New
Re: All Layer Style Outer Glow Opacity Expressions Error
on Jan 16, 2020 at 3:22:58 am

That's what I observe with errors in the AE visualizer.

What does the final rendering look like for you?

Thanks.


Gary


Return to posts index

Dan Ebberts
Re: All Layer Style Outer Glow Opacity Expressions Error
on Jan 16, 2020 at 5:36:36 am

I only rendered some of it, but the part that I saw looks fine (the glow pops into view with the audio).

Dan



Return to posts index

Gary New
Re: All Layer Style Outer Glow Opacity Expressions Error
on Jan 16, 2020 at 7:32:31 am

Hi Dan!

Does the glow pulsate on and off in what you rendered or does the glow just remain 100% and scale with the object?

In my rendered version, the glow does not pulsate on and off. The glow just remains at 100% and scales with the object, which is incorrect.

Your response will help me determine whether I need to upgrade my version of AE.

Thanks, again


Gary


Return to posts index

Dan Ebberts
Re: All Layer Style Outer Glow Opacity Expressions Error
on Jan 16, 2020 at 7:40:18 am

>Does the glow pulsate on and off in what you rendered...

Yes, definitely.


Dan



Return to posts index

Gary New
Re: All Layer Style Outer Glow Opacity Expressions Error
on Jan 16, 2020 at 8:01:08 am

Hi Dan!

It sounds like it must be a bug in AE 16.0.1 that was fixed by 16.1.3.

I guess it's time to upgrade my version of AE.

Thank you for all your help.

Respectfully,


Gary


Return to posts index

Gary New
Re: All Layer Style Outer Glow Opacity Expressions Error
on Jan 17, 2020 at 2:32:15 am

Hi Dan!

After upgrading to AE 16.1.3, I no longer receive the previously mentioned errors and am able to render the final product with the expression effects as visualized in AE.

It looks like it was a bug in 16.0.1.

Thanks, again, for all your time and assistance.

Respectfully,


Gary


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2020 CreativeCOW.net All Rights Reserved
[TOP]