FORUMS: list search recent posts

Set guideLayer property for shapeLayer not working for me

COW Forums : Adobe After Effects Expressions

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
rob mcgowan
Set guideLayer property for shapeLayer not working for me
on Feb 24, 2017 at 9:12:56 pm

Hi, I've seen a number of pages on setting guideLayer e.g.Dan Ebberts on this forum.

All the examples show people making new solids and setting guideLayer no problem.

When I try doing the same on a shapeLayer nothing happens.

c=this.app.project.activeItem.layers.addShape();
c.guideLayer=true;


Is this just another one of those things that doesn't work on shapeLayers in CS4 (like motion paths) ?


Return to posts index

rob mcgowan
Re: Set guideLayer property for shapeLayer not working for me
on Feb 24, 2017 at 9:16:13 pm

It's got to be me. DUIK manages to to set shapeLayers as guides.


Return to posts index

rob mcgowan
Re: Set guideLayer property for shapeLayer not working for me
on Feb 24, 2017 at 9:18:44 pm

Wrong again... DUIK sets guideLayers on nulls and solids but not shapeLayers.


Return to posts index


Dan Ebberts
Re: Set guideLayer property for shapeLayer not working for me
on Feb 24, 2017 at 9:47:57 pm

I just tried it in CS4 and it works for me. Of course the shape layer doesn't have any contents, but it's there (and marked as a guide layer).


Dan



Return to posts index

rob mcgowan
Re: Set guideLayer property for shapeLayer not working for me
on Feb 24, 2017 at 10:47:03 pm

hi, you are quite write however there I have tested this somewhat more and I am none the wiser...

The code that sets guideLayer is in a library.

The guideLayer is set fine if I call the fn from within the file that defines the fn.
The guideLayer is not set if I call the fn from another file that #includes the library.

If I copy the fn to the invoking script it works.
If I copy the invocation to the defining script it works.

It makes absolutely no sense.


Return to posts index

rob mcgowan
Re: Set guideLayer property for shapeLayer not working for me
on Feb 24, 2017 at 10:56:15 pm

DO! I think I got it now.


Return to posts index


rob mcgowan
Re: Set guideLayer property for shapeLayer not working for me
on Feb 24, 2017 at 10:58:25 pm

Doh. Stupid error. I was editing my latest code but including my last known good. Thanks.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]