FORUMS: list search recent posts

Puppet tool pins offsetting using the toComp expression

COW Forums : Adobe After Effects Expressions

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Ash Curkpatrick
Puppet tool pins offsetting using the toComp expression
on Feb 11, 2015 at 1:44:24 am
Last Edited By Ash Curkpatrick on Feb 11, 2015 at 3:21:52 am

Hi, this is driving my nuts because I've never had this problem before.

I'm trying to parent puppet tool pins to the nulls and for whatever reason, the pins are being completely offset from the null's anchor point. I can't understand why. I've checked my comp settings and it all seems to be fine. The only thing I can think to imagine might have gone wrong is there might be something weird going on from importing an odd comp size from an illustrator file (maybe?)

Anyone have any clues?

n = thisComp.layer("null");
n.toComp(n.anchorPoint)


Edit: I've just tested this in a friend's version of CS6 and it works fine. I've only recently updated to CC and if I attach the pins in CS6 and open it in CC, it works perfectly - but unfortunately, I have to use CC. Has anyone come across this before??

Edit 2: It seems as if I pre-compose the comp and move all the attributes in to it it works. But I don't remember ever having to do this in the past? Is there any way of getting around this?


Return to posts index

Dan Ebberts
Re: Puppet tool pins offsetting using the toComp expression
on Feb 11, 2015 at 3:07:54 am

Try it this way:

n = thisComp.layer("null");
fromComp(n.toComp(n.anchorPoint))


Dan



Return to posts index

Ash Curkpatrick
Re: Puppet tool pins offsetting using the toComp expression
on Feb 11, 2015 at 3:27:01 am

Yes, That works! Thanks so much. I'm working to an incredibly short deadline so you've literally saved me. I'm really going to have to find out why it works... at least until after this deadline.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]