FORUMS: list search recent posts

loopOut "cycle" expression problem

COW Forums : Adobe After Effects Expressions

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Nick Huskey
loopOut "cycle" expression problem
on Jan 11, 2013 at 10:07:05 pm

I have an image sequence layer that I duplicated, Roto Brushed out and used it as an alpha matte to the duplicated layer. I added a Cartoon effect to the duplicated layer, and both layers are precomposed and the composition settings are as follows:

HDV/HDTV 720 29.97
Duration: 0;00;01;09

I added this comp to my main comp (has the same comp settings, Duration is different), and allowed time remap to my layer. I moved the end keyframe to slow down my comps speed, and then I added the loopOut "cycle" default expression to the time remap but on the last keyframe of the time remap, right before it should cycle there is a frame of no image, causing it to blink. It only blinks on the first cycle around and not after that. the video is below.

Loop Video Here

Is there a way to remedy this?

loopOut(type = "cycle", numKeyframes = 0)

Nick Huskey
CG Artist


Return to posts index

Dan Ebberts
Re: loopOut "cycle" expression problem
on Jan 11, 2013 at 11:13:00 pm

As I recall, you can avoid the last frame glitch by (once you turn on time remapping) adding a keyframe one frame before the last keyframe, and setting the value of the last keyframe to zero.

Dan



Return to posts index

Nick Huskey
Re: loopOut "cycle" expression problem
on Jan 14, 2013 at 1:47:37 pm

That worked, thanks so much!

Nick Huskey
CG Artist


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]