FORUMS: list search recent posts

Custom Plugin Error going from AE5 to AE6

COW Forums : Adobe After Effects Expressions

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
John Jackowiak
Custom Plugin Error going from AE5 to AE6
on Aug 24, 2012 at 4:35:20 pm

This may or may not be the correct forum for this. I created a custom plugin through pixel bender to use in AE5. It worked great up until I recently upgrade to AE6. I'm new to this in general, and I can't seem to find why CS6 is having a hard time with this? Any help would be much appreciated. Thanks!

The first error I got was at line 11 "input image4 src;"

kernel INFO
&lt; displayname : "INFO";
category : "Demand Control Panel";
namespace : "Jackowiak";
vendor : "John Jackowiak";
version : 1;
>
{
input image4 src;
output pixel4 dst;
parameter float reveal
&lt;
aeDisplayName:"REVEAL";
minValue: 0.0 ;
maxValue: 300.0 ;
defaultValue: 0.0 ;
>;

parameter float buttonSelection
&lt;
aeDisplayName:"BUTTON SELECTION";
minValue: 0.0 ;
maxValue: 6.0 ;
defaultValue: 0.0 ;
>;
parameter bool alignCenter
&lt;
defaultValue: true;
aeUIControl: "aeCheckbox";
aeDisplayName: "CENTER";
>;
parameter bool alignLeft
&lt;
defaultValue: false;
aeUIControl: "aeCheckbox";
aeDisplayName: "LEFT";
>;
parameter bool alignRight
&lt;
defaultValue: false;
aeUIControl: "aeCheckbox";
aeDisplayName: "RIGHT";
>;
void
evaluatePixel()
{
dst = sampleNearest(src,outCoord());
}
}


John Jackowiak
Brand New Motion
johnj.bnm@gmail.com

***Recent Work***

http://brand-newmotion.com/reels/motion_graphics.mov


Return to posts index

Dan Ebberts
Re: Custom Plugin Error going from AE5 to AE6
on Aug 24, 2012 at 5:35:50 pm

Support for PixelBender was dropped for CS6.

Dan



Return to posts index

John Jackowiak
Re: Custom Plugin Error going from AE5 to AE6
on Aug 24, 2012 at 6:13:55 pm

I thought it might be because of Mac's Lion. Do you have a suggestion for a work around?

John Jackowiak
Brand New Motion
johnj.bnm@gmail.com

***Recent Work***

http://brand-newmotion.com/reels/motion_graphics.mov


Return to posts index


Dan Ebberts
Re: Custom Plugin Error going from AE5 to AE6
on Aug 24, 2012 at 6:29:29 pm

No good suggestions, unfortunately. You can hack the PresetEffects.xml file, or create a real plugin (similar to your PixelBender plug--it would just provide controls and pass the input directly to the output). I would do the second one, but there's a lot to learn if you haven't done it before.

Dan



Return to posts index

John Jackowiak
Re: Custom Plugin Error going from AE5 to AE6
on Aug 24, 2012 at 6:44:18 pm

What is the best approach for the second option? Would that be using the AE SDK? That is the only other option I've really been able to find in my searching other then hacking the XML. I've never used it before, but I've heard it takes some learning as well.

John Jackowiak
Brand New Motion
johnj.bnm@gmail.com

***Recent Work***

http://brand-newmotion.com/reels/motion_graphics.mov


Return to posts index


Dan Ebberts
Re: Custom Plugin Error going from AE5 to AE6
on Aug 24, 2012 at 7:08:31 pm

Yes, you would be using the SDK. For Windows, that also means you would need Visual Studio to compile the plugin. The SDK documentation is good and the sample plugins really help, but there is definitely a lot to learn, even to just gut one of the examples and just leave the controls.

Dan



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]