FORUMS: list search recent posts

PLEEEAAASSSEEEE HELP!!!

COW Forums : Broadcasting

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
TV Kid 2
PLEEEAAASSSEEEE HELP!!!
on Sep 15, 2007 at 9:08:43 pm

HI ALL,

I have an Editcam II and I just replaced the camera side back up battery and now it powers up fine but still flashes "cam backup batter warn" in the VF. In addition the LCD panel will not light up now.

PLEASE HELP ME.

Lawrence Moran


Return to posts index

Tim Ward
Re: PLEEEAAASSSEEEE HELP!!!
on Sep 21, 2007 at 11:06:22 pm

It may need to be re-initialized or something. Contact Ikegami, they'd definitely know.

Ikegami Contact Info

tim


Return to posts index

Mark Suszko
Re: PLEEEAAASSSEEEE HELP!!!
on Sep 26, 2007 at 9:38:54 pm

Did you have the camera on power while you swapped the little battery? Did you put the little battery in backwards? It happens to all of us sometime.

Try putting the camera on AC power supply, remove the little battery, check polarity AGAIN, then power down and restart witha back of the camera battery. You might also try a hard reboot by finding and resetting the breaker button, it's usually hidden somewhere ont he bottom of a camera.

But I'll bet you a donut you put the memory batery in backwards.


Return to posts index


Tim Ward
Re: PLEEEAAASSSEEEE HELP!!!
on Sep 26, 2007 at 9:59:20 pm

Boy, the 'backwards battery' didn't even occur to me! Over-analyzing is SO over-rated! :) That's probably it. Betcha that's why Lawrence hasn't posted back -- he figured it out on his own.

tim


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]