FORUMS: list search recent posts

NetStream.Play.StreamNotFound while trying to get RMTP snapshot

COW Forums : Compression Techniques

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Gabriel Barreras
NetStream.Play.StreamNotFound while trying to get RMTP snapshot
on Jul 17, 2014 at 10:28:07 am

I'm using the following command:
ffmpeg -i rtmp:// -f image2 -vf fps=fps=1 out%d.png
extracted from official FFmpeg wiki here.
I am allowed to see the video stream using VLC with the same link. However, when using the command above, I'm getting this output:
ffmpeg version N-64667-gd595361 Copyright (c) 2000-2014 the FFmpeg developers
built on Jul 14 2014 22:09:48 with gcc 4.8.3 (GCC)
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzl
libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amr
enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --ena
libavutil 52. 92.100 / 52. 92.100
libavcodec 55. 69.100 / 55. 69.100
libavformat 55. 47.100 / 55. 47.100
libavdevice 55. 13.102 / 55. 13.102
libavfilter 4. 10.100 / 4. 10.100
libswscale 2. 6.100 / 2. 6.100
libswresample 0. 19.100 / 0. 19.100
libpostproc 52. 3.100 / 52. 3.100
HandShake: client signature does not match!
Closing connection: NetStream.Play.StreamNotFound
rtmp:// Unknown error occurred

What is the problem here?
I've tried with other different rtmp streams and I'm still getting the same error.

Thank you!

Return to posts index

Jim Sustacek
Re: NetStream.Play.StreamNotFound while trying to get RMTP snapshot
on Jul 22, 2014 at 2:21:30 pm

I just tried your command and it worked fine for me. Maybe it is something about your FFMPEG installation? I am using version 2.4 on a Mac (tessus build).

I know other/older versions used "librtmp" for rtmp connections, which required some extra options behind the stream URL. See ffmpeg docs here:

And librtmp docs here:

For an unprotected live stream, you may want to try quoting the stream URL and appending " live=1" within the quotes:
ffmpeg -i "rtmp:// live=1" -f image2 -vf fps=fps=1 out%d.png

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2020 All Rights Reserved