FORUMS: list search recent posts

Command line compressor fails

COW Forums : Compression Techniques

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Loren Risker
Command line compressor fails
on Jul 13, 2018 at 7:42:57 pm

I can't get compressor to work from the command line, I get an error:

2018-07-13 12:38:11.801 Compressor[94312:4645537] Error loading /System/Library/Extensions/AMDMTLBronzeDriver.bundle/Contents/MacOS/AMDMTLBronzeDriver: dlopen(/System/Library/Extensions/AMDMTLBronzeDriver.bundle/Contents/MacOS/AMDMTLBronzeDriver, 265): no suitable image found. Did find:
/System/Library/Extensions/AMDMTLBronzeDriver.bundle/Contents/MacOS/AMDMTLBronzeDriver: mach-o, but wrong architecture
/System/Library/Extensions/AMDMTLBronzeDriver.bundle/Contents/MacOS/AMDMTLBronzeDriver: stat() failed with errno=1
Invalid parameter: /Users/lorenr/Library/Application Support/Compressor/Settings/Apple ProRes 422 test.cmprstng


Here's what I'm trying to run:

/Applications/Compressor.app/Contents/MacOS/Compressor -jobpath ./test.mp4 /Users/xxxxx/Library/Application\ Support/Compressor/Settings/Apple\ ProRes\ 422\ test.cmprstng -locationpath ./testoutput.mp4

Any ideas? I'm running macOS 10.13.6 and compressor 4.4.1

-------------
OutOfFocus.TV - Music Videos 24/7


Return to posts index

Loren Risker
Re: Command line compressor fails
on Jul 13, 2018 at 8:02:09 pm

never mind, forgot the -settingpath flag:

/Applications/Compressor.app/Contents/MacOS/Compressor -jobpath ./test.mp4 -settingpath /Users/xxxxx/Library/Application\ Support/Compressor/Settings/Apple\ ProRes\ 422\ test.cmprstng -locationpath ./testoutput.mp4

-------------
OutOfFocus.TV - Music Videos 24/7


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]