FORUMS: list search recent posts

Deinterlacing is giving me blocky interlacing

COW Forums : Compression Techniques

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Aaron Villa
Deinterlacing is giving me blocky interlacing
on Jan 9, 2018 at 9:37:29 pm

Is there any way to fix this issue?

This first image is the deinterlace from MpegStream Clip.


Here's an original still with interlacing.


Return to posts index

Craig Seeman
Re: Deinterlacing is giving me blocky interlacing
on Jan 9, 2018 at 10:54:00 pm
Last Edited By Craig Seeman on Jan 9, 2018 at 10:55:35 pm

Please read the sticky post at the top of this forum if you want detailed help.
It's the one that says PLEASE READ.
Otherwise you may get days of back and forth questions (if you're lucky).
Read that post and include all the details as if you were asking someone to match your steps on the same computer.
I have no idea what settings you've used other then whatever you used didn't work well.

Given MPEGStreamclip seem dead (last beta was over 5 years ago and the last release was over 9 years ago) you may want to look at HandBrake.

MPEGStreamClip User Guide on Deinterlacing:

Interlaced Scaling
If you are scaling an interlaced file to a different height, you can tell MPEG Streamclip to preserve interlacement and scale each video field separately by checking "Interlaced Scaling". If you don't, interlacement will be lost in the scaled movie, and, worse, you will get many visual artifacts. This setting is now enabled by default; remember to disable it with progressive files.

Interlacement requires a frame height of more than 288 pixels. If the frame height of the source file is up to 288, interlaced scaling will not be enabled. If the frame height you have chosen for the exported movie is up to 288 and you check "Interlaced Scaling", MPEG Streamclip discards the lower field before scaling the picture (i.e. it performs a fast deinterlacing by dropping one field).

Better Downscaling
If you are scaling the file to a smaller frame size, by checking "Better Downscaling" you can tell MPEG Streamclip to use a wider 2D-FIR scaler, providing even better picture quality. However this wide 2D-FIR scaler is quite slow and the resulting picture (although perfect) may have less sharpness. This option is disabled by default: enable it only if you need a perfectly scaled movie.

If you are scaling the file to a larger size, this option has no effect; the standard 2D-FIR scaler already provides the best scaling quality.

Reinterlace Chroma
If you are converting an interlaced MPEG-1/MPEG-2 file, you may wish to "reinterlace" chroma. By checking "Reinterlace Chroma" you can enable a special remapping of 4:2:0 chroma lines so they will be split correctly between the two video fields. This is a very advanced option: only professional users may see the difference in the output movie. This option is enabled by default; disable it when you are sure your file is not interlaced.
This option has no effect if the source stream is not an MPEG-1/MPEG-2 stream.

Deinterlace Video
If you have an interlaced file, you may also want to deinterlace it, usually to convert into a progressive format, get a "film" effect and have a better playback on the computer's display. When you check the option "Deinterlace Video", MPEG Streamclip enables a special motion-adaptive deinterlacer, and it deinterlaces the lower field in the parts that contain motion, and preserves video quality of all parts that do not contain motion; the upper field is left unchanged. This option slows down the conversion.

Please note that if you are changing the height of an interlaced stream (that is, you are telling MPEG Streamclip to perform vertical scaling) then you must enable either "Interlaced Scaling" or "Deinterlace Video" (at your own choice), otherwise you will see bad video artifacts in the converted movie.



Return to posts index

Aaron Villa
Re: Deinterlacing is giving me blocky interlacing
on Jan 10, 2018 at 7:26:28 pm

As well as MPSC, I've tried Handbrake (with debomb) & Compressor also. I'm just looking for a solution or trick to fix this. I have FCPX, Premiere, Resolve, Fusion.

It seems like the interlaced lines aren't lining up correctly (like the image was possibly scaled, but when I pull the still into photoshop, that's not the case). I just got an email today, that the producer may have found another version of the file.


Return to posts index


Craig Seeman
Re: Deinterlacing is giving me blocky interlacing
on Jan 10, 2018 at 8:38:45 pm

Without knowing the settings you used it's hard to make recommendations. Auto detect could be wrong. It might be some field dominance or field reversal. You have to provide details because the solution depends on the source and a screenshot of the source doesn't provide the information needed.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]