FORUMS: list search recent posts

Handbrake conversion won't start - one particular file

COW Forums : Compression Techniques

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Andrew Stuckey
Handbrake conversion won't start - one particular file
on Feb 24, 2012 at 1:02:53 am

Hi all,

Been a regular reader of the CC forums.

Literally been pulling my hair out over this issue. Spent HOURS researching and testing a fix for this but to no avail. So it's finally time to actually ask for some help.

--BACKGROUND--
I'm editing HDV 1080i50 video in FCP 7. Output to 1280x720i50 master with square pixels as a self contained mov. This will then be converted to mp4, deinterlaced and downsized for use on the web.

After testing various converters using a sample .mov from my master (Handbrake, MPEG Streamclip, Compressor, Quicktime Pro, Visual Hub) I have settled on Handbrake because it is delivering the best quality and speed for my purposes. MPEG Streamclip came second with Compressor 3 easily the worst of the bunch on both speed and quality.

--ISSUE--
Handbrake is now having an issue with my master mov file. No matter what I try it simply won't start the conversion. After setting everything up I click on start and nothing happens. I can't even add it to the queue. The activity window simply says "macgui: Rip: Pending queue count is 0". If I hit start again it simply repeats "macgui: Rip: Pending queue count is 0". (Full activity log posted in next post.)

After so many hours testing and crafting a nice workflow it is EXTREMELY frustrating to be faulting at the very last step. Aarrgh!

--OTHER INFO--
My master mov file is 1.5 hours duration and 18GB file size.

--TESTS ALREADY RUN--
- Completely deleting Handbrake and reinstalling latest version. No change.
- Changing the .mov extension to .mp4 and .m4v.
- Changing the source and destination locations.
- Shortening the video file name.
- Using a Quicktime reference file as the master instead of self contained.
- Converting another .mov file of the same format (HDV 1080i50) and larger size (100GB). This file worked just fine.
- All other Handbrake presets. None want to work with this file.
- Changing security preferences on my master file.
- Re-rendering and outputting a completely new master .mov file.


I would consider using MPEG Streamclip as option B, but strangely it is also having issues with the same master file (green vertical lines overlaid on the video, completely new and separate issue which I will troubleshoot next if all else fails with Handbrake).

As you can see I'm getting pretty desperate. Would really appreciate any help.

thanks
Andrew

2010 iMac i7, OSX 10.6.8, Handbrake 0.9.5, FCP 7, QT Pro 7.6.9


Return to posts index

Andrew Stuckey
Re: Handbrake conversion won't start - one particular file
on Feb 24, 2012 at 1:44:43 am

Handbrake log

[12:42:21] hb_init: checking cpu count
[12:42:21] hb_init: starting libhb thread
[12:42:21] macgui: Handbrake Version: 0.9.5 x86_64 (2011010300)
[12:42:23] hb_init: checking cpu count
[12:42:23] hb_init: starting libhb thread
[12:42:23] hb_init: checking cpu count
[12:42:23] hb_init: starting libhb thread
[12:42:25] macgui: hbInstances path to this instance: /Applications/HandBrake.app
[12:42:25] macgui: hbInstance found instance pidnum:12360 at path: /Applications/HandBrake.app
[12:42:25] macgui: hbInstance MATCH FOUND, our pidnum is:12360
[12:42:25] macgui: Pid for this instance:12360
[12:42:25] macgui: HBQueueController : My Pidnum is 12360
[12:42:31] macgui: trying to open video_ts folder (parent directory chosen)
[12:42:31] macgui: Preview: Disabling HUD Controls
[12:42:31] macgui: Minimum length of title for scan: 900000
[12:42:31] hb_scan: path=/Volumes/MYBOOK 2/Video Masters/Workshops/2011 Adv Workshop/AWP4_HDV_1080i.mov, title_index=0
libbluray/bdnav/index_parse.c:157: indx_parse(): error opening /Volumes/MYBOOK 2/Video Masters/Workshops/2011 Adv Workshop/AWP4_HDV_1080i.mov/BDMV/index.bdmv
libbluray/bluray.c:960: nav_get_title_list(/Volumes/MYBOOK 2/Video Masters/Workshops/2011 Adv Workshop/AWP4_HDV_1080i.mov) failed (0x104102000)
[12:42:31] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Encrypted DVD support unavailable.
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[12:42:31] dvd: not a dvd - trying as a stream/file instead
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/Volumes/MYBOOK 2/Video Masters/Workshops/2011 Adv Workshop/AWP4_HDV_1080i.mov':
Metadata:
major_brand : qt
minor_version : 537199360
compatible_brands: qt
Duration: 01:32:36.88, start: 0.000000, bitrate: 26546 kb/s
Chapter #0.0: start 33.320000, end 36.640000
Metadata:
Chapter #0.1: start 36.640000, end 37.400000
Metadata:
Chapter #0.2: start 37.400000, end 515.160000
Metadata:
Chapter #0.3: start 515.160000, end 953.400000
Metadata:
Chapter #0.4: start 953.400000, end 1026.080000
Metadata:
Chapter #0.5: start 1026.080000, end 1132.120000
Metadata:
Chapter #0.6: start 1132.120000, end 1634.080000
Metadata:
Chapter #0.7: start 1634.080000, end 2053.040000
Metadata:
Chapter #0.8: start 2053.040000, end 3124.560000
Metadata:
Chapter #0.9: start 3124.560000, end 3695.720000
Metadata:
Chapter #0.10: start 3695.720000, end 4022.400000
Metadata:
Chapter #0.11: start 4022.400000, end 5163.200000
Metadata:
Chapter #0.12: start 5163.200000, end 5163.240000
Metadata:
Chapter #0.13: start 5163.240000, end 5384.600000
Metadata:
Chapter #0.14: start 5384.600000, end 5523.480000
Metadata:
Stream #0.0(eng): Video: mpeg2video, yuv420p, 1440x1080 [PAR 4:3 DAR 16:9], 25000 kb/s, 25 fps, 25 tbr, 25 tbn, 50 tbc
Stream #0.1(eng): Audio: pcm_s16le, 48000 Hz, 2 channels, s16, 1536 kb/s
Stream #0.2(eng): Data: tmcd / 0x64636D74
Stream #0.3(eng): Subtitle: text / 0x74786574
[12:42:32] scan: decoding previews for title 1
[12:42:32] scan: 10 previews, 1440x1080, 25.000 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 4:3
[12:42:32] scan: title (0) job->width:1440, job->height:816
[12:42:32] libhb: scan thread found 1 valid title(s)
[12:42:32] macgui: showNewScan: This is a new source item scan
[12:42:32] macgui: Preview: Enabling HUD Controls
[12:43:34] macgui: Rip: Pending queue count is 0
[12:43:38] macgui: Rip: Pending queue count is 0
[12:43:38] macgui: Rip: Pending queue count is 0
[12:43:39] macgui: Rip: Pending queue count is 0


Return to posts index

Andrew Stuckey
Re: Handbrake conversion won't start - one particular file
on Feb 24, 2012 at 4:37:55 am

Sorry just realised that I said the master .mov was 1280x720. That was a typo out of habit working with files for youtube HD. ;)

The correct format for the master .mov file is Apple HDV 1080i50 1440 x 1080.


Return to posts index


Jeff Greenberg
Re: Handbrake conversion won't start - one particular file
on Feb 27, 2012 at 9:30:47 pm

Well, I have a workaround. Transcode everything to ProRes in Compressor from FCP - you'll have a 60-70 gig file, but I bet that should work fine.

Just a quick idea that hit me - what if you exporting only a minute to see if that had a problem?

Best,

Jeff G


Certified Master Trainer | Adobe, Apple, Avid
------------
You should follow me (filmgeek) on twitter. I promise to be nice.
My book (with Richard Harrington and Robbie Carman)- An Editor's Guide to Adobe Premiere Pro
Lynda.com - Compressor Essentials 3.5 and 4
Contact me through my Website


Return to posts index

Andrew Stuckey
Re: Handbrake conversion won't start - one particular file
on Feb 28, 2012 at 5:30:38 am

I had tried ProRes originally but the latest release of Handbrake wouldn't recognise the source file. I tested this on more than one ProRes file, which is why I resorted to HDV.

Anyway. I also posted the same issue an another forum and ended up working out a solution which I'll post below for the sake of completeness.


Return to posts index

Andrew Stuckey
Re: Handbrake conversion won't start - one particular file
on Feb 28, 2012 at 5:31:17 am

So I tried the x264 codec in QT and I wasn't overly impressed.
Not sure if QT does something to it or maybe I didn't have it fully optimised. Either way I was very surprised because its known to be such a great codec.

However I then tried x264 with MPEG Streamclip and got some excellent results, on par with Handbrake!!
(Very strange that QT could not deliver similar results with the same codec).

So it now seems that I have a viable workaround. What's even better is that unlike Handbrake, MPEG SC will handle AIC formats like ProRez, which is excellent.

Thanks all for your help.
I'll churn my master through and see how it goes.


Return to posts index


Andrew Stuckey
Re: Handbrake conversion won't start - one particular file
on Feb 28, 2012 at 5:33:23 am

SOLVED!
---------

At last a solution for Handbrake.

The latest nightly build of Handbrake not only manages to encode my master file but it also seems to support ProRes formatted files, which is a big win.

http://build.handbrake.fr/

Now all that is left is to compare the ProRes x264 encodes from Handbrake with the ones from MPEG Streamclip. Should be pretty close I imagine. :D

Thanks


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]