FORUMS: list search recent posts

Compressor Issue

COW Forums : Compression Techniques

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Chris Morfill
Compressor Issue
on Jul 27, 2011 at 11:05:49 am

Hi all,

I've just been capturing some video footage using a VCR plugged into a Key Digital VP-HD3 running via HDMI into a BlackMagic Intensity card. It's been capturing in PAL/DV format straight to the hard drive on a Mac Pro. Upon playing the raw files back in Quicktime, I've been getting some acceptable results: http://i55.tinypic.com/dqherp.png

Of course the raw DV files are a little too large for archival, so I've been trying different compression formats to see which offers the best quality:filesize ratio. Upon encoding these test files, I've noticed a problem across the board - Compressor is introducing interlacing lines, and whenever I encode anything with Compressor, I end up with results like the following: http://i55.tinypic.com/5uk3ea.png

As you can see, it's choc full of interlace lines and looking as ugly as anything. I've tried using the various deinterlacing options offered in Compressor like so: http://i52.tinypic.com/4v3k8h.png and modified each of them, re-rendered etc to no avail - the interlacing lines are still there.

The only option I found that worked was to use Compressor's "De-Interlace Blur" filter, which doesn't seem to visibly blur the source footage too much, but I do worry nontheless that it could be reducing the quality of the video (though I can't tell for sure): http://i53.tinypic.com/11ghnrq.png

Is this the only option I've got aside from taking it into FCP and running a deinterlace filter on the footage?

Thanks guys!


Return to posts index

Mark Spano
Re: Compressor Issue
on Jul 27, 2011 at 2:47:19 pm

Question 1: why do you want to deinterlace? Are you compressing the files for web, or are you just trying to get them down smaller for archiving?

Your footage is interlaced. That's how it came in when you captured it. Looking at it in the Quicktime Player is deceptive, as that will show you blended frames. In order to properly QC the material you've captured, you need to play it out a video I/O card to a broadcast monitor. There you'll see the interlacing magically disappear, as the broadcast monitor understands that these fields are to be displayed one after the other (instead of how QT Player shows them at the same time).

Any compression you apply with Compressor will preserve the interlacing in your footage unless you deinterlace it with the Frame Controls. If you really do want to get rid of interlacing (and throw away half your vertical resolution) then set Frame Controls to Output Fields: Progressive and Deinterlace: Best.



Return to posts index

Chris Morfill
Re: Compressor Issue
on Jul 27, 2011 at 4:09:41 pm

Thanks for your reply Mark,

It's a bit of both really! We're both compressing them for the web display, but also for displaying in museum galleries - which usually involve playback via either a solid state HD or SD video player, or a Mac Mini/PowerMac plugged into an LCD or Plasma display to display the material. Either way, they will not be played back by standard TV receivers or DVD players - we're digitising so we can keep the signal path almost entirely digital. Therefore I feel that deinterlacing may be necessary - or do you think this would be wrong?

Thanks for the advice. Unfortunately, whenever I try that it doesn't seem to have much of an effect on the final footage. Being a small institution with a small edit suite we don't actually have access to (or the budget for) broadcast monitors. I tried a digital signage display (just a glorified monitor really) plugged into the Intensity's HDMI output but unfortunately it still displayed interlace lines despite running the video through the deinterlace option in Compressor... any ideas?

Thanks


Return to posts index


Mark Spano
Re: Compressor Issue
on Jul 27, 2011 at 5:02:03 pm

The only thing I can think is that somehow (maybe with the HDMI conversion) that the interlaced footage is being blended on the way in. Thereby blending two fields together into a progressive frame, which can't be split back apart to be properly deinterlaced. That seems destructive and not the way this hardware should work, but I don't have access to what you're working with, so I couldn't tell for sure. It could very well be that the HDMI conversion is not set properly. The ideal way to do this is to make sure that the HDMI converter is passing through - i.e. taking the 576i input and doing a straight A/D to 576i HDMI. I would then capture that as Apple ProRes422, 720x576, 25fps interlaced. Once captured, pass it through Compressor using the frame controls settings as above and keep it ProRes. That should knock down the file size and keep the quality high.



Return to posts index

Craig Seeman
Re: Compressor Issue
on Jul 27, 2011 at 5:54:19 pm

I wonder if Compressor isn't detecting the source properly.
In Compressor, select the source file with no settings attached and look at the Summary tab (first button in Inspector) and see what it says about Interlacing and Field Priority.

As Mark notes, use ProRes as the intermediary as well but do one with DV as well. It might indicate something about how Compressor is detecting the file from Blackmagic.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]