FORUMS: list search recent posts

Compressor hangs for half an hour or more when applying settings to a batch of files

COW Forums : Compression Techniques

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Benjamin Reichman
Compressor hangs for half an hour or more when applying settings to a batch of files
on Sep 2, 2010 at 5:22:39 pm

I'm running Compressor 3.5.2 on Snow Leopard (10.6.4). I have several batches of Canon 7D clips (H.264) which I want to convert to ProRes 422 for editing/color correction. The final delivery will be a DVD.

The problem I'm having is that when I drag a few dozen files into the Compressor window, the app hangs for a very long time. Then when I apply the setting -- the standard "ProRes 422" setting, unmodified -- Compressor hangs for an extremely long time. Choosing a destination (on a local hard drive) also takes an extremely long time.

I have a Mac Pro with a single 2.8GHz Quad-Core Intel Xeon, 6GB of RAM, and the footage is on an internal 3-drive RAID array.

The fact that Compressor can hang at each of those steps for half an hour or sometimes more seems like abnormal behavior. Has anyone else seen this? Is there anything else I can do?

I should mention I tried creating a Compressor Droplet to use instead, but even putting five or six files into the window at once causes it to hang for over half an hour.


Return to posts index

Rich Rubasch
Re: Compressor hangs for half an hour or more when applying settings to a batch of files
on Sep 7, 2010 at 1:02:05 am

Did you try a test with say, 10 files and see how that goes? Also, why not give MPEG Streamclip a try for your conversions?

Rich Rubasch
Tilt Media Inc.
Video Production and Post
Owner/President/Editor/Designer/Animator
http://www.tiltmedia.com


Return to posts index

anthony harrison
Re: Compressor hangs for half an hour or more when applying settings to a batch of files
on Sep 22, 2011 at 10:36:37 am

I have noticed the same issues when transcoding 800+ .wmv videos into h.264 mp4 files.

I'm using the 2011 macbook pro, 8GB ram, 2.2GHz intel core i7.

My files are on an external firewire 800 drive, as is the droplet.

I usually drag approximately 50 files at a time into the droplet and it just hangs.

I thought it had crashed, but after about 40 minutes it prompted me to title the batch. After adding the title and pressing submit, it began to hang again for another half an hour before starting the encoding.

It seems the more files you add the longer it hangs for. With this in mind I foolishly tried to cue up 200 files last night before I left work around 4pm, and waited til gone 6pm for the droplet to respond. It was still hanging and I couldn't wait another hour so I turned everything off, defeated.

Checking the Activity Monitor while the droplet is in this state reveals THE DROPLET IS NOT RESPONDING...although I know if left long enough it'll wake from it's coma.

Is this a common bug?
Does it have anything to do with problematic .wmv files?
Does it happen with other file types?
Should I move the droplet from the external drive to internal drive?
Is there a max amount of files it can batch?
Is there a max amount data it can handle?

Any tips or advice would be greatly appreciated as I stil have around 600 videos to go.


Return to posts index


Benjamin Reichman
Re: Compressor hangs for half an hour or more when applying settings to a batch of files
on Sep 22, 2011 at 11:26:54 pm

Anthony,

It definitely happens with other file types, but otherwise, I can't answer your questions.

I've never really taken the time to try to pinpoint the problem. I mostly work around it by submitting smaller batches, as Rich suggests above. In your situation, you have 600 videos, so small batches aren't practical. Maybe (as Rich said) MPEG Streamclip could work for you?


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]