FORUMS: list search recent posts

HD compression query please help

COW Forums : Compression Techniques

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Roli Rivelino
HD compression query please help
on Feb 8, 2010 at 8:29:22 pm

I have compressed a couple of HD files for vimeo.com and I've used their preferred settings which are:

H.264 codec at size 1280×720, bit rate 3000-5000 kbits/sec (optimized for “download”), key frame every 30 frames (frame reordering on), using whatever frame rate you shot in.

For sound, use AAC at 128kbps in stereo.

I went for a 5000 kbits/sec.

My video is not playing back properly and is jerky, even when you let the 'buffer' bar load right up, I'm watching over a pretty fast connection.

I shot using the DVCPROHD codec, set to QT (50fps).

I'm wondering if it is anything to do with the bit rate, whether I should reduce that, will that help?

If it helps or anyone's interested in seeing what I'm talking about the video is at

many thanks.

aka Newbie Wan Kenewbie. "The young Newbie, is now a Padawon."

System
Mac Pro 2.8Gb quad core
8Gb RAM
1x 320Gb 7200 hardrive
1x 1Tb 7200 hardrive
Nvidia Geforce 8800 512mb Graphics card
1x 1Tb external WD 'My Book' eSata

Equipment
Panasonic AG-HVX 200
Firestore FS-100


Return to posts index

Craig Seeman
Re: HD compression query please help
on Feb 8, 2010 at 8:34:38 pm

Looks fine to me. Played straight through without issues. I have 32,000kbps down. I didn't check their encode but it's usually around 2000kbps for 720p. A lot can happen though from point A to point B on the internet though.



Return to posts index

Roli Rivelino
Re: HD compression query please help
on Feb 8, 2010 at 8:44:02 pm

OK maybe it is connection speed then I have 10MB down and it's a complete jerkathon!

Would you recommend reducing the bit rate for people with lower bandwidth, or does this seriously reduce quality?

aka Newbie Wan Kenewbie. "The young Newbie, is now a Padawon."

System
Mac Pro 2.8Gb quad core
8Gb RAM
1x 320Gb 7200 hardrive
1x 1Tb 7200 hardrive
Nvidia Geforce 8800 512mb Graphics card
1x 1Tb external WD 'My Book' eSata

Equipment
Panasonic AG-HVX 200
Firestore FS-100


Return to posts index


Craig Seeman
Re: HD compression query please help
on Feb 8, 2010 at 9:14:23 pm

[Roli Rivelino] "OK maybe it is connection speed then I have 10MB down and it's a complete jerkathon! "

That should be fine though. I assume you mean 10mbps (bits not bytes otherwise you'd by flying. I get about 3.3MB down more or less).

[Roli Rivelino] "Would you recommend reducing the bit rate for people with lower bandwidth, or does this seriously reduce quality? "

Vimeo has complete control of the final encode bit rate. They use around 2000kbps for 720p. They have an HD on/off overlay for viewers who need lower bandwidth.





Return to posts index

Daniel Low
Re: HD compression query please help
on Feb 8, 2010 at 10:35:06 pm

Yea, it's jerky for me too and I'm on a clean 50Mb/s connection, Mac Pro. It looks jerky even once it's all loaded. (located in UK)

Vimeo has possibly encoded it badly, try resubmitting it again.


__________________________________________________________________
Sent from my iPad Nano.


Return to posts index

Craig Seeman
Re: HD compression query please help
on Feb 8, 2010 at 11:24:58 pm

but looks great here in NYC.
That's why I'm wondering if it's another issue. I'd have Vimeo support staff check it.



Return to posts index


Daniel Low
Re: HD compression query please help
on Feb 8, 2010 at 11:50:26 pm

Hmmmm - if I switch to the HTML5 version it's much better, still getting a nasty stutter on the credits mind you.

__________________________________________________________________
Sent from my iPad Nano.


Return to posts index

Craig Seeman
Re: HD compression query please help
on Feb 9, 2010 at 12:05:16 am

So maybe there's Flash demons about.

I've got 10.0.42.34 installed. Here's check link.
http://kb2.adobe.com/cps/155/tn_15507.html
This link will work as well
http://www.adobe.com/software/flash/about/

It crashes periodically though but that's obvious when it does that.



Return to posts index

Roli Rivelino
Re: HD compression query please help
on Feb 9, 2010 at 12:57:51 am

Yeah, I've got the same version of flash as you Craig, I will check it out with Vimeo support, I would try resubmitting but it happened with the other HD videos I've got up there as well and I'm sure it's happened on someone else's HD movie I've watched on there. Strange that it seems to work well in the US and not the UK though.

Anyway any more thoughts welcome and thanks for your time on this guys.

UPDATE: I just did a trouble shoot on vimeo and found out it's their fault, guess I shouldn't have been so quick to blame myself and done that first :-)

Once again thanks guys

aka Newbie Wan Kenewbie. "The young Newbie, is now a Padawon."

System
Mac Pro 2.8Gb quad core
8Gb RAM
1x 320Gb 7200 hardrive
1x 1Tb 7200 hardrive
Nvidia Geforce 8800 512mb Graphics card
1x 1Tb external WD 'My Book' eSata

Equipment
Panasonic AG-HVX 200
Firestore FS-100


Return to posts index


Craig Seeman
Re: HD compression query please help
on Feb 9, 2010 at 1:11:34 am

[Roli Rivelino] "Strange that it seems to work well in the US and not the UK though. "
Maybe not so strange at all. I've seen what appears to be similar issues in the Vimeo forums. User sees dropped frames from one location but others don't in another location. This obviously isn't consistent though.

One thing to try is
http://www.speedtest.net/
Of course this only helps if you know where their servers are but I'm under the impression they may be in New York which may partially explain the issue.

Just guessing at this point but I've seen others with similar complaints.



Return to posts index

Daniel Low
Re: HD compression query please help
on Feb 9, 2010 at 6:29:10 am

[Craig Seeman] "One thing to try is
http://www.speedtest.net/ "


This is not an issue with the connection, it's a problem with the transcode.

The jerking/stuttering appears even after the video has downloaded



__________________________________________________________________
Sent from my iPad Nano.


Return to posts index

Craig Seeman
Re: HD compression query please help
on Feb 9, 2010 at 2:20:58 pm

Yet it's fluid to me. I see no dropped frames.

I was all over Vimeo back when that was the norm and found they were taking 29.97 material an transcoding to 24fps by dropping frames. They claimed that most people couldn't decode 29.97 so they had poor viewing experience. My response was that their horrible frame rate conversion ensured a poor viewing experience.

I am seeing smooth 30fps (or 29.97fps) playback with no motion issues. I suspect what's being viewed by those outside of the USA is not the same as what I see for reasons I obviously don't know. If the file you downloaded looks different then what I see then "something" is up. I see smooth playback and temporal resolution is one of my biggest peeves especially with Vimeo and I had been quite demonstrative there. I do not see that issue in this case as I observe the file.



Return to posts index


Craig Seeman
Re: HD compression query please help
on Feb 9, 2010 at 2:37:10 pm

The encode that I see today is DEFINITELY NOT what I saw yesterday. It seems every 4th or 5th frame is duplicated. It looks like a bad 23.98 to 30fps conversion.

Back when they went from 24 to 30 to 24 they did re-encodes. One day my 29.97 material looked good and then it would look bad. I had found out that after experimenting with 30fps and deciding that "people couldn't decode it" they re-encoded it back to 24fps.

While this file looks to be 30fps, it looks as if the source were either 23.98 or 25 with frames duplicated to playback at 30fps. This is not what I saw yesterday.



Return to posts index

Craig Seeman
Re: HD compression query please help
on Feb 9, 2010 at 3:26:36 pm

Please read these two threads on Vimeo.

http://vimeo.com/forums/topic:21784
Vimeo is doing re-encodes apparently. What I saw yesterday is not what you saw and not what I'm seeing today.

http://vimeo.com/forums/topic:18488
See recent posts lower down.
Note the posts from Staff that they say they see smooth video while viewer does not. In fact the whole 2nd half of the thread seems to involve issues there one day, gone the next, and in some cases Vimeo re-encoding to fix issues.





Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]