FORUMS: list search recent posts

After Effects 3D layers showing through randomly with depth of field blur

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Paul Roper
After Effects 3D layers showing through randomly with depth of field blur
on Dec 3, 2010 at 2:34:38 am

Hello.

I've created a comp with many nested 3D comps (a large cardboard box with 25 smaller boxes inside, one of which has 16 tiny boxes in it). I've keyframed a camera move around the main box and into the small box.

Despite all the boxes being well away from the outer faces of the containing box, they intermittently show through. I've isolated the problem to the depth of field blur - if I turn it off, the comp renders perfectly. But looks boring. I have some keyframes for the focal distance, aperture and blur level set - they're nothing outrageous.

The comp is 1280 x 720, 30fps.

Any thoughts or suggestions would be most welcome!

Cheers,
Paul


Return to posts index

Dave LaRonde
Re: After Effects 3D layers showing through randomly with depth of field blur
on Dec 3, 2010 at 2:49:51 am

I hope it REALLY isn't 30 fps, but 29.97. There's a big difference. You almost always want to set the frame rate at 29.97 unless there's an overwhelming reason not to do so. What's YOUR overwhelming reason?

The most common reason for depth of field weirdness is because the comp contains 2D layers among 3D layers. Check for that right away.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Paul Roper
Re: After Effects 3D layers showing through randomly with depth of field blur
on Dec 3, 2010 at 5:11:30 am

Thanks for your fast response, Dave!

I've chosen 30fps because isn't 29.97 an awkward number whose existence is a relic of the days when the invention of colour TV was The Next Big Thing? And the final piece will be only viewed on t'internet and won't go near a TV, neither black and white nor one of those new fangled colour things (I personally think colour TV is just a passing fad and will never catch on).

Anyway...enough of that foolishness and general rambling...is there any reason why After Effects would not like 30fps?

There aren't any 2D layers in the comp - nor in the nested comps. There is a 3D text layer in the (topmost) comp. My suspicion is that during the depth of field processing, After Effects kind of 'expands' each layer in all directions before applying the blur, which makes it poke through the other layers. Adjacent layers are all a good 5-10 pixels apart; there aren't any co-planar layers.


Return to posts index


Tudor "Ted" Jelescu
Re: After Effects 3D layers showing through randomly with depth of field blur
on Dec 3, 2010 at 7:12:58 am

Are you using OpenGL? If so, turn that off and try rendering again.

Tudor "Ted" Jelescu
Senior Compositor/VFX Artist


Return to posts index

Paul Roper
Re: After Effects 3D layers showing through randomly with depth of field blur
on Dec 3, 2010 at 5:20:53 pm

No, openGL's off.


Return to posts index

Dave LaRonde
Re: After Effects 3D layers showing through randomly with depth of field blur
on Dec 3, 2010 at 6:10:24 pm

[Paul Roper] "...I've chosen 30fps because isn't 29.97 an awkward number whose existence is a relic of the days when the invention of colour TV was The Next Big Thing?"

That's a misconception: 29.97 is very much alive, and will remain so for the foreseeable future. If you ever incorporate video into your comps, you can rest assured the camera will shoot at 29.97... and in the case of 720p, it may be twice that frame rate, 59.94.

If you enjoy extra work for the sake of a nice, round number, stick with comps at 30fps. If you like to keep things simple, go with the flow and make your comps 29.97.



[Paul Roper] "...And the final piece will be only viewed on t'internet and won't go near a TV..."

Considering internet video is in almost all cases frame rate agnostic, it shouldn't be a concern whether it's 29.97.


I wish I had an answer to your far more vexing problem of depth of field. All I have to offer are standard causes for weirdness:


Once you overcome those common hurdles, things might get a lot better.

Oops! I failed to mention that simply turning off one's computer is also theraputic for AE. If you like to keep your machine on, give it a shot. That's REALLY simple.

By tending to the simple stuff, it's easier to make a diagnosis if the problem should persist.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index


Paul Roper
Re: After Effects 3D layers showing through randomly with depth of field blur
on Dec 3, 2010 at 7:06:29 pm

Thanks, Dave for those suggestions...but I still have the same problems. I'm using AE 9.0.3.8 (CS4). As far as I can tell, it's the latest version (for some reason "Update" is greyed out in the help menu). I've tried turning computer off and on, and also tried rendering it on a completely different Mac that I've got set up as a render machine. I'm running OS 10.6.4 on my "main" Mac, and 10.5.8 on the render machine.

One more (probably important) point is that the "anomalies" DO show up when I'm looking at the composition view (before I've rendered it). Strangely, the process goes like this:

1. depth of field is ON, the still frame shows 3D planes showing through where they shouldn't.

2. I turn off depth of field on the camera controls; the weirdness goes away and the frame looks perfect.

3. I turn DOF back on, my background appears nice and blurry, but the progress bar at the bottom of the screen is still frantically processing...then the weirdness appears. The weirdness is only in the areas not blurred by the DOF.

I think I'll just have to live with a boring, non-depth-of-field-loveliness version.

Regarding the 29.97fps thing - there's no shot footage in the project - just a few photoshop files (brought in as footage, not comps). The entire 'collected' project is only about 6MB.


Return to posts index

Paul Roper
Re: After Effects 3D layers showing through randomly with depth of field blur
on Dec 9, 2010 at 6:40:33 am

...I just upgraded to After Effects CS5 (with all the updates)...exactly the same problem.

Never mind!


Return to posts index

Jiri Fiala
Re: After Effects 3D layers showing through randomly with depth of field blur
on Oct 16, 2012 at 6:33:39 pm

I know this is old thread, but I've come across same exact problem and see no solution...


Return to posts index


Paul Roper
Re: After Effects 3D layers showing through randomly with depth of field blur
on Oct 23, 2012 at 7:42:36 pm

I can't really remember but I think I may have fixed it by increasing the 'Samples per frame' and 'Adaptive Sample Limit' settings in the comp settings (select your comp and hit command-K / ctrl-K and click no the 'Advanced' tab). Maybe try increasing it to 32-bit in the project settings - that can improve the transition between on-blurred and blurred areas when using depth of field.

I've just tried to replicate it in CS6 (11.0.2.11) but can't get it to create the weirdness. I don't have the old project to hand, but I created something similar (boxes in a box with depth of field on). And I used the 'classic' renderer, not the flashy new Raytrace one.

- Paul


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]