FORUMS: list search recent posts

AE alpha channel problem

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Cory Reeder
AE alpha channel problem
on Aug 18, 2010 at 3:26:21 pm

I'm working in AE CS3. I have a comp that is HD 1080 24fps. And I have approx. 20 pictures, 30 optical flares and 10 titles all flying three dimensionally using the sure target plug in.

I originally created the comp without the flares on my Power Mag G5. When I did a pre-render I could then drop the new file into a new comp and add background graphics. My point being that the alpha channel worked and all things black became transparent.

Now that I have switched the project over to my Mac Pro (so I could use the video co-pilot Optical Flare plug in) when I try to pre-render I A: get a saved file in my project folder & B: the alpha channel doesn't work when I put the pre-rendered file into a new comp.

I've tried switching the mode for the pre-rendered file in the new comp, but it doesn't give the correct effect. I've tried comparing the preferences between my two machines and they appear to be the same.

I'm what I would call an advanced newbie in AE and can't help but feel I'm missing something simple here. Please help. Thank you.


Return to posts index

Dave LaRonde
Re: AE alpha channel problem
on Aug 18, 2010 at 3:39:03 pm

The fix should be easy enough: highlight the clip in the project window, and go to the Interpret Footage settings. Set the Alpha Channel to either Straight or Premultiplied, whichever kind you made originally. Done.

If there's really an alpha channel there, you'll be good to go. If it's still black, you didn't make the alpha channel properly in the first place.

And if you DO get transparency, it raises a disturbing question: why didn't AE read it in the first place?

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Cory Reeder
Re: AE alpha channel problem
on Aug 18, 2010 at 3:55:38 pm

Dave,

I tried what you suggested checking the interpret footage settings set on pre-manipulated (which was what it was already set on) and on straight. Neither one allowed the black/empty/Alpha sections of the video to become transparent.

I may have pre-rendered it incorrectly, but as I said, to the best of my knowledge I'm doing just as I did on my Power PC but getting a different result.

Any suggestions on what I should look for on my output settings and I'll try to do another version.

Thank you,
Cory


Return to posts index


Cory Reeder
Re: AE alpha channel problem
on Aug 18, 2010 at 4:34:21 pm

Dave,

I think I may have found what the problem is. I went into the Optical Flares plug in and found that the render mode on all of them are set to black - so I've done a 1 second test render and so far it seems to work properly now that I have changed their render mode to transparent.

There is still some black outlining around the flares themselves but maybe that is because of the screen mode I have chosen for them. I'm going to put them on screen mode and see if that gives me a cleaner Key. Thanks for your help.


Return to posts index

Dave LaRonde
Re: AE alpha channel problem
on Aug 18, 2010 at 4:49:21 pm

You have to use a codec that supports alpha channels
You have to set it to RGB+Alpha
You have to set it to millions (or Trillions) of colors+
You have to pick Premultiplied or Straight
You have to double-check your comp to make sure there's actually transparency in it: just change the default background to the familiar Photoshop checkerboard pattern. The switch is at the bottom of the comp window.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]